Search found 11 matches

by rayvd
2009-12-17 00:29
Forum: FileZilla Client Support
Topic: ASN1 parser: Error in TAG
Replies: 2
Views: 3395

Re: ASN1 parser: Error in TAG

Actually, the following may have done the trick: $ openssl s_client -connect ftp.pp.xw.gm.com:21 -starttls ftp CONNECTED(00000003) 32061:error:0D0680A8:asn1 encoding routines:ASN1_CHECK_TLEN:wrong tag:tasn_dec.c:1316: 32061:error:0D06C03A:asn1 encoding routines:ASN1_D2I_EX_PRIMITIVE:nested asn1 erro...
by rayvd
2009-12-17 00:25
Forum: FileZilla Client Support
Topic: ASN1 parser: Error in TAG
Replies: 2
Views: 3395

ASN1 parser: Error in TAG

I'm getting the following error from GnuTLS when attempting to connect via Explicit TLS (AUTH TLS): GnuTLS error -73: ASN1 parser: Error in TAG. I get this error from lftp as well, so it's either an issue with GnuTLS or the certificate in use on this site. The site also supports Implicit TLS via por...
by rayvd
2008-07-30 16:48
Forum: FileZilla Client Support
Topic: Can't connect with TLS/SSL in version 3.1.0
Replies: 65
Views: 69886

Re: Can't connect with TLS/SSL in version 3.1.0

FYI, fix for ProFTPd has been committed to CVS. Also, since I (and perhaps others) use RHEL for this, built an RPM against the EPEL version (1.3.1) that includes this patch. You can snag it here or watch the RH bugzilla here.
by rayvd
2008-07-30 15:38
Forum: FileZilla Client Support
Topic: Can't connect with TLS/SSL in version 3.1.0
Replies: 65
Views: 69886

Re: Can't connect with TLS/SSL in version 3.1.0

ProFTPd bug opened. Jump on the CC or add your two cents to the discussion (especially if you're a developer).
by rayvd
2008-07-30 15:09
Forum: FileZilla Client Support
Topic: Can't connect with TLS/SSL in version 3.1.0
Replies: 65
Views: 69886

Re: Can't connect with TLS/SSL in version 3.1.0

The older clients are available for download on the Sourceforge download page. I am recommending 3.0.11.1 to users currently that require TLS/SSL.

3.0.11.1 here.
by rayvd
2008-07-30 14:13
Forum: FileZilla Client Support
Topic: Can't connect with TLS/SSL in version 3.1.0
Replies: 65
Views: 69886

Re: Can't connect with TLS/SSL in version 3.1.0

Yes, I think you developers need to take an active role petitioning server vendors (especially the OSS ones). Users pestering them with only a partial understanding of the techincal reasons only goes so far. The reality as mentioned already is that we can no longer recommend the latest versions of F...
by rayvd
2008-07-29 21:08
Forum: FileZilla Client Support
Topic: Can't connect with TLS/SSL in version 3.1.0
Replies: 65
Views: 69886

Re: Can't connect with TLS/SSL in version 3.1.0

Developers might be interested in this thread. It would be nice to get some cross-developer discussion going to avoid this not getting fixed if it should. :-)
by rayvd
2008-07-29 21:04
Forum: FileZilla Client Support
Topic: SSL woes with >= 3.1.0
Replies: 5
Views: 6154

Re: SSL woes with >= 3.1.0

Alright, duh, shoulda read down further.

Go ahead and lock this if ya like. Dupe of this thread.
by rayvd
2008-07-29 20:53
Forum: FileZilla Client Support
Topic: SSL woes with >= 3.1.0
Replies: 5
Views: 6154

Re: SSL woes with >= 3.1.0

I'll do some more reading.

I'm just worried this is going to devolve into a blame game between server people and the FileZilla client. ProFTPd for example feels they're following the spec, and I'm sure FileZilla had good reason for doing what its doing as well......
by rayvd
2008-07-29 20:34
Forum: FileZilla Client Support
Topic: SSL woes with >= 3.1.0
Replies: 5
Views: 6154

Re: SSL woes with >= 3.1.0

Debug level 4 output: Command: PASV Trace: CTlsSocket::OnRead() Trace: CFtpControlSocket::OnReceive() Response: 227 Entering Passive Mode (198,102,62,21,235,117). Trace: CFtpControlSocket::TransferParseResponse() Trace: code = 2 Trace: state = 2 Trace: CFtpControlSocket::SendNextCommand() Trace: CFt...
by rayvd
2008-07-29 20:24
Forum: FileZilla Client Support
Topic: SSL woes with >= 3.1.0
Replies: 5
Views: 6154

SSL woes with >= 3.1.0

Server is ProFTPd 1.3.1 -- everything worked perfectly with FileZilla 3.0.11.1. After upgrading however, when attempting to connect via Explicit TLS/SSL (same settings that worked in the previous version), the following error is observed preventing a directory listing: Error from 3.1.0 Command: PASV...