making sure your port is open to all external IP addresses

Come here to discuss FileZilla and FTP in general

Moderator: Project members

Message
Author
pythonprogram
503 Bad sequence of commands
Posts: 21
Joined: 2023-10-05 11:33

making sure your port is open to all external IP addresses

#1 Post by pythonprogram » 2023-12-11 13:19

I am trying to figure out how to make sure that my filezilla sever port is open to all external IP addresses. I have went to Filezilla, edit, settings, active mode, and unchecked the "Don't use external IP address on local connection." I also then put my external address in the "Use the following IP address" in the box under Active Mode (IPV4 address).

A company is trying to give me a file but they said that are having trouble. They are asking for me to confirm the protocol and that the port is open to all external IP addresses. I have given them my external IP address, my UserID, and my password in order to be able to log in and give me the folder/file that I need.

To find the protocol that I am using I went to File, Site Manager, and looked under General where it says SFTP-SSH File Transfer Protocol. Or, how would I know the exact protocol that I am using?

Some help would be greatly appreciated. Thank you

User avatar
botg
Site Admin
Posts: 35457
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse

Re: making sure your port is open to all external IP addresses

#2 Post by botg » 2023-12-11 14:32

FileZilla Server only supports plain FTP and FTP over TLS (FTPS).

SFTP is a feature reserved for FileZilla Pro Enterprise Server.

pythonprogram
503 Bad sequence of commands
Posts: 21
Joined: 2023-10-05 11:33

Re: making sure your port is open to all external IP addresses

#3 Post by pythonprogram » 2023-12-14 14:02

@botg

Thank you for the response/answer and I appreciate it.

How can I figure out if my port is open to all external IP addresses?

User avatar
botg
Site Admin
Posts: 35457
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse

Re: making sure your port is open to all external IP addresses

#4 Post by botg » 2023-12-14 15:39

Connect to all your external IP addresses over the Internet and see whether it works.

pythonprogram
503 Bad sequence of commands
Posts: 21
Joined: 2023-10-05 11:33

Re: making sure your port is open to all external IP addresses

#5 Post by pythonprogram » 2023-12-19 18:59

@botg

thanks for the response. I have tried to access my external IP address from a different computer (which I can access using my local IP address) but the connection is not working. I receive the following error message:

"FTP folder error.
Windows cannot access this folder. Make sure you typed the name correctly and that you have permission to access the folder.
Details:
A connection with the server could not be established."

This is the error message that I received. However, from that same computer I can access the folder/server from a different computer using my local IP address. I guess this is the issue the client is having trying to access my server with the external IP address that I had gave them

Please help and thank you

User avatar
botg
Site Admin
Posts: 35457
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse

Re: making sure your port is open to all external IP addresses

#6 Post by botg » 2023-12-19 21:30

Try a proper FTP client, don't use shitty Explorer.

pythonprogram
503 Bad sequence of commands
Posts: 21
Joined: 2023-10-05 11:33

Re: making sure your port is open to all external IP addresses

#7 Post by pythonprogram » 2023-12-20 20:12

The people trying to access the external IP address said that the port isn't open and that they tried from their home computer just to see if they could find it using an internet search and they couldn't find it. They said that I possibly may need to Whitelist my IP address because they said nothing is going through it. They said that possibly that my port forwarding settings may not allow inbound. How do I check this?

Thank you for your help

User avatar
boco
Contributor
Posts: 26877
Joined: 2006-05-01 03:28
Location: Germany

Re: making sure your port is open to all external IP addresses

#8 Post by boco » 2023-12-20 20:51

We have a test site where you can check if the server works.

https://ftptest.net
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Please do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

pythonprogram
503 Bad sequence of commands
Posts: 21
Joined: 2023-10-05 11:33

Re: making sure your port is open to all external IP addresses

#9 Post by pythonprogram » 2023-12-21 03:12

@boco

thanks for the response. When I use that link and put my external IP address in the Host Box I get the following response:

"Error: Could not resolve hostname: Name or service not known

Make sure to enter the correct server address
You can either enter fully qualified domain names or public IP addresses.
Obviously this script cannot connect to your server should you have entered a private IP address."

I am putting my correct external IP address in the Host box, my port is 21, and I put the correct username/password that is needed to access that folder (I can access it on my local network using my local IP address). Just not sure what is going on. I am sorry for the constant question. I am so new to this and I am trying to figure this out. I appreciate your help and time with me on this.

User avatar
botg
Site Admin
Posts: 35457
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse

Re: making sure your port is open to all external IP addresses

#10 Post by botg » 2023-12-21 08:53

If you get "Could not resolve hostname" you didn't enter an IP address.

User avatar
boco
Contributor
Posts: 26877
Joined: 2006-05-01 03:28
Location: Germany

Re: making sure your port is open to all external IP addresses

#11 Post by boco » 2023-12-21 11:56

IP addresses are a.b.c.d for IPv4 and aaaa:bbbb:cccc:dddd:eeee:ffff:gggg:hhhh for IPv6 (there can be fewer numbers, that's normal). Protocol identifiers (ftp:// or sftp:// etc.) are not part of the IP address.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Please do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

pythonprogram
503 Bad sequence of commands
Posts: 21
Joined: 2023-10-05 11:33

Re: making sure your port is open to all external IP addresses

#12 Post by pythonprogram » 2023-12-21 14:55

@boco and @botg

Thanks..I really appreciate the help. I was able to try the IPV4 and IPV6.

I received the following error message:

"Error: Connection attempt timed out

Timeouts are usually caused by some router and/or firewall that is interrupting the connection.
Try uninstalling all firewalls and plug your computer directly into your modem, thus bypassing the router."

I thought I did uninstall the firewall? Any idea on this? I'm sorry if I am asking ridiculous questions. I am a newbie and I am trying. This is just a part of computers I have no clue about. I've looked at the manual and watched YT videos.

pythonprogram
503 Bad sequence of commands
Posts: 21
Joined: 2023-10-05 11:33

Re: making sure your port is open to all external IP addresses

#13 Post by pythonprogram » 2023-12-21 15:12

I had already went to control panel-firewall settings-new rule- inbound rules- and put TCP and allowed access for port 20 and 21. Not sure why it still is blocking it.

User avatar
boco
Contributor
Posts: 26877
Joined: 2006-05-01 03:28
Location: Germany

Re: making sure your port is open to all external IP addresses

#14 Post by boco » 2023-12-21 21:36

I had already went to control panel-firewall settings-new rule- inbound rules- and put TCP and allowed access for port 20 and 21. Not sure why it still is blocking it.
20 isn't required. But what about the Passive data port range? Listings and transfers do not use port 21 but the range you configured as Passive range in the server. That Passive range has to be completely forwarded in the router, too, in addition to the listening port 21.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Please do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

pythonprogram
503 Bad sequence of commands
Posts: 21
Joined: 2023-10-05 11:33

Re: making sure your port is open to all external IP addresses

#15 Post by pythonprogram » 2023-12-22 12:34

@boco


Ok, so I think I understand now. For Filezilla Server, the port range is 49,152-65,534 (and the Use the default host for local connections box is checked). So, I guess I have to create a Port Forwarding Rule by logging into my router and creating it there. I do not think there is another way of doing it; am I correct? I tried going to the Defender's Firewall but I did not see an option there for the passive range.

Post Reply