Changing default editor in Flatpak Filezilla [solved]

Come here to discuss FileZilla and FTP in general

Moderator: Project members

Post Reply
Message
Author
MrMike
504 Command not implemented
Posts: 7
Joined: 2019-02-17 02:40
First name: Mike

Changing default editor in Flatpak Filezilla [solved]

#1 Post by MrMike » 2019-02-17 16:01

I'm running Linux Mint 19.1, using Filezilla 3.28.0 and my question is in regards to setting a default editor for text files in FIlezilla.
(The Filezilla "about" screen is included here in case it may help people figure out how to resolve this.)

Currently I have xed 2.02 sitting on the desktop and I managed to get it to be the default editor in Filezilla to use when I open a text file.

Xed is a little too limited for my use, so I installed Notepadqq via Flatpak (from the Mint Software Manager). It's also sitting on the desktop.

Try as I might, I can't get it to be the default editor for text files in Filezilla. Clicking on the Properties menu item, it shows me this:

/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=notepadqq --file-forwarding com.notepadqq.Notepadqq @@u %U @@

I've tried about a bazillion different ways to get Filezilla to use it, but Filezilla always complains that it can't find Notepadqq. The same kinds of settings that work to use xed as the default don't work for Notepadqq.

This is what works to use xed as the default editor in Filezilla:

htm "/usr/bin/xed"
txt "/usr/bin/xed"

How do I set Filezilla to use Notepadqq the default editor for text files? No matter what I enter, it pops up this error when I try to save the Filezilla settings:

Associated program not found:
/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=notepadqq --file-forwarding com.notepadqq.Notepadqq @@u %U @@

(I've tried countless variations of this but can't get any of them to work.)

What would be the command to enter into the Filezilla setup dialog?
Attachments
filezilla-1.png
filezilla-1.png (58.39 KiB) Viewed 2620 times
Last edited by MrMike on 2019-02-17 23:31, edited 2 times in total.

User avatar
boco
Contributor
Posts: 24783
Joined: 2006-05-01 03:28
Location: Germany

Re: Changing default editor in FIlezilla

#2 Post by boco » 2019-02-17 18:22

Sorry, we do only support the latest version from here.

Old versions are unsupported, and third party distributions (repository versions) need to be supported by their respective distributor.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

MrMike
504 Command not implemented
Posts: 7
Joined: 2019-02-17 02:40
First name: Mike

Re: Changing default editor in FIlezilla

#3 Post by MrMike » 2019-02-17 19:55

boco wrote:
2019-02-17 18:22
Sorry, we do only support the latest version from here.
Old versions are unsupported, and third party distributions (repository versions) need to be supported by their respective distributor.
Thank you, boco.

1) I went to download it directly from here but I don't see anything for Mint or Ubuntu...is there one? Can I install the Debian version on Mint?

2) Has the file association setup in Filezilla changed significantly from 3.28 to 3.40? I'd be more than willing to try what worked on earlier versions if it's mostly the same as previous versions. I searched the forum looking for anything similar but found nothing and the Mint forums are unresponsive to this.

Pretend for a moment that I have the most current version- what file association line would I use in that case?

User avatar
boco
Contributor
Posts: 24783
Joined: 2006-05-01 03:28
Location: Germany

Re: Changing default editor in FIlezilla

#4 Post by boco » 2019-02-17 20:45

filezilla_3.40_linux_on_tessa_cinnamon.jpg
filezilla_3.40_linux_on_tessa_cinnamon.jpg (54.28 KiB) Viewed 2598 times
1) The Linux download from here will run on Linux Mint 19.1 (Tessa), but it ain't fun getting it to run. It is meant for Debian 9 and compatible. You could always use the source code and compile your own, however.

2) No idea, I'm not a Linux guy, sorry. Non-flatpack version of your editor might work much better.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

MrMike
504 Command not implemented
Posts: 7
Joined: 2019-02-17 02:40
First name: Mike

Re: Changing default editor in FIlezilla

#5 Post by MrMike » 2019-02-17 21:35

boco wrote:
2019-02-17 20:45
1) The Linux download from here will run on Linux Mint 19.1 (Tessa), but it ain't fun getting it to run.
I'm fairly new to Linux, so I don't know how much more frustration I can use at this time. It's been a slog switching from Windows to Linux and the last thing I need is something that "ain't fun" lol.

Building from source is a little beyond my skillset at this point.

It's too bad- this is literally the last thing I need to configure in Fakezilla to make it my standard, use-every-day tool, but it's a major part of it. :(

Thank you, I guess I'll go look and see what else is out there in terms of file xfer apps for Mint.

User avatar
botg
Site Admin
Posts: 32470
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Changing default editor in FIlezilla

#6 Post by botg » 2019-02-17 22:42

I happen to know that the file association code hasn't been changed in a while (I know, it should be changed, code is dated, blame General Lazyness). Does the program entered really exist at the entered path, or is there merely a rabbit hole of unknown depth at that path one might need to symbolically follow?

MrMike
504 Command not implemented
Posts: 7
Joined: 2019-02-17 02:40
First name: Mike

Re: Changing default editor in FIlezilla

#7 Post by MrMike » 2019-02-17 23:19

botg wrote:
2019-02-17 22:42
I happen to know that the file association code hasn't been changed in a while (I know, it should be changed, code is dated, blame General Lazyness). Does the program entered really exist at the entered path, or is there merely a rabbit hole of unknown depth at that path one might need to symbolically follow?
Well, judging by 'command' under 'properties', probably more of the latter:

/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=notepadqq --file-forwarding com.notepadqq.Notepadqq @@u %U @@

It's running flatpak and giving flatpak a command to run notepadqq. There's nothing that explicitly specifies where notepadqq is, so flatpak must "know" or be able to find it. Maybe it can, lol, but I've had no luck.

I searched for notepadqq and found ~100+ entries. I tried some of the likely ones as the path/program but none of them were accepted by Filezilla.

I'd say something must be related to flatpak; it's a sandbox that uses comtainers and I don't know if the containers themselves are launchable, but either way I should be able to enter a command path/program that would work.

It runs just fine from the desktop, I would think it could run from anywhere given the right command.

MrMike
504 Command not implemented
Posts: 7
Joined: 2019-02-17 02:40
First name: Mike

Re: Changing default editor in Flatpak Filezilla

#8 Post by MrMike » 2019-02-17 23:29

Okay, here's what finally worked (example for .htm files):

htm "/var/lib/flatpak/exports/bin/com.notepadqq.Notepadqq"



Some keywords for anyone who may be searching on this exact same issue:

filezilla command path flatpak notepadqq settings filetype associations custom filetype

User avatar
boco
Contributor
Posts: 24783
Joined: 2006-05-01 03:28
Location: Germany

Re: Changing default editor in Flatpak Filezilla [solved]

#9 Post by boco » 2019-02-18 09:52

"Ain't fun" = Strangely, you cannot run the executable directly from the file manager or start menu shortcut. You need to run it from the Terminal (I'm using a little shell script on the Desktop to run it). It worked in 19.0, but now fails. It's as if the executable format isn't recognized correctly.

Just for information.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

MrMike
504 Command not implemented
Posts: 7
Joined: 2019-02-17 02:40
First name: Mike

Re: Changing default editor in Flatpak Filezilla [solved]

#10 Post by MrMike » 2019-06-20 16:18

I upgraded to the latest flatpak of Filezilla (3.42.1) and no matter what I do, I can't seem to set an editor, default or otherwise.

I also can't seem to set any custom filetype associations. The filetype associations that worked on the previous version I had don't work, and now just return an error message. For example, this was a previous (working) file association:

htm "/usr/bin/medit"

When I use that and try to save the settings, Filezilla pops up an error message:

Code: Select all

Failed to validate settings, associated program not found /usr/bin/medit
I had exported my filezilla settings, then installed the flatpak version from Software Manager, and then imported the settings. Selecting a site works and filezilla connects, but I can no longer edit anything.

Using the option to use the system's default editor produces this error when I right click on a file and select 'edit':

Code: Select all

An assertion failed!

./src/common/filefn.cpp(1610): assert "!szFile.empty()" failed in wxFindFileInPath(): empty file name in wxFindFileInPath
Nothing I've tried has worked. I'm at a loss as to what to do next.

User avatar
botg
Site Admin
Posts: 32470
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Changing default editor in Flatpak Filezilla [solved]

#11 Post by botg » 2019-06-20 16:22

We cannot support exotic non-default distributions of FileZilla. You need to contact whoever created the flatpak package.

MrMike
504 Command not implemented
Posts: 7
Joined: 2019-02-17 02:40
First name: Mike

Re: Changing default editor in Flatpak Filezilla [solved]

#12 Post by MrMike » 2019-06-21 00:11

Okay, since I'm running Mint (basically Ubuntu) I downloaded the source.

I'll have to admit, I don't know anything about building from source (https://filezilla-project.org/download.php?show_all=1). I've looked at a lot of docs but I'm still pretty fuzzy on what to do.

Soooo....I stuck the folder on my desktop, opened a terminal and went to the folder.

I ran "./configure" and got this:

Code: Select all

./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether the C++ compiler works... no
configure: error: in `/home/<my username>/Desktop/filezilla-3.42.1':
configure: error: C++ compiler cannot create executables
See `config.log' for more details
The config.log has this in it:

Code: Select all

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by FileZilla configure 3.42.1, which was
generated by GNU Autoconf 2.69.  Invocation command line was

  $ ./configure 

## --------- ##
## Platform. ##
## --------- ##

hostname = MintBox
uname -m = x86_64
uname -r = 4.15.0-50-generic
uname -s = Linux
uname -v = #54-Ubuntu SMP Mon May 6 18:46:08 UTC 2019

/usr/bin/uname -p = unknown
/bin/uname -X     = unknown

/bin/arch              = unknown
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin
PATH: /usr/games
PATH: /usr/local/games


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2782: checking for a BSD-compatible install
configure:2850: result: /usr/bin/install -c
configure:2861: checking whether build environment is sane
configure:2916: result: yes
configure:3067: checking for a thread-safe mkdir -p
configure:3106: result: /bin/mkdir -p
configure:3113: checking for gawk
configure:3129: found /usr/bin/gawk
configure:3140: result: gawk
configure:3151: checking whether make sets $(MAKE)
configure:3173: result: yes
configure:3202: checking whether make supports nested variables
configure:3219: result: yes
configure:3350: checking build system type
configure:3364: result: x86_64-pc-linux-gnu
configure:3384: checking host system type
configure:3397: result: x86_64-pc-linux-gnu
configure:3476: checking for g++
configure:3506: result: no
configure:3476: checking for c++
configure:3506: result: no
configure:3476: checking for gpp
configure:3506: result: no
configure:3476: checking for aCC
configure:3506: result: no
configure:3476: checking for CC
configure:3506: result: no
configure:3476: checking for cxx
configure:3506: result: no
configure:3476: checking for cc++
configure:3506: result: no
configure:3476: checking for cl.exe
configure:3506: result: no
configure:3476: checking for FCC
configure:3506: result: no
configure:3476: checking for KCC
configure:3506: result: no
configure:3476: checking for RCC
configure:3506: result: no
configure:3476: checking for xlC_r
configure:3506: result: no
configure:3476: checking for xlC
configure:3506: result: no
configure:3530: checking for C++ compiler version
configure:3539: g++ --version >&5
./configure: line 3541: g++: command not found
configure:3550: $? = 127
configure:3539: g++ -v >&5
./configure: line 3541: g++: command not found
configure:3550: $? = 127
configure:3539: g++ -V >&5
./configure: line 3541: g++: command not found
configure:3550: $? = 127
configure:3539: g++ -qversion >&5
./configure: line 3541: g++: command not found
configure:3550: $? = 127
configure:3570: checking whether the C++ compiler works
configure:3592: g++    conftest.cpp  >&5
./configure: line 3594: g++: command not found
configure:3596: $? = 127
configure:3634: result: no
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "FileZilla"
| #define PACKAGE_TARNAME "filezilla"
| #define PACKAGE_VERSION "3.42.1"
| #define PACKAGE_STRING "FileZilla 3.42.1"
| #define PACKAGE_BUGREPORT "tim.kosse@filezilla-project.org"
| #define PACKAGE_URL "https://filezilla-project.org/"
| #define PACKAGE "filezilla"
| #define VERSION "3.42.1"
| /* end confdefs.h.  */
| 
| int
| main ()
| {
| 
|   ;
|   return 0;
| }
configure:3639: error: in `/home/<my username>/Desktop/filezilla-3.42.1':
configure:3641: error: C++ compiler cannot create executables
See `config.log' for more details

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=x86_64-pc-linux-gnu
ac_cv_env_CCC_set=
ac_cv_env_CCC_value=
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPPUNIT_CFLAGS_set=
ac_cv_env_CPPUNIT_CFLAGS_value=
ac_cv_env_CPPUNIT_LIBS_set=
ac_cv_env_CPPUNIT_LIBS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_CXXCPP_set=
ac_cv_env_CXXCPP_value=
ac_cv_env_CXXFLAGS_set=
ac_cv_env_CXXFLAGS_value=
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_HOGWEED_CFLAGS_set=
ac_cv_env_HOGWEED_CFLAGS_value=
ac_cv_env_HOGWEED_LIBS_set=
ac_cv_env_HOGWEED_LIBS_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBDBUS_CFLAGS_set=
ac_cv_env_LIBDBUS_CFLAGS_value=
ac_cv_env_LIBDBUS_LIBS_set=
ac_cv_env_LIBDBUS_LIBS_value=
ac_cv_env_LIBFILEZILLA_CFLAGS_set=
ac_cv_env_LIBFILEZILLA_CFLAGS_value=
ac_cv_env_LIBFILEZILLA_LIBS_set=
ac_cv_env_LIBFILEZILLA_LIBS_value=
ac_cv_env_LIBGNUTLS_CFLAGS_set=
ac_cv_env_LIBGNUTLS_CFLAGS_value=
ac_cv_env_LIBGNUTLS_LIBS_set=
ac_cv_env_LIBGNUTLS_LIBS_value=
ac_cv_env_LIBGTK_CFLAGS_set=
ac_cv_env_LIBGTK_CFLAGS_value=
ac_cv_env_LIBGTK_LIBS_set=
ac_cv_env_LIBGTK_LIBS_value=
ac_cv_env_LIBSQLITE3_CFLAGS_set=
ac_cv_env_LIBSQLITE3_CFLAGS_value=
ac_cv_env_LIBSQLITE3_LIBS_set=
ac_cv_env_LIBSQLITE3_LIBS_value=
ac_cv_env_LIBSTORJ_CFLAGS_set=
ac_cv_env_LIBSTORJ_CFLAGS_value=
ac_cv_env_LIBSTORJ_LIBS_set=
ac_cv_env_LIBSTORJ_LIBS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_LT_SYS_LIBRARY_PATH_set=
ac_cv_env_LT_SYS_LIBRARY_PATH_value=
ac_cv_env_NETTLE_CFLAGS_set=
ac_cv_env_NETTLE_CFLAGS_value=
ac_cv_env_NETTLE_LIBS_set=
ac_cv_env_NETTLE_LIBS_value=
ac_cv_env_OBJCXXFLAGS_set=
ac_cv_env_OBJCXXFLAGS_value=
ac_cv_env_OBJCXX_set=
ac_cv_env_OBJCXX_value=
ac_cv_env_PKG_CONFIG_LIBDIR_set=
ac_cv_env_PKG_CONFIG_LIBDIR_value=
ac_cv_env_PKG_CONFIG_PATH_set=
ac_cv_env_PKG_CONFIG_PATH_value=
ac_cv_env_PKG_CONFIG_set=
ac_cv_env_PKG_CONFIG_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=x86_64-pc-linux-gnu
ac_cv_path_install='/usr/bin/install -c'
ac_cv_path_mkdir=/bin/mkdir
ac_cv_prog_AWK=gawk
ac_cv_prog_make_make_set=yes
am_cv_make_support_nested_variables=yes

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /home/<my username>/Desktop/filezilla-3.42.1/config/missing aclocal-1.15'
AMDEPBACKSLASH=''
AMDEP_FALSE=''
AMDEP_TRUE=''
AMTAR='$${TAR-tar}'
AM_BACKSLASH='\'
AM_DEFAULT_V='$(AM_DEFAULT_VERBOSITY)'
AM_DEFAULT_VERBOSITY='1'
AM_V='$(V)'
AR=''
AUTOCONF='${SHELL} /home/<my username>/Desktop/filezilla-3.42.1/config/missing autoconf'
AUTOHEADER='${SHELL} /home/<my username>/Desktop/filezilla-3.42.1/config/missing autoheader'
AUTOMAKE='${SHELL} /home/<my username>/Desktop/filezilla-3.42.1/config/missing automake-1.15'
AWK='gawk'
CC=''
CCDEPMODE=''
CFBUNDLEIDSUFFIX=''
CFLAGS=''
CPP=''
CPPFLAGS=''
CPPUNIT_CFLAGS=''
CPPUNIT_LIBS=''
CXX='g++'
CXXCPP=''
CXXDEPMODE=''
CXXFLAGS=''
CYGPATH_W='echo'
DEFS=''
DEPDIR=''
DLLTOOL=''
DSYMUTIL=''
DUMPBIN=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
ENABLE_PRECOMP_FALSE=''
ENABLE_PRECOMP_TRUE=''
ENABLE_STORJ_FALSE=''
ENABLE_STORJ_TRUE=''
EXEEXT=''
FGREP=''
FILEZILLA_LINGUAS=''
FILEZILLA_LINGUAS_MO=''
FILEZILLA_LINGUAS_PO=''
FILEZILLA_LINGUAS_PO_NEW=''
GREP=''
HAS_CPPUNIT_FALSE=''
HAS_CPPUNIT_TRUE=''
HAVE_CXX14=''
HAVE_DBUS_FALSE=''
HAVE_DBUS_TRUE=''
HAVE_LIBPUGIXML_FALSE=''
HAVE_LIBPUGIXML_TRUE=''
HOGWEED_CFLAGS=''
HOGWEED_LIBS=''
IDN_LIB=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='$(install_sh) -c -s'
LD=''
LDFLAGS=''
LIBDBUS_CFLAGS=''
LIBDBUS_LIBS=''
LIBFILEZILLA_CFLAGS=''
LIBFILEZILLA_LIBS=''
LIBGNUTLS_CFLAGS=''
LIBGNUTLS_LIBS=''
LIBGTK_CFLAGS=''
LIBGTK_LIBS=''
LIBOBJS=''
LIBS=''
LIBSQLITE3_CFLAGS=''
LIBSQLITE3_LIBS=''
LIBSTORJ_CFLAGS=''
LIBSTORJ_LIBS=''
LIBTOOL=''
LIPO=''
LN_S=''
LOCALES_FALSE=''
LOCALES_ONLY_FALSE=''
LOCALES_ONLY_TRUE=''
LOCALES_TRUE=''
LTLIBOBJS=''
LT_SYS_LIBRARY_PATH=''
MACAPPBUNDLE_FALSE=''
MACAPPBUNDLE_TRUE=''
MAKEINFO='${SHELL} /home/<my username>/Desktop/filezilla-3.42.1/config/missing makeinfo'
MAKENSISSCRIPT_FALSE=''
MAKENSISSCRIPT_TRUE=''
MANIFEST_TOOL=''
MINGW_FALSE=''
MINGW_TRUE=''
MKDIR_P='/bin/mkdir -p'
NETTLE_CFLAGS=''
NETTLE_LIBS=''
NM=''
NMEDIT=''
NSIS_64BIT=''
OBJCXX=''
OBJCXXDEPMODE=''
OBJCXXFLAGS=''
OBJDUMP=''
OBJEXT=''
OTOOL64=''
OTOOL=''
PACKAGE='filezilla'
PACKAGE_BUGREPORT='tim.kosse@filezilla-project.org'
PACKAGE_NAME='FileZilla'
PACKAGE_STRING='FileZilla 3.42.1'
PACKAGE_TARNAME='filezilla'
PACKAGE_URL='https://filezilla-project.org/'
PACKAGE_VERSION='3.42.1'
PACKAGE_VERSION_MAJOR=''
PACKAGE_VERSION_MICRO=''
PACKAGE_VERSION_MINOR=''
PACKAGE_VERSION_NANO=''
PATH_SEPARATOR=':'
PKG_CONFIG=''
PKG_CONFIG_LIBDIR=''
PKG_CONFIG_PATH=''
PUGIXML_LIBS=''
RANLIB=''
SED=''
SET_MAKE=''
SFTP_MINGW_FALSE=''
SFTP_MINGW_TRUE=''
SFTP_UNIX_FALSE=''
SFTP_UNIX_TRUE=''
SHELL='/bin/bash'
STRIP=''
USE_MAC_SANDBOX_FALSE=''
USE_MAC_SANDBOX_TRUE=''
USE_RESOURCEFILE_FALSE=''
USE_RESOURCEFILE_TRUE=''
VERSION='3.42.1'
WINDRES=''
WINDRESFLAGS=''
WXRC=''
WX_CFLAGS=''
WX_CFLAGS_ONLY=''
WX_CONFIG_PATH=''
WX_CONFIG_WITH_ARGS=''
WX_CPPFLAGS=''
WX_CXXFLAGS=''
WX_CXXFLAGS_ONLY=''
WX_LIBS=''
WX_LIBS_STATIC=''
WX_RESCOMP=''
WX_VERSION=''
WX_VERSION_MAJOR=''
WX_VERSION_MICRO=''
WX_VERSION_MINOR=''
ac_ct_AR=''
ac_ct_CC=''
ac_ct_CXX=''
ac_ct_DUMPBIN=''
ac_ct_OBJCXX=''
am__EXEEXT_FALSE=''
am__EXEEXT_TRUE=''
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__fastdepCXX_FALSE=''
am__fastdepCXX_TRUE=''
am__fastdepOBJCXX_FALSE=''
am__fastdepOBJCXX_TRUE=''
am__include=''
am__isrc=''
am__leading_dot='.'
am__nodep=''
am__quote=''
am__tar='$${TAR-tar} chof - "$$tardir"'
am__untar='$${TAR-tar} xf -'
bindir='${exec_prefix}/bin'
build='x86_64-pc-linux-gnu'
build_alias=''
build_cpu='x86_64'
build_os='linux-gnu'
build_vendor='pc'
datadir='${datarootdir}'
datarootdir='${prefix}/share'
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
dvidir='${docdir}'
exec_prefix='NONE'
host='x86_64-pc-linux-gnu'
host_alias=''
host_cpu='x86_64'
host_os='linux-gnu'
host_vendor='pc'
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_sh='${SHELL} /home/<my username>/Desktop/filezilla-3.42.1/config/install-sh'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
mandir='${datarootdir}/man'
mkdir_p='$(MKDIR_P)'
msgfmt=''
msgmerge=''
oldincludedir='/usr/include'
pdfdir='${docdir}'
prefix='NONE'
program_transform_name='s,x,x,'
psdir='${docdir}'
runstatedir='${localstatedir}/run'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
subdirs=''
sysconfdir='${prefix}/etc'
target_alias=''
xdgopen=''
xgettext=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

/* confdefs.h */
#define PACKAGE_NAME "FileZilla"
#define PACKAGE_TARNAME "filezilla"
#define PACKAGE_VERSION "3.42.1"
#define PACKAGE_STRING "FileZilla 3.42.1"
#define PACKAGE_BUGREPORT "tim.kosse@filezilla-project.org"
#define PACKAGE_URL "https://filezilla-project.org/"
#define PACKAGE "filezilla"
#define VERSION "3.42.1"

configure: exit 77
I'm not sure what to make of the error messages, and I'd welcome any suggestions or a few hints.

User avatar
boco
Contributor
Posts: 24783
Joined: 2006-05-01 03:28
Location: Germany

Re: Changing default editor in Flatpak Filezilla [solved]

#13 Post by boco » 2019-06-21 02:27

According to the log, it looks like the scripts doesn't find any compiler to use.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

Post Reply