Version 3.46.3 Does Not Support OS X El Capitan Version 10.11.6

Come here to discuss FileZilla and FTP in general

Moderator: Project members

Post Reply
Message
Author
billyfox@soundscapes.us
500 Command not understood
Posts: 1
Joined: 2019-12-27 13:09
First name: Bill
Last name: Fox

Version 3.46.3 Does Not Support OS X El Capitan Version 10.11.6

#1 Post by billyfox@soundscapes.us » 2019-12-27 13:37

Greetings,

Today FileZilla offered an update which, as usual, I blindly did. Because of my practice of moving the new application to the Applications folder and selecting to replace the old file, I found that I had installed a version that requires a much newer version of OS X than the one I have.*

To get myself out of hot water, I went into my Time Machine backups and brought back the previous version of FileZilla (3.46.0). In preferences, I turned off the search for newer versions. I'm safe, for now.

Please allow my cautionary tale to inspire you to always keep the most recent version of a working app on hand when offered to update. When FileZilla offered the update, either I missed seeing a warning or none was offered that my OS was no longer supported. My first reaction was to download the previous version but either it isn't available for download of I couldn't easily find it. My backup saved my bacon but not everyone has access to a backup routine as good as Time Machine.

To the developers: Please think about updates that disallow the use by an older OS. (1) A significantly visible warning would be appreciated to allow users to decide not to install the new update. (2) An easy to find previous version of FileZilla should always be readily downloadable. (3) Thank you for FileZilla. It's great!

* I have a late 2009 iMac that still works great. It runs OS X El Capitan Version 10.11.6 and cannot be updated to anything newer. When I get rich or this iMac fails, then I will get a new computer that will be able to run the latest version of FileZilla.

User avatar
boco
Contributor
Posts: 24960
Joined: 2006-05-01 03:28
Location: Germany

Re: Version 3.46.3 Does Not Support OS X El Capitan Version 10.11.6

#2 Post by boco » 2019-12-27 22:49

No idea if the FileZilla MacOS client returns the complete MacOS version string to the update server (I don't have any Apple hardware). If it does, then FileZilla should simply not offer updates that would deactivate the client due to unsupported OS, displaying a warning instead.

For the free FileZilla, the download archive is at https://download.filezilla-project.org (no support is provided for old versions).
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

User avatar
schroef
504 Command not implemented
Posts: 8
Joined: 2017-08-04 16:21
First name: Rombout
Last name: Versluijs

Re: Version 3.46.3 Does Not Support OS X El Capitan Version 10.11.6

#3 Post by schroef » 2020-02-28 23:04

Why isnt it stated in the update history that minimum requirements has now jumped from 10.11.6 to 10.13.2? Prior it was stated in updates.
That is a massive jump! in 2019 it was stated that it was jumped to 10.11.6 as a minimum. Why then jump suddenly to 10.13.2?

See update from 2019
3.43.0-rc1 (2019-06-19)
Bugfixes and minor changes:
macOS: Minimum required macOS version has been increased to 10.11 (El Capitan)
Nowhere in this history does the requirements now state 10.13.2, only on the download page
https://filezilla-project.org/versions.php

TheBUZZ
500 Command not understood
Posts: 2
Joined: 2020-02-28 12:31
First name: Sharon
Last name: Alboni

Version 3.46.3 Does Not Support OS X El Capitan Version 10.11.6

#4 Post by TheBUZZ » 2020-02-29 11:28

Did you find the previous version as I have done exactly the same?

Sharon

User avatar
botg
Site Admin
Posts: 32700
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Version 3.46.3 Does Not Support OS X El Capitan Version 10.11.6

#5 Post by botg » 2020-02-29 18:11

You need to update to the most recent version.

Post Reply