Page 1 of 1

You do not have permission to list this directory

Posted: 2020-01-13 00:18
by wotnow
Hi updated to Mac Catalina yesterday and ran Filezilla this morning and it asked me about letting filezilla have permission to all my directories and I paranoid like said no .. damn .. now I cant see my local files on the left panel of Filezilla interface. How do I give Filezilla permission to access my local folders. Cant seem to find it anywhere in the menus?

Thanks :)

Re: You do not have permission to list this directory

Posted: 2020-01-13 08:14
by botg
Open your system settings, somewhere there is a page where you can grant programs permission to access various locations.

Re: You do not have permission to list this directory

Posted: 2020-01-14 02:05
by wotnow
Thanks so much .. I was looking within Filezilla. As you suggested it was in my OS. New security with Mac Catalina OS. This page walked me through in 5 secs.

Code: Select all

https://nektony.com/duplicate-finder-free/folders-permission#folders

Re: You do not have permission to list this directory

Posted: 2020-01-14 17:12
by cbitterfield
I am having a similar issue but the posted solution does not work.

How do I enable external (removable volumes)? My other apps can see the directory, Filezilla can not. (Pro Version).

It worked before the upgrade to Catalina. I can't find any setting in security that adds a directory list to the permissions in security.

Re: You do not have permission to list this directory

Posted: 2020-01-14 18:20
by boco
Do you have the Store version? There should be an option for granting directory permissions under the Edit menu.

Re: You do not have permission to list this directory

Posted: 2020-01-31 06:14
by CynthiaBlue44
I thought I'd found a solution to my problem with the error message "you do not have permission to list this directory". My web site files were held in ../John Wells Murals/johnwellsmurals. It occurred to me that the software may not like the fact that I had spaces between the words of my directory, i.e. John Wells Murals. So ... I changed the Directory name to ../John-Wells-Murals/johnwellsmurals and it listed the files, using dashes instead of spaces between the words, and suddenly the files were available. I'm not sure if this will work for anyone else, but it worked for me.

However, after I returned to the software to 'put my feet up" and pat my self on the head. I got the "dreaded" message again. Not good. It's strange because I connected to my other website easily, but johnwellsmurals has me stumped.

Re: You do not have permission to list this directory

Posted: 2020-03-27 18:07
by michael.glenn.williams
Hey All, I'm getting the same error on pretty much all folders, including 777 folders, and my home directory.
I'm on Mojave, macbook pro. On Mojave, there is no Files and Folders item on the left in Security and Privacy.

Re: You do not have permission to list this directory

Posted: 2020-04-24 16:50
by donnamarie.duncan
@cynthiablue44

Thanks for this post, this is the first time something has worked without issues.