Page 1 of 1

Login problems

Posted: 2020-08-20 10:06
by jdegenfellner
Hi, I am new here!

Hope you guys can help me :)

I've tried to create an ssh-key for login.

used the command

Code: Select all

 ssh-keygen -t rsa -b 2048 -f my-ssh-key 
on the server

which created the public key and the private key my-ssh-key.
I've put the public key to into the directory ~/.ssh/authorized_keys and tried to use the private key in the FileZilla client to login with a key file.

I get the error message:
Fehler: Authentifizierung fehlgeschlagen.
Fehler: Kritischer Fehler: Herstellen der Verbindung zum Server fehlgeschlagen
What am I doing wrong?

In the meantime I have also tried to create and RSA key with puTTYgen - that also did not work.


Re: Login problems

Posted: 2020-08-21 07:12
by botg
Check the permissions of the .ssh directory and the authorized_keys file. Your SSH server's manpage can tell you which permission it expects.

Re: Login problems

Posted: 2020-08-24 05:44
by jdegenfellner
Thanks for your answer!
For testing purposes I switched to read/write/execute allowed in both folders. Does not work yet. Same error message.

Pic of FileZilla folder attributes menu: ... o6WhEER1ta

Re: Login problems

Posted: 2020-08-24 06:55
by botg
That site is throwing endless captchas at me. Please attach images directly to this forum thread.

Re: Login problems

Posted: 2020-08-24 07:32
by jdegenfellner
There u go, haven't found the Attachment area before.

Re: Login problems

Posted: 2020-08-24 16:28
by jdegenfellner

Re: Login problems

Posted: 2020-08-24 16:45
by jdegenfellner
Did not work, same error message as before...

Re: Login problems

Posted: 2020-08-24 19:44
by jdegenfellner
I've used this howto
still the same error message.

any suggestions :) ?

Re: Login problems

Posted: 2020-08-24 21:16
by boco
Does the server support SFTP access (SFTP subsystem on the server is activated)? FileZilla does support ONLY SFTP, not SSH2 in general. In order to check this, you can try connecting with WinSCP (which does support the full SSH2 protocol, including the shell).
Since November 2013 access to VSC is restricted to IP addresses from the participating partner universities of the VSC project. If users wants to access VSC from IPs outside of these IP ranges, they have first to login to a machine or service to get access to their university network.
Did you read about this additional restriction? You need to be inside your university network for being able to connect (either directly or via VPN). IP addresses from your home ISP won't get access.

Re: Login problems

Posted: 2020-08-24 21:19
by jdegenfellner
Thanks for the hint!
I used WinSCP and it worked. I ll just use this :)