Upload forum, domainname still empty

Post all HTML related questions here. No support.

Moderator: Project members

Post Reply
Message
Author
Mieke
500 Command not understood
Posts: 3
Joined: 2013-01-24 05:23

Upload forum, domainname still empty

#1 Post by Mieke » 2013-01-24 05:27

Hi there!
Thank you for this forum. I have a question. I have to say English is not my native language, I might make mistakes in my text.

Anyway, I use FileZilla to upload a phpBB-forum to my domain. I transfer all the files to domain/'domainname'/public_html.
However, when I open my domain, I keep getting a warning. What a I doing wrong?
Forbidden

You don't have permission to access / on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

User avatar
boco
Contributor
Posts: 25241
Joined: 2006-05-01 03:28
Location: Germany

Re: Upload forum, domainname still empty

#2 Post by boco » 2013-01-24 15:40

1. Can you confirm that your webhoster supports PHP+one of the database engines phpBB requires?
2. Did you upload the files so the phpBB's index.php file is directly in /public_html? Or did you make the mistake and uploaded the complete phpBB subdirectory rather than the files and directories inside it?
3. After upload you are supposed to run the phpBB install routine to setup database connections, admin account etc. If 1. and 2. are resolved it should take you there automatically.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

Mieke
500 Command not understood
Posts: 3
Joined: 2013-01-24 05:23

Re: Upload forum, domainname still empty

#3 Post by Mieke » 2013-01-25 18:06

Thank you very much. That second question gave me the answer. How silly. Thank you very much, again. It is working now!!

Mieke
500 Command not understood
Posts: 3
Joined: 2013-01-24 05:23

Re: Upload forum, domainname still empty

#4 Post by Mieke » 2013-03-09 08:46

Well, I was working on FileZilla (uploading a WP-blog to another domain). Something went wrong and I wanted to delete te WP-files that I allready uploaded on FileZilla.
And yes.... I deleted all the files from my forum as well. Is that a problem? If so, how do I fix it.

(And another question to the side: can you replace the folders from where you uploaded the forum? Or can you even delete those folders? As you can see, I am a newbie)

User avatar
boco
Contributor
Posts: 25241
Joined: 2006-05-01 03:28
Location: Germany

Re: Upload forum, domainname still empty

#5 Post by boco » 2013-03-09 20:10

If you deleted the forum files the forum will go down. The easy part is that you can simply re-upload the missing files (you do not sound like using forum mods/hacks so I think your deleted files were the vanilla ones).
The harder part is re-establishing your config.php file (configuration information file which includes connection information to the forum database). Every specific question regarding this must be directed at phpBB support.

To the second question: Once you uploaded the phpBB file you can delete the local copy. But, provided you don use forum mods/hacks, having a local backup of your config.php file and a database dump is absolutely recommended to prevent future disasters.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

Post Reply