Embedding a youtube video problem on publish

Post all HTML related questions here. No support.

Moderator: Project members

Post Reply
Message
Author
valbasile
500 Command not understood
Posts: 2
Joined: 2013-01-25 02:32
First name: val
Last name: basile

Embedding a youtube video problem on publish

#1 Post by valbasile » 2013-01-25 02:52

I am having trouble publishing a youtube video to my website. I use Kompozer and embed the "old style" code youtube gives for the video and I see it after I save it and browse the page but when I publish it the embed code changes so I have a blank white box where the video should be. I thought this was going to be an easy do. Cant figure out what to do. PLEASE advise. Thanks.

pre html before publishing to web
<object width="560" height="315"><param name="movie" value="http://www.youtube.com/v/example?versio ... ram><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/example?versio ... n_US&rel=0" type="application/x-shockwave-flash" width="560" height="315" allowscriptaccess="always" allowfullscreen="true"></embed></object>

after publish: <embed src="example" type="application/x-shockwave-flash" width="560" height="315" allowscriptaccess="always" allowfullscreen="true"></embed></object>

Furniture Hire
500 Command not understood
Posts: 2
Joined: 2013-02-18 15:19
First name: Furniture
Last name: Hire
Location: London

Re: Embedding a youtube video problem on publish

#2 Post by Furniture Hire » 2013-02-18 15:27

Is your site using html 5?
<Removed, advertisements not allowed>

valbasile
500 Command not understood
Posts: 2
Joined: 2013-01-25 02:32
First name: val
Last name: basile

Re: Embedding a youtube video problem on publish

#3 Post by valbasile » 2013-02-18 16:18

Dont know. I had a devoloper who built it in 2009. Ive seen this to be a Kompozer problem and havent seen a solution. I basically inserted the youtube html link into an image so user has to click on the image and it brings them to the Youtube video. It does take them away from my site though (doesnt open in a new page).

User avatar
audiopro
226 Transfer OK
Posts: 293
Joined: 2013-03-23 12:55
First name: Keith
Location: Morecambe, England
Contact:

Re: Embedding a youtube video problem on publish

#4 Post by audiopro » 2013-03-27 10:40

I am not familiar with Kompozer but it is likely to be that which is corrupting the code as it is publishing it. There is no opening <object> tag in the after publish code you supplied.
Just FTP the HTML file up to the server.
Morecambe - Where the sun goes at night

maybis
550 File not found
Posts: 31
Joined: 2013-04-16 22:47
First name: Maybis
Last name: Schollen

Re: Embedding a youtube video problem on publish

#5 Post by maybis » 2013-04-16 23:32

Yes I had that problem with that software too. Now I only use dreamweaver, but it is very expensive. But I am slowly moving all my sites to WordPress, and then you can forget all about the complexities of HTML.

Even Matt Cutts from Google and advised using WordPress because it sells many issues. I'm sure the makers of HTML editors wouldn't be happy about this

User avatar
audiopro
226 Transfer OK
Posts: 293
Joined: 2013-03-23 12:55
First name: Keith
Location: Morecambe, England
Contact:

Re: Embedding a youtube video problem on publish

#6 Post by audiopro » 2013-04-17 06:37

you can forget all about the complexities of HTML
The original poster's problem had noting to do with the 'complexities' of HTML, it was down to the fact that the chosen software was, for some reason, not up to the job.

As for Wordpress, it is useful software in some instances but you have to jump through all the hoops of setting it up, downloading and installing your required add ons, plug ins and such. Then you produce your Wordpress website and after all that, Wordpress creates the code suitable for publishing to the internet. The code created is that 'complex' HTML you are so keen to avoid.
Many developers prefer to cut out the middle man and write the HTML code directly as it gives them complete control of the final site.
Morecambe - Where the sun goes at night

maybis
550 File not found
Posts: 31
Joined: 2013-04-16 22:47
First name: Maybis
Last name: Schollen

Re: Embedding a youtube video problem on publish

#7 Post by maybis » 2013-04-19 04:44

While it is a matter of time until everything becomes more stable and standardised. At the moment the Internet is so new that everything is changing. For example, everything used to be about flash, but now it's html5. Open source things tend to stick better. The whole Internet should be open source in my opinion, but the powers that be want to censor it

User avatar
audiopro
226 Transfer OK
Posts: 293
Joined: 2013-03-23 12:55
First name: Keith
Location: Morecambe, England
Contact:

Re: Embedding a youtube video problem on publish

#8 Post by audiopro » 2013-04-19 06:39

At the moment the Internet is so new
:shock:

After more than 20 years the internet should be stable and standardised but unfortunately development has been led, not by requirements but by what technology geeks have been able to make it do.

Throughout the industrial revolution, all inventions were developed in answer to a need, usually to improve a process to make the company more money.

With technology there has been the opposite approach. A new technique or process was discovered and then people set about finding a use for it.
Morecambe - Where the sun goes at night

User avatar
botg
Site Admin
Posts: 33162
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Embedding a youtube video problem on publish

#9 Post by botg » 2013-04-19 19:54

audiopro wrote:After more than 20 years the internet should be stable and standardised but unfortunately development has been led, not by requirements but by what technology geeks have been able to make it do.
Corporate NIH syndrome is what is causing most of the problems in my opinion. See also http://xkcd.com/927/

Post Reply