Website Links

Post all HTML related questions here. No support.

Moderator: Project members

Message
Author
rjlump54
504 Command not implemented
Posts: 7
Joined: 2013-05-20 01:54
First name: Robert
Last name: Lumpkin

Website Links

#1 Post by rjlump54 » 2013-05-20 03:22

Our church website is experiencing problems with some of the links. The links to other (external) web pages seem to work alright, but the ones that are (internal) linking to documents or pages within our website have stopped working and I can't say that anything has changed over the past few days for this to occur. Our site address is: <not allowed to post links>.
I tried to find out information regarding this matter in other posts, but I guess I'm not looking in the right place. If you need more info I'll be more than happy to provide.

Thank You in advance,
Bob

User avatar
boco
Contributor
Posts: 25189
Joined: 2006-05-01 03:28
Location: Germany

Re: Website Links

#2 Post by boco » 2013-05-20 04:12

Did you use relative links (recommended) or did you use the full URL for every link?
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

buttfish13
504 Command not implemented
Posts: 7
Joined: 2013-05-21 21:51
First name: ferdinand
Last name: vogel
Location: Austria

Re: Website Links

#3 Post by buttfish13 » 2013-05-21 22:25

If you used relative links, you could have large ammounts of issues. The simple solution would be to add a "basedir" function to .htaccess , this will mean that every request won't be sent back to the server and take precious resources to process.

However , if you are unable to do this, use full links. If those do not work, you need to have your network administrator rework your server configuration (perhaps you are using php and your server does not have php).

Hope this helps!
The Cthulhu Portal breathes!

User avatar
boco
Contributor
Posts: 25189
Joined: 2006-05-01 03:28
Location: Germany

Re: Website Links

#4 Post by boco » 2013-05-21 22:40

Relative linking has the least problems. Additionally, it makes the website portable.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

rjlump54
504 Command not implemented
Posts: 7
Joined: 2013-05-20 01:54
First name: Robert
Last name: Lumpkin

Re: Website Links

#5 Post by rjlump54 » 2013-05-21 23:21

Hello Responders
The links begin www. When I test the links (hold down control key and right click) the link works, but in the site they are not active. All links to other website pages work fine.

I appreciate all your responses
Thanks and God Bless

Bob

User avatar
boco
Contributor
Posts: 25189
Joined: 2006-05-01 03:28
Location: Germany

Re: Website Links

#6 Post by boco » 2013-05-22 01:28

The links begin www.
That means they include the whole domain name etc? That's very bad practice. Use relative links, only specify where from your current point the file is. If it is in the same directory on the server, use the filename only, in case of subdirectories include it.

Ex.

image.gif

images/image.gif
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

rjlump54
504 Command not implemented
Posts: 7
Joined: 2013-05-20 01:54
First name: Robert
Last name: Lumpkin

Re: Website Links

#7 Post by rjlump54 » 2013-05-22 03:32

Renamed the link as suggested but the results are the same.

downloads/docx

Any other ideas?

User avatar
boco
Contributor
Posts: 25189
Joined: 2006-05-01 03:28
Location: Germany

Re: Website Links

#8 Post by boco » 2013-05-22 06:07

downloads/docx
What's this? It doesn't end with a filename. And you should note that Word documents will not show in any browser unless some kind of plugin is installed.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

rjlump54
504 Command not implemented
Posts: 7
Joined: 2013-05-20 01:54
First name: Robert
Last name: Lumpkin

Re: Website Links

#9 Post by rjlump54 » 2013-05-22 12:34

Good Morning All,

May I remind you that this site was functioning fine for the past year with no issues. For whatever the reason all of a sudden the links stopped working. That's the reason I posted here because they just stopped working. Prior to whatever happened the links as they were assigned worked as they should.

I can appreciate the tech savvy of all of you and am sure if I were on the level of expertise you are, I probably would have this matter resolved by know, but I'm not. I just want to get to the bottom of why the links stopped working. If it will help, the site was built with Word Publisher 07 and I am using FileZilla as my FTP. Since I can't post addresses I don't know how to get you there other than you emailing me.

May you have a great day!

User avatar
boco
Contributor
Posts: 25189
Joined: 2006-05-01 03:28
Location: Germany

Re: Website Links

#10 Post by boco » 2013-05-22 12:36

May I remind you that this site was functioning fine for the past year with no issues. For whatever the reason all of a sudden the links stopped working. That's the reason I posted here because they just stopped working. Prior to whatever happened the links as they were assigned worked as they should.
If your site stopped working (which is served through HTTP, not FTP), shouldn't you have contacted your hosting provider first?
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

rjlump54
504 Command not implemented
Posts: 7
Joined: 2013-05-20 01:54
First name: Robert
Last name: Lumpkin

Re: Website Links

#11 Post by rjlump54 » 2013-05-22 13:16

That I did and the person(s) I spoke with tried to tell me that it was not due to their servers.

This is the response I received from the host:This is not a server wide issue and we have nothing to do on it . Please check this with your developer/webmaster as they can help you better than us. Please note that we are help less on this issue . We didn't make any change on server and couldn't see any error message in error logs . Upon checking the website ,some hyperlinks are working fine and others not . You have to investigate it yourself .

As you can see, that was a lot of help!

User avatar
audiopro
226 Transfer OK
Posts: 293
Joined: 2013-03-23 12:55
First name: Keith
Location: Morecambe, England
Contact:

Re: Website Links

#12 Post by audiopro » 2013-05-22 17:55

For now, assume that your ISP is correct and that they have made no changes to the server.

You need to do a bit of investigating yourself first.
Regardless of whether the links worked previously, the first course of action is to check whether the link is correct within the page.
Look at the source code and identify code which relates to a non working link, copy that code directly into your address bar and see if it directs you to the correct location.
Your next move depends on the results of those tests.
Morecambe - Where the sun goes at night

rjlump54
504 Command not implemented
Posts: 7
Joined: 2013-05-20 01:54
First name: Robert
Last name: Lumpkin

Re: Website Links

#13 Post by rjlump54 » 2013-05-23 03:40

Hello,

Had to shut down to go to BS.

The links as I look at them in Publisher 07 in the design mode are correctly pointed. When I check them by holding down ctrl key and right clicking the link, it opens to the place where it is supposed to. Now why they are not active links on the site, I don't know.

Bob

User avatar
audiopro
226 Transfer OK
Posts: 293
Joined: 2013-03-23 12:55
First name: Keith
Location: Morecambe, England
Contact:

Re: Website Links

#14 Post by audiopro » 2013-05-23 06:54

As previously posted.
Look at the source code and identify code which relates to a non working link, copy that code directly into your address bar and see if it directs you to the correct location.
You need to check that the code on the server is correct, it may well be correct in Publisher but it may be getting corrupted as it is being put on the server.
Morecambe - Where the sun goes at night

rjlump54
504 Command not implemented
Posts: 7
Joined: 2013-05-20 01:54
First name: Robert
Last name: Lumpkin

Re: Website Links

#15 Post by rjlump54 » 2013-05-23 22:06

Good Evening,

Well, I've just finished rebuilding the website and having checked and rechecked the link on the Gallery page and still it isn't working. I've gone to the gallery itself to make sure the address in the bar is the same as that in the hyperlink box, so now I am really stumped at this point. I have not published the site as of yet being that I wanted to make sure everything was working properly.

Any suggestions???
Bob

Post Reply