Image not displaying...

Post all HTML related questions here. No support.

Moderator: Project members

Locked
Message
Author
katekavs
500 Command not understood
Posts: 2
Joined: 2017-06-24 21:19
First name: kate
Last name: kavanagh

Image not displaying...

#1 Post by katekavs » 2017-06-24 21:30

Hello,

I've been fiddling with this for hours and can't work out what I'm doing wrong. When I use the url http://example.com/images/fbcircusicon.jpg the image appears online, but when I try to put it in the code for my index page as <img src="images/fbcircusicon.jpg"> then all I get is the empty box icon. Can someone help?

Thank you!
:)
Last edited by boco on 2017-06-24 22:45, edited 1 time in total.
Reason: Modified URL according to our board rules.

User avatar
boco
Contributor
Posts: 24156
Joined: 2006-05-01 03:28
Location: Germany

Re: Image not displaying...

#2 Post by boco » 2017-06-24 22:56

You might have to use <img alt="" src="/images/fbcircusicon.jpg">.

"images/fbcircusicon.jpg" means "the file fbcircusicon.jpg that is in a subdirectory images from the current location"

"/images/fbcircusicon" means "the file fbcircusicon.jpg that is in a subdirectory images from the root directory"

The alt= argument specifies the alternate text (if the image failed to load) and is also required.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

katekavs
500 Command not understood
Posts: 2
Joined: 2017-06-24 21:19
First name: kate
Last name: kavanagh

Re: Image not displaying...

#3 Post by katekavs » 2017-06-25 09:10

That's not working either I'm afraid :(

Locked