Page 1 of 1

ccs and js not rendering only html

Posted: 2020-10-04 23:15
by Nessyd
Hi there, I'm a newbie and I'm studying web dev and design.

Pardon me if this has already been answered but I was not able to find the solution here so far. I have spent so many precious hours searching and trying what I could understand but now I think I need pro help. It's my first time using FiIeZilla and I could be doing something stupidly wrong!

1-I have successfully connected to the college server and transferred the web files.
2- when I copy the URL to the clipboard and check the site only HTML renders.
3-The files are in the right html_public directory and they are all under the same folder. The images, css and js are in their own subfolders but still within the same directory as HTML.

4-The HTML code is pointing at the right place: e.g. css/style.css, etc. I thought it could be the folder level and I changed them at different times to root "/" and at another time, one level up "../" - even if it didn't make sense to do it, because the site renders correctly from my local pc using the current hierachy. This didn't work so I changed them back but I have not touched the code otherwise so it shouldn't be case-sensitive issue.

5-I noticed the size of the files had changed after trasferring so I change the Transfer to Binary as advised by Boco to someone else, this worked for the size but had no effect on the rendering.

6-I changed all file permissions to be 777 - no joy here.

7-Only now it occurred to me to inspect the site in the console and it shows that the css, js, and images files cannot be found - but I can see them in the window pane of the remote server in Filezilla.

8- I tried taking the files out of the subfolders and have them all sitting "bare" in the directory as well, and this didn't work either

What am I doing wrong? (btw, I cannot change to connection to Active because I don't have the IP address for the college server or at least, it looks that way)

Any help is greatly appreciated! :)

Re: ccs and js not rendering only html

Posted: 2020-10-05 21:55
by botg
Character case?

Re: ccs and js not rendering only html

Posted: 2020-10-06 10:38
by Nessyd
Thank you for your reply botg. I couldn't see a problem there.

However, something happened that I don't understand.

I noticed that when I copied the url to the clipboard and pasted it on the browser to view the site, when I hit enter, a copy of the html file is downloaded to my local C drive in the Downloads folder.

Is this how it's supposed to work? I thought the website would open on the browser straight away? Am I wrong? thanks for your patience :!:

Re: ccs and js not rendering only html

Posted: 2020-10-06 13:10
by botg
If you copy the URL you get one for the FTP server. Browsers do not do FTP.