Can't "configure" libfilezflla

Everything related to libfilezilla

Moderator: Project members

Post Reply
Message
Author
RWCarr
500 Syntax error
Posts: 13
Joined: 2012-10-20 23:49
First name: Richard
Last name: Carr

Can't "configure" libfilezflla

#1 Post by RWCarr » 2022-01-08 06:15

I carefully followed all the steps in https://wiki.filezilla-project.org/Comp ... nder_macOS. I downloaded all the components, including gmp-6.1.2, extracted them with tar, performed the ./configure, make and make install steps on all the components up to libfilezflla. When I did the ./configure on libfilezflla, I got the following:

checking whether pthread_condattr_setclock is declared... no
checking whether iconv can be used without link library... no
checking whether iconv needs -liconv... yes
checking for pkg-config... /Users/richard/prefix/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for gmp... no
configure: error: gmplib was not found. You can get it from https://gmplib.org/

I checked with gmplib.org and they pointed out that version 6.1.2 needs to be compiled with XCODE 11.3 or later. So I made sure I had XCODE 11.3 and redid the gmplib steps, including make check. I still get the error shown above.

Looking in the src and prefix folders, I see lots of source files for gmp-6.1.2 and a few gmp files in prefix/lib and prefix/include, but no gmp files in prefix/bin.

I've been a professional programmer for 55 years, and a Mac owner since 1984 but this is my first foray into Mac development, so I'm at a complete loss as to how to figure out what the problem is.

RWCarr
500 Syntax error
Posts: 13
Joined: 2012-10-20 23:49
First name: Richard
Last name: Carr

Re: Can't "configure" libfilezflla

#2 Post by RWCarr » 2022-01-09 08:56

I decided get a more recent version of gmp (2.1), which, of course, required getting more recent versions of gnutils and nettle. That eliminated the error in the libfilezflla configure step, but now I'm getting lots of strange compile errors on libfilezilla. There were 19 of them and they all look like this:

json.cpp:47:8: error: 'get<1, std::string, std::map<std::string, fz::json, std::less<>>, std::vector<fz::json>, bool>' is unavailable: introduced in macOS 10.13
std::get<1>(value_).erase(name);

The error is always on get<0>, get<1>, get<2>, or get<3>.

I was on macOS 10.14 and using XCODE 11.3, so I figured it wouldn't hurt to upgrade to MacOS 12.1 and XCODE 13.1. (I was holding back because I was using a 32-bit FTP client and it runs on 10.14 but not 11 or 12.)

Well, that didn't help. Still getting the same error.

Should I get newer versions of all the other components that are compiled before libfilezflla?

Can someone tell me a "current" set of components that are in routine use building FileZilla? Some of the components in https://wiki.filezilla-project.org/Comp ... nder_macOS are not the latest.

User avatar
botg
Site Admin
Posts: 34006
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Can't "configure" libfilezflla

#3 Post by botg » 2022-01-10 14:00

I've been a professional programmer for 55 years, and a Mac owner since 1984 but this is my first foray into Mac development, so I'm at a complete loss as to how to figure out what the problem is.
You missed all the fun then ;)
It used to be much more difficult in the past, OS X builds used to be very sensitive to particular versions of libraries and tools, making for a very fragile build system. Similar to how fragile building with MinGW on Windows used to be. Fortunately the situation has improved a lot since.

Yes, you need the latest versions of everything.

In the various environment variables, change the minimum version of macOS to 10.13 instead of 10.11

I've updated the instructions accordingly.

Post Reply