Filezilla ignores Site Manager "Logon Type" Setting

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
Amandaville
504 Command not implemented
Posts: 10
Joined: 2012-03-28 11:36

Filezilla ignores Site Manager "Logon Type" Setting

#1 Post by Amandaville » 2018-07-11 16:15

Filezilla ignores the Site Manager settings and never sends the user name and password entered in Site Manager. Instead, it sends unrelated keys residing in my .ssh directory to the server even though I have selected "Logon Type: Normal" with a User Name and Password entered. I DO NOT have "Logon Type: Key File" selected. The server counts each key sent by Filezilla as an authentication attempt and reaches the server's maximum number of attempts before returning the Error: "Too many authentication failures for (user)" "Could not connect to server".

Thus, I cannot log in to my sites. I have created a config file in my .ssh directory and added the lines "host (domainname)" & "PubkeyAuthentication=no". This resolved the identical error I was receiving when trying to log in to these sites with SFTP in a terminal but it appears as though Filezilla ignores the preferences in the .ssh/config file even though it is picking up the keys in the .ssh directory.

How do I force Filezilla to ignore the unrelated SSH keys and use ONLY the User Name and Password as entered in the Site Manager entry?

User avatar
botg
Site Admin
Posts: 31605
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Filezilla ignores Site Manager "Logon Type" Setting

#2 Post by botg » 2018-07-11 20:18

Just don't load all your keys into your system's SSH agent.

Note that, unless you rely on agent forwarding, using more than one private key with SSH does not offer any additional security, it just makes things more complicated.

Amandaville
504 Command not implemented
Posts: 10
Joined: 2012-03-28 11:36

Re: Filezilla ignores Site Manager "Logon Type" Setting

#3 Post by Amandaville » 2018-07-12 10:30

botg wrote:
2018-07-11 20:18
Just don't load all your keys into your system's SSH agent.

Note that, unless you rely on agent forwarding, using more than one private key with SSH does not offer any additional security, it just makes things more complicated.
How is that an appropriate solution for an app that doesn't respect it's own settings? If I select NORMAL Logon Type, not KEY FILE, why is it even passing keys in the first place?

I have keys for several servers that are accessed in cron jobs on a daily basis, but I also need to access a half a dozen other servers infrequently enough that keys are not really necessary. I'm not going to delete the keys and cause the associated cron jobs to fail just because Filezilla doesn't work as it should.

User avatar
botg
Site Admin
Posts: 31605
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Filezilla ignores Site Manager "Logon Type" Setting

#4 Post by botg » 2018-07-12 14:40

For SFTP it is normal to first try any keys provided by the system's SSH agent before falling back to password authentication.

Amandaville
504 Command not implemented
Posts: 10
Joined: 2012-03-28 11:36

Re: Filezilla ignores Site Manager "Logon Type" Setting

#5 Post by Amandaville » 2018-07-12 15:45

Is there a way to pass the -o flag in Filezilla?

The following command works in the terminal

ssh -o PubkeyAuthentication=no username@12.34.56.78

By using the -o flag, the connection will disregard public key authentication all together and go straight to user/pass login.

User avatar
botg
Site Admin
Posts: 31605
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Filezilla ignores Site Manager "Logon Type" Setting

#6 Post by botg » 2018-07-12 15:52

No.

Amandaville
504 Command not implemented
Posts: 10
Joined: 2012-03-28 11:36

Re: Filezilla ignores Site Manager "Logon Type" Setting

#7 Post by Amandaville » 2018-07-13 04:37

Might be a useful feature request for a future version. It seems there are quite a few people running into the same problem.

Post Reply