Stop with popups while editing !!!

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Message
Author
User avatar
boco
Contributor
Posts: 25539
Joined: 2006-05-01 03:28
Location: Germany

Re: Stop with popups while editing !!!

#46 Post by boco » 2011-08-10 10:33

By using unofficial versions, you forfeit all support from us. But you probably know that.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

zenzen
500 Command not understood
Posts: 2
Joined: 2011-10-10 03:20
First name: zen
Last name: zen

Re: Stop with popups while editing !!!

#47 Post by zenzen » 2011-10-10 03:23

Cyberduck doesnt have this!

WinScp doesnt have this!

This filezilla popup is irritating!!

kalar
500 Command not understood
Posts: 1
Joined: 2014-03-03 22:32
First name: Kala
Last name: Raymond

Re: Stop with popups while editing !!!

#48 Post by kalar » 2014-03-03 22:47

Been using filezilla for many years, maybe ten or more. I have enjoyed the program at it has done what I wanted it to silently and without complaint. I have referred countless people to the program . . .

Now in the last few weeks (I don't run the updater regularly) every single time I save work to a file I get a popup in filezilla asking me "a file previously opened has been changed, upload this file to the server?" with an option to delete the local file O.o

All I can say is wtf and why won't it go away . . . FOREVER

I did try it out after getting tired of just x'ing it out.

Option 1 click yes - A file is transferred, but my recently saved changes are not reflected
Option 2 click no - window closes

So how does this benefit anyone in any circumstances, and are there any recommendations for other ftp clients that work like filezilla did before this "enhancement"? I do not mean to antagonize, I truly appreciate the work that I have benefited from over the years, but we not so good a match anymore.

So sad . . . Been using this app so long for so many different customers filezilla had become synonymous with ftp for me QQ

User avatar
boco
Contributor
Posts: 25539
Joined: 2006-05-01 03:28
Location: Germany

Re: Stop with popups while editing !!!

#49 Post by boco » 2014-03-03 23:21

If you are using 3.7.4 right now, please update to 3.7.4.1. There is a bug in the previous version that causes excessive file change prompts.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

hilogogifts
500 Command not understood
Posts: 1
Joined: 2014-03-04 15:08
First name: Nathan
Last name: Hi

Re: Stop with popups while editing !!!

#50 Post by hilogogifts » 2014-03-04 15:13

wow. really ?

User avatar
botg
Site Admin
Posts: 33508
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Stop with popups while editing !!!

#51 Post by botg » 2014-03-04 18:59

Yup.

potter223
500 Command not understood
Posts: 1
Joined: 2014-03-07 14:33
First name: Gordon
Last name: Potter

Re: Stop with popups while editing !!!

#52 Post by potter223 » 2014-03-07 14:37

boco wrote:If you are using 3.7.4 right now, please update to 3.7.4.1. There is a bug in the previous version that causes excessive file change prompts.
I am using 3.7.4.1 and I have the "file has changed" dialog box.
I know everyone has complained about this popup "feature" on this post so I won't belabor the point.

I would assume there is a setting to fix this?

Any tips would be a great help.

Thanks everyone,
:o

User avatar
boco
Contributor
Posts: 25539
Joined: 2006-05-01 03:28
Location: Germany

Re: Stop with popups while editing !!!

#53 Post by boco » 2014-03-07 18:48

My statement is only for people getting the prompt continually without the file having changed, actually. The prompt itself appearing when FileZilla detects a change in a file being edited is by design and cannot be disabled.
I would assume there is a setting to fix this?
Automatic upload without confirming the prompt is not possible.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

mmitchell
500 Command not understood
Posts: 1
Joined: 2019-05-01 17:03

Re: Stop with popups while editing !!!

#54 Post by mmitchell » 2019-05-01 17:08

This is a painful behavior to deal with when you're doing a lot of small file edits throughout the day. Transmit dealt with the issue of file corruption by adding a "safe save" feature that transfers the local file to a new temporary location on the remote server and then overwrites the existing file only once the transfer is complete. I often work on some really sketchy and brittle connections and I've never had it corrupt a file this way; if it fails, it just aborts the transfer and deletes the temp file (if it still can). Unfortunately Transmit isn't cross platform so it's only usable on some of my devices but I think it was a pretty clever solution. The only downside is that every once in a blue moon, I have to go delete the half-baked temp file, but I think a lot of people would prefer that to the popup.

svetaklisko
500 Command not understood
Posts: 2
Joined: 2019-05-08 07:00
First name: Anna
Last name: Tsevcenko
Contact:

Re: Stop with popups while editing !!!

#55 Post by svetaklisko » 2019-05-08 07:14

mmitchell wrote:
2019-05-01 17:08
This is a painful behavior to deal with when you're doing a lot of small file edits throughout the day. Transmit dealt with the issue of file corruption by adding a "safe save" feature that transfers the local file to a new temporary location on the remote server and then overwrites the existing file on my only once the transfer is complete. I often work on some really sketchy and brittle connections and I've never had it corrupt a file this way; if it fails, it just aborts the transfer and deletes the temp file (if it still can). Unfortunately Transmit isn't cross platform so it's only usable on some of my devices but I think it was a pretty clever solution. The only downside is that every once in a blue moon, I have to go delete the half-baked temp file, but I think a lot of people would prefer that to the popup.
yes everything is much easier with it when having good stable connection, I ve been strugeling with same issuses before.

funtastic
500 Command not understood
Posts: 3
Joined: 2009-03-29 12:09
First name: Herm
Last name: Herm

Re: Stop with popups while editing !!!

#56 Post by funtastic » 2021-06-10 11:39

Hi,
I also have to say that this attitude is really annoying.
I really respect that you don't want to corrupt files and set actual behavior as default.
But you should have noticed how many people complain about it.
So why don't offer a setting that can be activated by the user on his own risk that allows an automatic upload after saving after a configurable delay ?

This way you would be on the safe side and can stay with your nerd dogmas and on the other hand everybody who is happy with a 99,99999% solution could use the different configuration.

Herm

Post Reply