unable to prevent 'new version available' popup

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Message
Author
User avatar
botg
Site Admin
Posts: 34006
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: unable to prevent 'new version available' popup

#16 Post by botg » 2021-12-01 09:09

Updating doesn't even take 10 seconds. Surely you can spend 10 seconds once per month. Have a sip of coffee/tee/beer/cowjuice while it updates.

User avatar
boco
Contributor
Posts: 25891
Joined: 2006-05-01 03:28
Location: Germany

Re: unable to prevent 'new version available' popup

#17 Post by boco » 2021-12-02 01:01

botg wrote:
2021-12-01 09:09
cowjuice
It's "udder liqueur", you cretin. :mrgreen: :mrgreen: :mrgreen:
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

Passant
500 Command not understood
Posts: 4
Joined: 2021-12-27 11:47

Re: unable to prevent 'new version available' popup

#18 Post by Passant » 2021-12-27 12:03

I just created an account to give my +1 for @Ventures opinion. That popup is annoying.

Uh... and there is one other thing to metion:
Dear bocos and botgs out there, if people start programming autohotkey scrips to make filezilla useable for them, it may be worth considering to make that "popup feature" optional.

Lets copy that AHK code to my running background script.
Cheers :smoke:

User avatar
botg
Site Admin
Posts: 34006
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: unable to prevent 'new version available' popup

#19 Post by botg » 2021-12-27 14:34

You need to update FileZilla. Running outdated software is a security risk.

Passant
500 Command not understood
Posts: 4
Joined: 2021-12-27 11:47

Re: unable to prevent 'new version available' popup

#20 Post by Passant » 2022-01-01 20:18

I can not see any risk, using a older filezilla version.
Where should be the entry gate for the exploit?

Can you please tell me a use case, how a pontentially weakness could be utilized to run harmful code?

User avatar
botg
Site Admin
Posts: 34006
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: unable to prevent 'new version available' popup

#21 Post by botg » 2022-01-03 11:40

Do you trust that 100% of the data you receive over the network is benevolent?

Processing any untrusted data poses a risk. Attackers have ample time analyzing outdated software for potential vulnerabilities.

Passant
500 Command not understood
Posts: 4
Joined: 2021-12-27 11:47

Re: unable to prevent 'new version available' popup

#22 Post by Passant » 2022-01-14 17:38

Do you trust that 100% of the data you receive over the network is benevolent?
Processing any untrusted data poses a risk.
That is true. But how does an updated version of FileZilla increase data trustworthiness in any way?
FileZilla does not have the ability to detect, if a transfered file is malicious or not. So every file transfered by an old FileZilla version is as trustworthy as one transfered by an updated FileZilla version.
I may be thumb, but I see absolutely no reason to update here.

- - -
Attackers have ample time analyzing outdated software for potential vulnerabilities.
Yes, they have. But it is informative, that even a very experienced developer can not give us any use case of how they attacked an outdated FileZilla installation in the past.
To be honest: I am realy still waiting to see any rational reason to update (and and therefore a reason to nudge users by that popup).

Passant
500 Command not understood
Posts: 4
Joined: 2021-12-27 11:47

Re: unable to prevent 'new version available' popup

#23 Post by Passant » 2022-01-20 12:16

No answer?

⠀⠀⠀⠀⠀⠀⠀Hm....
https://abload.de/img/meme-faces-png-free-fxakjg.png

Some weird people could think, there are other reasons than providing security for your absolute will to bring updated code on users computers.

User avatar
botg
Site Admin
Posts: 34006
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: unable to prevent 'new version available' popup

#24 Post by botg » 2022-01-20 13:42

What is there to answer? Just update. Updates bring fixes to bugs. Many classes of bugs are potential security vulnerabilities. Not updating leaves you vulnerable. Simple as that.

Update good, old version bad.

Post Reply