FileZilla Client 3.2.4 no longer works on CentOS 5.3

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
rkl
500 Command not understood
Posts: 5
Joined: 2007-10-04 14:32

FileZilla Client 3.2.4 no longer works on CentOS 5.3

#1 Post by rkl » 2009-04-22 15:06

I've been unpacking the Linux binary .tar.bz2 package of several of the 3.X releases of
FileZilla Client and they've been working fine on CentOS 5 (we're on CentOS 5.3 at
the moment). However, the new release of FileZilla Client, 3.2.4, sadly no longer runs on
CentOS 5.

The filezilla binary for 3.2.4 seems to have been built with much later versions of various
shared libraries - well beyond what's available on CentOS 5 (or, indeed, the RHEL 5 distro that CentOS 5 is based on). Examples include:

* libstdc++.so.6 now requires GLIBCXX_3.4.9 versioning, which isn't present in CentOS 5.
* libgnutls.so.26 is needed, but CentOS 5 only has libgnutls.so.13.

Even trying to copy Fedora Rawhide versions of those libraries and setting LD_LIBRARY_PATH to
include them triggered issues with libc.so.6 (versioning) and a missing libtasn1.so.3 library. Adding those from Rawhide just resulted in a futex() call hanging, at which point I gave up :(

Any chance of building the FileZilla Client with the older libraries like you did with 3.2.3.1 and
earlier? It's a shame that FileZilla Client now no longer works for the most popular commercial Linux (RHEL 5).

User avatar
botg
Site Admin
Posts: 33428
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: FileZilla Client 3.2.4 no longer works on CentOS 5.3

#2 Post by botg » 2009-04-22 19:14

The binaries are now built on Debian 5 aka Lenny.

Why don't you simply compile the source yourself? If you for some reason cannot do that (It really is not hard at all), contact a packager working with your distribution to get it included into the distribution.

rkl
500 Command not understood
Posts: 5
Joined: 2007-10-04 14:32

Re: FileZilla Client 3.2.4 no longer works on CentOS 5.3

#3 Post by rkl » 2009-04-23 13:08

Sadly, not only isn't FileZilla available in any of the typical additional repos (e.g. epel, rpmforge, extras), but it won't build from source code either. This is because the configure script now expects a minimum of libgnutls 2.0.4 or greater, but CentOS 5.3 only ships with libgnutls 1.4.1. I guess that's the end of the road for CentOS 5/RHEL 5 users then - we'll be stuck on FileZilla 3.2.3.1 until RHEL 6/CentOS 6 comes out next year :(

User avatar
botg
Site Admin
Posts: 33428
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: FileZilla Client 3.2.4 no longer works on CentOS 5.3

#4 Post by botg » 2009-04-23 16:00

Simply build your own GnuTLS.

jdratlif
226 Transfer OK
Posts: 392
Joined: 2008-12-30 10:30
First name: John
Last name: Ratliff
Location: In a small white padded room.
Contact:

Re: FileZilla Client 3.2.4 no longer works on CentOS 5.3

#5 Post by jdratlif » 2009-04-24 04:19

You can mostly follow the directions from Compiling FileZilla 3 under Mac OS X. You will need to compile GnuTLS, libgpg-error, libgrcrypt, and possibly wxWidgets. I didn't notice a wxWidgets package in the CentOS package manager, but I only installed in virtual box and played with it for a few minutes.

I put the binary I compiled on the Unofficial Binaries page. I didn't install the VirtualBox guest additions, so my screen size was too small for FileZilla to be usable, but it started.
http://jdrrant.blogspot.com/ - CODEpendent Blog

User avatar
foo
500 Command not understood
Posts: 3
Joined: 2009-02-11 06:38
First name: bob
Last name: dole

Re: FileZilla Client 3.2.4 no longer works on CentOS 5.3

#6 Post by foo » 2009-04-25 05:42

Strange. I'm getting the same error after unpacking FileZilla_3.2.4_i586-linux-gnu.tar.bz2 on ubuntu 804.

"filezilla: error while loading shared libraries: libgnutls.so.26: cannot open shared object file: No such file or directory"

(edit: nvm...just read posts after 1st one :shock: .. reverted back to 3.2.3.1)

jdratlif
226 Transfer OK
Posts: 392
Joined: 2008-12-30 10:30
First name: John
Last name: Ratliff
Location: In a small white padded room.
Contact:

Re: FileZilla Client 3.2.4 no longer works on CentOS 5.3

#7 Post by jdratlif » 2009-04-25 14:34

Try the binary I posted on the Unofficial Binaries page for CentOS, or compile it yourself.

FileZilla isn't in an ubuntu repository? It should be. You should tell them that.
http://jdrrant.blogspot.com/ - CODEpendent Blog

User avatar
foo
500 Command not understood
Posts: 3
Joined: 2009-02-11 06:38
First name: bob
Last name: dole

Re: FileZilla Client 3.2.4 no longer works on CentOS 5.3

#8 Post by foo » 2009-04-25 16:43

jdratlif wrote:FileZilla isn't in an ubuntu repository? It should be. You should tell them that.
I will try it. Thanks.

It is in the repo...just not near the latest version, which fixed a few problems I kept encountering.

(edit: tried the binary you posted, get ~> filezilla: error while loading shared libraries: libtiff.so.3 & libexpat.so.0: cannot open shared object file: No such file or directory)
fixed it by just creating sym links to libtiff.so.4 & libexpat.so.1

owkaye
500 Command not understood
Posts: 3
Joined: 2009-04-30 03:24
First name: Owkaye
Last name: Go

Re: FileZilla Client 3.2.4 no longer works on CentOS 5.3

#9 Post by owkaye » 2009-04-30 03:36

Try the binary I posted on the Unofficial Binaries page for CentOS.
Hi jdratlif,

I downloaded your special build for CentOS 5.3 but I don't know how to install it. Do I have to extract the files from the archive, then manually drag-and-drop them into the corresponding directories in my /usr directory? Or is there an easier/better way to install everything?

Sorry for my ignorance here, but my experience in installing on CentOS is limited to using yum, and I don't want to screw anything up.

:)

jdratlif
226 Transfer OK
Posts: 392
Joined: 2008-12-30 10:30
First name: John
Last name: Ratliff
Location: In a small white padded room.
Contact:

Re: FileZilla Client 3.2.4 no longer works on CentOS 5.3

#10 Post by jdratlif » 2009-04-30 04:15

I wouldn't know how to properly install it on CentOS.

The binary I built is for a user's home directory. If you extracted it in your home directory, it should work. It might work if you put it in /opt.
FileZilla might need some path clarification if you don't run the binary in the same working directory. I think there is a path variable to set this, but I'm not positive about that.

I don't know anything about yum or rpm, sorry. I haven't used anything RedHat based in years. How would you have installed the official binary if it worked?

What I would do: start terminal
bzip2 -cd FileZilla-3.2.whateveritwasicalledit.tar.bz2 | tar x
cd filezilla/bin
./filezilla
http://jdrrant.blogspot.com/ - CODEpendent Blog

owkaye
500 Command not understood
Posts: 3
Joined: 2009-04-30 03:24
First name: Owkaye
Last name: Go

Re: FileZilla Client 3.2.4 no longer works on CentOS 5.3

#11 Post by owkaye » 2009-04-30 04:34

Thanks for the explanation, jdratlif.

Since you said it's built to run from the user's home directory that's what I did. I extracted the archive into my /home/owkaye folder then I clicked on the "filezilla" executable and it works great!

Apparently everything filezilla needs is self-contained in the proper locations in your archive. As long as everything stays where you put it, I imagine it's going to work fine for me.

You've done a great job with this and I thank you very much!!!

:)

santoshmohan
500 Command not understood
Posts: 1
Joined: 2010-05-28 10:19
First name: Santosh
Last name: Mohan

Re: FileZilla Client 3.2.4 no longer works on CentOS 5.3

#12 Post by santoshmohan » 2010-05-28 10:22

Same issue was seen for SLED10SP2.
srm-srv-r4vm7:/tmp/FileZilla3 # ./bin/filezilla
./bin/filezilla: error while loading shared libraries: libtasn1.so.3: cannot open shared object file: No such file or directory

Is there any workaround for this issue??

jdratlif
226 Transfer OK
Posts: 392
Joined: 2008-12-30 10:30
First name: John
Last name: Ratliff
Location: In a small white padded room.
Contact:

Re: FileZilla Client 3.2.4 no longer works on CentOS 5.3

#13 Post by jdratlif » 2010-05-28 19:12

Have you tried installing libtasn1?
http://jdrrant.blogspot.com/ - CODEpendent Blog

Post Reply