Server sent passive reply with unroutable address.

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
kostresa
500 Command not understood
Posts: 2
Joined: 2010-01-27 20:52

Server sent passive reply with unroutable address.

#1 Post by kostresa » 2010-01-29 22:06

When I'm connecting to an IIS5 ftp server behind a NAT router, I get this: "Server sent passive reply with unroutable address. Passive mode failed" when trying to access the folder directory.

I know the problem. I read the network configuration guide. I know that IIS is replying with it's internal NAT 192.168.X.X IP address. I know it's supposed to give out the external IP. But I don't think IIS5 is capable of being configured to use the external IP address.

Anyways, I get this problem message with the 3.3.1 filezilla client. However, the 3.3.0.1 version on another computer seems smarter. When trying the server I get: "Server sent passive reply with unroutable address. Using server address instead." Yay, it works. filezilla 3.3.0.1 knows what to do.

Question, is there some setting to "try the other IP" on the client if the reply IP is bad? Not sure why 3.3.1 won't try the external IP after the first fails.



and before you ask, yes, the ports are forwarded correctly.

User avatar
boco
Contributor
Posts: 25246
Joined: 2006-05-01 03:28
Location: Germany

Re: Server sent passive reply with unroutable address.

#2 Post by boco » 2010-01-29 22:21

This is configured in FileZilla's settings: Connection - FTP - Passive mode .
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

kostresa
500 Command not understood
Posts: 2
Joined: 2010-01-27 20:52

Re: Server sent passive reply with unroutable address.

#3 Post by kostresa » 2010-01-30 00:25

Thanks!

yanqian
500 Command not understood
Posts: 3
Joined: 2013-02-27 02:47
First name: qian
Last name: yan
Location: Shanghai

Re: Server sent passive reply with unroutable address.

#4 Post by yanqian » 2013-02-27 10:00

Hi,All,
I have another question or maybe a feature request.

I did some digging in this forum, found a lot of posts about "Passive mode replying with different IP than the server IP", I also know that we have a setting in Filezilla Client.

Connection > FTP > Passive mode,
"Use the serveris external IP address instead"

It is lucky that we have this option, many issues could be solved by this, but does anyone meet a case like following?

---------------------------
A FTPES server (IIS 7.5 on Windows Server 2008 R2), it's IP is 192.168.1.2, only 1 NIC.
The public IP of this server is 210.13.xx.xx, we have firewall and F5 BIG-IP device, NAT is handled by F5.

Due to some reason, the server administrator set the “External IP Address of Firewall” to "210.13.xx.xx" in IIS.
Now the internet clients can connect to the FTP smoothly, but internal clients (inside our corporation) couldn't get directory listing, because internal client get passive mode reply with "Public IP" too, so they can't connect to it.
----------------------------

Under this condition, the settings I mentioned above didn't work, i.e., it only works when server reply with internal IP.

Leaving aside the server side issues, It's better that Filezilla client can change any IP replied in passive mode which is not same as the IP (you connected) to the server IP, no matter what it is.

In other word, Even if you connect to internal IP, but server reply with public IP, Filezilla also change the public IP to internal IP.

User avatar
boco
Contributor
Posts: 25246
Joined: 2006-05-01 03:28
Location: Germany

Re: Server sent passive reply with unroutable address.

#5 Post by boco » 2013-02-27 19:18

Due to some reason, the server administrator set the “External IP Address of Firewall” to "210.13.xx.xx" in IIS.
Correct setup. For connections from the outside, it is required. If your FTP server does not have a feature for detecting local connections and acting accordingly (many have), all clients inside the LAN must use Active mode for IPv4. Note if using IPv6 these restrictions do not apply.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

yanqian
500 Command not understood
Posts: 3
Joined: 2013-02-27 02:47
First name: qian
Last name: yan
Location: Shanghai

Re: Server sent passive reply with unroutable address.

#6 Post by yanqian » 2013-02-28 00:48

Hi,Boco,
Thanks for your reply.
Yes, active mode is a working choice, but you know it's not a good one, If some clients have firewall installed in their own pc, it will trigger firewall alert when data connection starts.

Shall I go to Filezilla trac system and submit a feature request about this ? I will search issues in there first.

User avatar
botg
Site Admin
Posts: 33123
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Server sent passive reply with unroutable address.

#7 Post by botg » 2013-02-28 06:53

Shall I go to Filezilla trac system and submit a feature request about this ? I will search issues in there first.
No. The problem is with your server and needs to be fixed there.

yanqian
500 Command not understood
Posts: 3
Joined: 2013-02-27 02:47
First name: qian
Last name: yan
Location: Shanghai

Re: Server sent passive reply with unroutable address.

#8 Post by yanqian » 2013-03-01 08:50

Hi,Botg,
Sorry, I noticed your reply just now, I had filed a ticket yesterday.
http://trac.filezilla-project.org/ticket/8523

Thank you all the same.

Post Reply