Upload is successful but file doesn't change

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Message
Author
Tanner
500 Command not understood
Posts: 4
Joined: 2012-10-16 16:37

Re: Upload is successful but file doesn't change

#16 Post by Tanner » 2012-10-16 18:28

To be clear, I tried clearing the cache on both my CMS and my web browser. I also opened the pages in multiple browsers to be sure it wasn't a cache issue. When I drag files into FileZilla, (just as q4legend describes) it will tell me it uploaded successfully and update the timestamp on the server, but still remain with the content of the old version of the file. It is incredibly frustrating.

User avatar
botg
Site Admin
Posts: 31661
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Upload is successful but file doesn't change

#17 Post by botg » 2012-10-17 06:29

What's your file exists action set to?

Tanner
500 Command not understood
Posts: 4
Joined: 2012-10-16 16:37

Re: Upload is successful but file doesn't change

#18 Post by Tanner » 2012-10-17 16:44

I tried a variety of options. First it was set to "Overwrite if source newer", but since that wasn't working, I tried it again (multiple times) set to "Overwrite". That also doesn't work, so my final attempted option was to delete the files from the server, then move the newer versions onto the server. It didn't work, but the really odd thing is when I remove the files and then refresh the web page, it shows an error pertaining to those files being missing. This shows that they were actually removed successfully. But as soon as I upload new versions of those old files, the server instead "undeletes" the older version of those files, but gives them a new timestamp.

Tanner
500 Command not understood
Posts: 4
Joined: 2012-10-16 16:37

Re: Upload is successful but file doesn't change

#19 Post by Tanner » 2012-10-17 17:19

I tried restarting FileZilla and restarting my computer, but it didn't help. I'm running Windows 7 64 bit. FileZilla had been working fine for me for months, and I had never modified any of the settings, other than the server connection of course. Thinking that maybe it's an issue with the server I'm connecting to, I installed CoreFTP, which is working fine.

User avatar
botg
Site Admin
Posts: 31661
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Upload is successful but file doesn't change

#20 Post by botg » 2012-10-17 17:27

What's the local directory the files are in?

jeanmi2A
500 Command not understood
Posts: 1
Joined: 2011-10-26 08:33
First name: Jean-Michel
Last name: Noblat

Re: Upload is successful but file doesn't change

#21 Post by jeanmi2A » 2012-11-03 08:22

Hi,
May I help you...after my last week attempts to upload the new 2013 version of my webpages ?
Since all advices from this forum experts, as posted on this topic, couldn't help me updating but until yesterday this above one: local directories...
I realized mine held two versions -2013's and current Year's-my Filezilla setting went on the "old" one ...so I uploaded the obsolete 2012 version.
Explanation: my option for our web site visitors easy access to our site, keeping the same URL on year Y and on Year Y+1.
But same filename on local site two subdirectories was for this webmaster misleading duplication... Even when the FTP process was successful and log timestamp changed ...
Good luck.

mcb927
500 Command not understood
Posts: 2
Joined: 2012-12-03 15:13
First name: Michael
Last name: Beard

Re: Upload is successful but file doesn't change

#22 Post by mcb927 » 2012-12-03 15:24

I am having the same issue described by other forum members above. It is not a browser cache issue, and I have made sure my page edits are saved before uploading. Here is more detail: I do my main editing and FTP activities on an iMac, and it has never had an issue with FTP. In a user testing scenario a couple of days ago, I took my laptop (MacBook Pro) to an office, copied the entire site down to my laptop using FileZilla, and used the same text editor (TextWrangler) as on my iMac to make changes. I edited a page and uploaded using my laptop it with a "successful" status reported by FileZilla after confirming the "Overwrite?" prompt, twice. When I checked the page, it was not updated on the web site. 3 people were testing the site, and none of them could see the changes, either. I was using Chrome on the MacBook Pro, one was using Chrome on a PC, and 2 were using 2 different versions of IE on Windows laptops. When I returned home, I made the same edits on my iMac, uploaded them, and the changes appeared immediately when I checked the site. The problem only occurs when I use my MacBook Pro. As a point of clarification, I have used my MacBook Pro with TextWrangler and FileZilla to edit and update the same web site in the past, and it worked fine from home and from other locations. This problem started happening just a few weeks ago.

Twayne
504 Command not implemented
Posts: 8
Joined: 2009-09-01 21:30
First name: Thomas
Last name: Wayne

Re: Upload is successful but file doesn't change

#23 Post by Twayne » 2012-12-06 00:09

Time goes on. Perhaps I have a couple more details that might help someone help us.

I have a page of links to chapters of a book I've written for 'round the world access.

I too get different or unchanged filesizes OR nothing changes. For awhile, I was able to get Filezilla (FZ) out and it too failed. I like NOFD-11 and NOF12's ftp featues set for uploads.
After deleting the file first from the server, sometimes NOF can make the upload happen. About half the time, NOT, though.
Time after time I've uploaded the same files to the same location. About half the links work, half dont. These are "File Link" PDF files, BTW, and the Adobe reader is up to date.
After checkng EVERY PDF file for usefulness locally and also with Local Publshes, when I go remote, it's always the SAME files that succee and don't succeed.
I either get a "Done" but the page is blank, OR I get and Adobe message about an invalid color space.
So, using the SAME several times tested source on my hard drive from the same directory, and uploading to the SAME directory on my web server, they should all work if any of them do, but, and it's repeatably, the same files that don't work.
NOF-12 as it turns out, uses the underscore instead of %20 for spaces, but that's not relative to anything - it doesn't matter.

Somewhere, either in my upload or in the serving of the link data from the server, damage is occurring. But why always on the SAME identical files is beyond me! At least it's repeatable.
I 've exhausted support at both my server and my NOF site to no avail. My site's gone dead in the water because of this.

I am using header_Index, body_index, and index .html FWIW, which seems to be nothing.

If you'd like a look at this, you can see it at http://twaynesdomain.com by clicking on My Book and then TOC, or directly on TOC flyout.

I'd certainly welcome any suggestions. So far I'm blaming my web server, right or wrong. As with you, this all started to happen a few weeks ago, possibly 3 or 2+.
--
Regards,

Tom`

User avatar
boco
Contributor
Posts: 24203
Joined: 2006-05-01 03:28
Location: Germany

Re: Upload is successful but file doesn't change

#24 Post by boco » 2012-12-06 05:35

For me, it says that site has no index document at all.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

Twayne
504 Command not implemented
Posts: 8
Joined: 2009-09-01 21:30
First name: Thomas
Last name: Wayne

Re: Upload is successful but file doesn't change

#25 Post by Twayne » 2012-12-06 21:13

It does have an index.html that NOF-12 uploaded. However it is not recognized for whatever reason. When I check with Filezilla however, it is NOT the same size as the source.
Using Filezilla next, and the setup to reflect the source file size, the two numbers do NOT match up - they always differ by a small percentage. Other files however display the exact file-size as the source. Two files in partcular have this symptom: index.html and toc.html. I've made certain all the letter cases are the same, too.

I also cannot upload files to the server without first DELETING it first from the server, which is a real PITA but does work. Both NOF and FZ succeed as long as I've deleted the files to upload first, usng FZ.

At least I have an upload "method" that'll work now, albeit kind of a PITA!
--
Regards,

Tom`

mcb927
500 Command not understood
Posts: 2
Joined: 2012-12-03 15:13
First name: Michael
Last name: Beard

Re: Upload is successful but file doesn't change

#26 Post by mcb927 » 2012-12-06 22:01

I may have resolved this on my MacBook Pro. So far, so good. I will repost if I run into problems.

I changed 2 things: first, I deleted FileZilla from my laptop. I noticed that the app was located in my Downloads directory, which is not where I intended it to be.
Second, I re-downloaded the file, then moved it to the Apps folder before expanding it. Once the app was installed, I deleted the compressed file and fired it up. It still retained my server connection information, and uploading an edited file a few times worked each time.

I don't know if the fix was due to re-installing the app (maybe the initial download was corrupt), moving to the Apps folder, or both. In any case, it seems to have worked.

User avatar
boco
Contributor
Posts: 24203
Joined: 2006-05-01 03:28
Location: Germany

Re: Upload is successful but file doesn't change

#27 Post by boco » 2012-12-07 05:18

When I check with Filezilla however, it is NOT the same size as the source.
Small size differences are to be expected for ASCII transfers due to alteration of line endings. See Data Type.

The site works now for me.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

ametallichick
500 Command not understood
Posts: 1
Joined: 2013-01-31 23:22

Re: Upload is successful but file doesn't change

#28 Post by ametallichick » 2013-01-31 23:25

I have cleared my cache and the webpage still won't update. I also tried using a different browser. Any ideas???

User avatar
boco
Contributor
Posts: 24203
Joined: 2006-05-01 03:28
Location: Germany

Re: Upload is successful but file doesn't change

#29 Post by boco » 2013-02-01 05:23

Simply wait. If that won't work contact your hoster.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

windymiller
500 Command not understood
Posts: 5
Joined: 2013-03-22 12:53
First name: chris
Last name: miller

Re: Upload is successful but file doesn't change

#30 Post by windymiller » 2013-03-22 13:00

try the following in order to clear the cache and view your recent upload successfully
1) press control + F5 - this should clear the cache and show your new site
2) go to options on the tools menu - then advanced - General - there you should see the cache info box - click clear now and also reduce the cache number field to zero - this way the browser wont hold onto your previous file upload

hope this helps

Post Reply