"Always trust certificate" checkbox disabled

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
User avatar
Paddy Landau
550 Permission denied
Posts: 29
Joined: 2007-09-26 13:55
First name: Paddy
Last name: Landau
Location: United Kingdom

"Always trust certificate" checkbox disabled

#1 Post by Paddy Landau » 2011-07-12 12:59

My web host uses a certificate with a different name from the FTP.

Therefore, I always get the "Unknown certificate" error.

Additionally, the certificate is expired (the date is wrong on the certificate; it comes before the start date).

I wish to check the box "Always trust certificate in future sessions." However, that checkbox has been disabled (see screenshot).

I've tried searching for a solution to this problem, and looked at my FileZilla settings, but I cannot see what to do.

Are you able to tell me what to do?

FileZilla version: 3.3.1
OS: Linux Ubuntu 10.04
Attachments
Unknown certificate.png
The certificate error message with the disabled checkbox.
Unknown certificate.png (79.96 KiB) Viewed 12550 times

User avatar
boco
Contributor
Posts: 24649
Joined: 2006-05-01 03:28
Location: Germany

Re: "Always trust certificate" checkbox disabled

#2 Post by boco » 2011-07-12 14:01

My web host uses a certificate with a different name from the FTP.

Therefore, I always get the "Unknown certificate" error.
FileZilla not inherently trusts certificates. No matter what, you'll always be presented that message.
Additionally, the certificate is expired (the date is wrong on the certificate; it comes before the start date).

I wish to check the box "Always trust certificate in future sessions." However, that checkbox has been disabled (see screenshot).

I've tried searching for a solution to this problem, and looked at my FileZilla settings, but I cannot see what to do.

Are you able to tell me what to do?
The certificate is not expired, but simply broken/invalid: It doesn't have a valid expiration date configured (stored as zero, shows as 1970-01-01 in UNIX Time). This is a required field and you should take it very seriously. We deal with precious security stuff here! Eternal certificates do not exist.

The checkbox being disabled is the direct result from the above. FileZilla doesn't allow storing certificates it deems expired. That certificate is broken and must be re-issued.

You should try with another FTP client: Does the other client show the right date?
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

User avatar
Paddy Landau
550 Permission denied
Posts: 29
Joined: 2007-09-26 13:55
First name: Paddy
Last name: Landau
Location: United Kingdom

Re: "Always trust certificate" checkbox disabled

#3 Post by Paddy Landau » 2011-07-12 14:24

boco wrote:This is a required field and you should take it very seriously. We deal with precious security stuff here! Eternal certificates do not exist.
I realise. I have checked the host (it is GoDaddy, who hosts my sites), and I am certain that it is a valid site.
boco wrote:The checkbox being disabled is the direct result from the above. FileZilla doesn't allow storing certificates it deems expired. That certificate is broken and must be re-issued.
That's a shame. I've spoken to GoDaddy, and it is completely unconcerned (the only time I've ever had less than outstanding customer service from that company). I shall try again.
boco wrote:You should try with another FTP client: Does the other client show the right date?
I tried Firefox, which did not complain, and bareFTP, which did complain. I'm sure you are right that the certificate is incorrect; but I wish I could tell FileZilla to accept it automatically without having to click it every time I use it.

Thanks for your time.

FileGamer
450 Internal Error
Posts: 38
Joined: 2014-08-16 06:26

Re: "Always trust certificate" checkbox disabled

#4 Post by FileGamer » 2014-09-19 07:46

I know you Filezilla developers will probably recommend against this, but I'm building for my own personal use, so I'd like to ask here. Where are the values (for allowing certificates expired or thought to be expired to be stored) in the source code?

FileGamer
450 Internal Error
Posts: 38
Joined: 2014-08-16 06:26

Re: "Always trust certificate" checkbox disabled

#5 Post by FileGamer » 2014-09-29 01:00

FileGamer wrote:I know you Filezilla developers will probably recommend against this, but I'm building for my own personal use, so I'd like to ask here. Where are the values (for allowing certificates expired or thought to be expired to be stored) in the source code?
*The values for the popups that appear when Filezilla sees a so-called expired certificate.

User avatar
botg
Site Admin
Posts: 32335
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: "Always trust certificate" checkbox disabled

#6 Post by botg » 2014-09-29 07:26

It appears by now the certificate in question has been updated to no longer be expired.

FileGamer
450 Internal Error
Posts: 38
Joined: 2014-08-16 06:26

Re: "Always trust certificate" checkbox disabled

#7 Post by FileGamer » 2014-09-30 05:37

botg wrote:It appears by now the certificate in question has been updated to no longer be expired.
Wha? No, I was asking about where the code for disabling the notifications of accepting expired certificates is in the source code?

User avatar
botg
Site Admin
Posts: 32335
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: "Always trust certificate" checkbox disabled

#8 Post by botg » 2014-09-30 07:05

I think that's a terrible idea, you should not do that. Certificate expiry is there for a reason. If you must for some ill-conceived reason, search the source for expired.

Post Reply