Download files with accents/special characters in path name

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
Perry Diels
500 Command not understood
Posts: 3
Joined: 2012-01-11 15:38
First name: Perry
Last name: Diels

Download files with accents/special characters in path name

#1 Post by Perry Diels » 2012-01-11 16:16

To my surprise the latest versions of Filezilla client cannot download filenames with special characters in their names (or in the path).
In my situation, the server is Windows FTP server (with Windows Server 2008 R2) and UTF8 is enabled.
The files are visible and spelled correctly from the Filezilla client, but as soon as the transfer is started it says "Critical File Error".
It is even possible with FZ to change te names on the sever side (as long as connected with granted credentials). After that the download works OK.

Downloading the same files with accents such as é è from the same server works OK with other clients. Hence I suspect a bug in F7 3.5.3. Unless there's something I'm overlooking, such as a preference or setting?

Lastly, when I choose Autodetect in the Site manager charset dialog, it is possible to browse special character folders, but not download.
But when I set "Force UTF-8" special character folders cannot be browsed.

All help and suggestions appreciated.

User avatar
botg
Site Admin
Posts: 32907
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Download files with accents/special characters in path n

#2 Post by botg » 2012-01-12 06:42

But when I set "Force UTF-8" special character folders cannot be browsed.
This means that the server does not use UTF-8.

Perry Diels
500 Command not understood
Posts: 3
Joined: 2012-01-11 15:38
First name: Perry
Last name: Diels

Re: Download files with accents/special characters in path n

#3 Post by Perry Diels » 2012-01-13 01:25

Thanks for your feedback botg.

I have double checked the server and the UTF-8 parameter is set to "True" I tried "False" and back to "True" but not difference whatsoever.
I have a similar server running (same OS etc. ....) and here no problems with FileZilla (that is with é and è and ... in the filenames). I compared al the ftp setting of the 2 servers side by side, but I could not find a difference. Unless there's somewhere a hidden feature in IIS 7.5 (or Server 2008 R2). Anyone has any idea where to look in this particular server?

There is however one difference between both servers, one is the English version and the other one is French (the latter with the problem). I cannot imagine this has something to do with it, or am I wrong?

With other ftp clients there's no problem with browsing and downloading from the French server version. Could it be that FZ has a problem with that?

Perry Diels
500 Command not understood
Posts: 3
Joined: 2012-01-11 15:38
First name: Perry
Last name: Diels

Re: Download files with accents/special characters in path n

#4 Post by Perry Diels » 2012-01-13 01:45

SOLVED!

It was the FEAT command that was set to "FALSE" which I have overlooked. Anyhow your comment about the UTF8 parameter pointed me in the right direction.
Thanks a lot!

wookiee
500 Command not understood
Posts: 2
Joined: 2020-05-06 12:45
First name: Harry
Last name: Wookiee

Re: Download files with accents/special characters in path name

#5 Post by wookiee » 2020-05-06 12:52

Years later - I know.
I'm having the same problem.
Where is the FEAT setting? What is the FEAT setting?
I've gone through every setting and am unable to find it.

User avatar
boco
Contributor
Posts: 25094
Joined: 2006-05-01 03:28
Location: Germany

Re: Download files with accents/special characters in path name

#6 Post by boco » 2020-05-11 10:41

FEAT is sent by the FTP server. There is no setting I'm aware of in any FileZilla product for disabling FEAT - It's always enabled.

Your problem might be that the server doesn't support UTF-8 (from ~1990) at all. Then, you cannot use anything besides US-English.
You could also try to force UTF-8 for a server, it's a setting in the Site Manager (Charset tab).

Last, if you know the charset the server uses, you can also enter it there. But this is in no way supported by us.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

Post Reply