Latest update not working

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
503 Bad sequence of commands
Posts: 19
Joined: 2011-07-21 18:05
First name: Bill
Last name: Dee

Latest update not working

#1 Post by fzbill » 2014-12-10 12:15

I let Filezilla auto-update to the latest version.
The first time I tried to connect it said the certificate was wrong, or something,
so I told it to accept it anyway. It's, so I have no idea what that's all about.
It always worked before.

This is the log:

Code: Select all

04:10:20	Status:	Resolving address of
04:10:20	Status:	Connecting to
04:10:20	Status:	Connection established, waiting for welcome message...
04:10:20	Response:	220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
04:10:20	Response:	220-You are user number 5 of 1000 allowed.
04:10:20	Response:	220-Local time is now 05:10. Server port: 21.
04:10:20	Response:	220-This is a private system - No anonymous login
04:10:20	Response:	220-IPv6 connections are also welcome on this server.
04:10:20	Response:	220 You will be disconnected after 15 minutes of inactivity.
04:10:20	Command:	AUTH TLS
04:10:20	Response:	234 AUTH TLS OK.
04:10:20	Status:	Initializing TLS...
04:10:21	Status:	Verifying certificate...
04:10:21	Status:	TLS connection established.
04:10:21	Command:	USER username
04:10:21	Response:	331 User username OK. Password required
04:10:21	Command:	PASS *************
04:10:21	Response:	230 OK. Current restricted directory is /
04:10:21	Status:	Server does not support non-ASCII characters.
04:10:21	Command:	PBSZ 0
04:10:21	Response:	200 PBSZ=0
04:10:21	Command:	PROT P
04:10:21	Response:	200 Data protection level set to "private"
04:10:21	Status:	Connected
04:10:21	Status:	Retrieving directory listing of "/www"...
04:10:21	Command:	CWD /www
04:10:21	Response:	250 OK. Current directory is /www
04:10:21	Command:	TYPE I
04:10:21	Response:	200 TYPE is now 8-bit binary
04:10:21	Command:	PASV
04:10:21	Response:	227 Entering Passive Mode (69,89,31,156,220,14)
04:10:21	Command:	MLSD
04:10:42	Error:	Connection timed out
04:10:42	Error:	Failed to retrieve directory listing
I tried the Connection Wizard, and it looks like it has problems, too:

Code: Select all

Connecting to
Response: 220 FZ router and firewall tester ready
USER FileZilla
Response: 331 Give any password.
PASS 3.10.0-beta2
Response: 230 logged on.
Checking for correct external IP address
IP bjc-bgi-b-e
Response: 510 Mismatch. Your IP is, ce-h-bgg-cfc
Wrong external IP address
Connection closed
OS: Windows 7 Home Premium (6.1) 64-bit SP1

User avatar
Site Admin
Posts: 33238
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse

Re: Latest update not working

#2 Post by botg » 2014-12-10 12:40

Client update at the same time the problem started might just be coincidental. To rule out a potential server issue, what does say about your server?

503 Bad sequence of commands
Posts: 19
Joined: 2011-07-21 18:05
First name: Bill
Last name: Dee

Re: Latest update not working

#3 Post by fzbill » 2014-12-10 18:48

I obfuscated the names.
It seems to work with one warning.

Plain FTP:

Code: Select all

Status: Resolving address of

Status: Connecting to

Warning: The entered address does not resolve to an IPv6 address.

Status: Connected, waiting for welcome message...

Reply: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------

Reply: 220-You are user number 2 of 1000 allowed.

Reply: 220-Local time is now 11:37. Server port: 21.

Reply: 220-This is a private system - No anonymous login

Reply: 220-IPv6 connections are also welcome on this server.

Reply: 220 You will be disconnected after 15 minutes of inactivity.

Command: CLNT on behalf of

Reply: 530 You aren't logged in

Command: USER username

Reply: 331 User username OK. Password required

Command: PASS *************

Reply: 230 OK. Current restricted directory is /

Command: SYST

Reply: 215 UNIX Type: L8

Command: FEAT

Reply: 211-Extensions supported:

Reply: EPRT

Reply: IDLE

Reply: MDTM

Reply: SIZE

Reply: MFMT


Reply: MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;

Reply: MLSD


Reply: PBSZ

Reply: PROT

Reply: ESTA

Reply: PASV

Reply: EPSV

Reply: SPSV

Reply: ESTP

Reply: 211 End.

Command: PWD

Reply: 257 "/" is your current location

Status: Current path is /

Command: TYPE I

Reply: 200 TYPE is now 8-bit binary

Command: PASV

Reply: 227 Entering Passive Mode (69,89,31,156,25,223)

Command: MLSD

Status: Data connection established.

Reply: 150 Accepted data connection

Listing: type=cdir;sizd=4096;modify=20141202041705;UNIX.mode=0710;UNIX.uid=2387;UNIX.gid=12;unique=821g3058001; .

Listing: type=pdir;sizd=4096;modify=20141202041705;UNIX.mode=0710;UNIX.uid=2387;UNIX.gid=12;unique=821g3058001; ..

Listing: type=dir;sizd=4096;modify=20110329024637;UNIX.mode=0700;UNIX.uid=2387;UNIX.gid=2387;unique=821g3079047; dir

Listing: type=dir;sizd=4096;modify=20130117104719;UNIX.mode=0700;UNIX.uid=2387;UNIX.gid=2387;unique=821g306c288; dir

Listing: type=file;size=66;modify=20140715101119;UNIX.mode=0600;UNIX.uid=2387;UNIX.gid=2387;unique=821g30596f3; file

Listing: type=file;size=24;modify=20071119210247;UNIX.mode=0644;UNIX.uid=2387;UNIX.gid=2387;unique=821g30580f7; file

Listing: type=file;size=191;modify=20071018215100;UNIX.mode=0644;UNIX.uid=2387;UNIX.gid=2387;unique=821g30580f8; file

Listing: type=file;size=124;modify=20071018215100;UNIX.mode=0644;UNIX.uid=2387;UNIX.gid=2387;unique=821g30580f9; file

Listing: type=file;size=28;modify=20130926175931;UNIX.mode=0600;UNIX.uid=2387;UNIX.gid=2387;unique=821g30580fa; file

Listing: type=dir;sizd=4096;modify=20141117053456;UNIX.mode=0700;UNIX.uid=2387;UNIX.gid=2387;unique=821g306401c; dir

Listing: type=dir;sizd=4096;modify=20140715085509;UNIX.mode=0700;UNIX.uid=2387;UNIX.gid=2387;unique=821g3058004; dir

Listing: type=file;size=21;modify=20140715091643;UNIX.mode=0644;UNIX.uid=2387;UNIX.gid=2387;unique=821g30594df; file

Listing: type=file;size=383;modify=20071119210247;UNIX.mode=0644;UNIX.uid=2387;UNIX.gid=2387;unique=821g30580fb; file

Listing: type=dir;sizd=4096;modify=20120222202514;UNIX.mode=0750;UNIX.uid=2387;UNIX.gid=2387;unique=821g3058005; dir

Listing: type=dir;sizd=4096;modify=20121104015337;UNIX.mode=0755;UNIX.uid=2387;UNIX.gid=2387;unique=821g309009f; dir

Listing: type=file;size=15;modify=20080923101949;UNIX.mode=0600;UNIX.uid=2387;UNIX.gid=2387;unique=821g30580fc; file

Listing: type=dir;sizd=4096;modify=20110411070039;UNIX.mode=0700;UNIX.uid=2387;UNIX.gid=2387;unique=821g307464e; dir

Listing: type=dir;sizd=4096;modify=20080519060138;UNIX.mode=0750;UNIX.uid=2387;UNIX.gid=12;unique=821g3058006; dir

Listing: type=file;size=12;modify=20140128224448;UNIX.mode=0600;UNIX.uid=2387;UNIX.gid=2387;unique=821g3059564; file

Listing: type=dir;sizd=4096;modify=20140326141828;UNIX.mode=0755;UNIX.uid=2387;UNIX.gid=2387;unique=821gd2c8002; dir

Listing: type=dir;sizd=4096;modify=20080530133618;UNIX.mode=0700;UNIX.uid=2387;UNIX.gid=2387;unique=821g3058007; dir

Listing: type=file;size=0;modify=20071120081502;UNIX.mode=0644;UNIX.uid=2387;UNIX.gid=2387;unique=821g30580ff; file

Listing: type=file;size=24;modify=20140326134446;UNIX.mode=0600;UNIX.uid=2387;UNIX.gid=2387;unique=821g3058100; file

Listing: type=dir;sizd=4096;modify=20080128123436;UNIX.mode=0700;UNIX.uid=2387;UNIX.gid=2387;unique=821g3058008; dir

Listing: type=file;size=658;modify=20071119210247;UNIX.mode=0644;UNIX.uid=2387;UNIX.gid=2387;unique=821g3058101; file

Reply: 226-Options: -a -l

Reply: 226 38 matches total

Listing: type=OS.unix=slink:;size=34;modify=20100224214718;UNIX.mode=0777;UNIX.uid=2387;UNIX.gid=2387;unique=821g3058002; link

Listing: type=file;size=1;modify=20090124100733;UNIX.mode=0640;UNIX.uid=2387;UNIX.gid=2387;unique=821g3058102; file

Listing: type=dir;sizd=4096;modify=20140715092246;UNIX.mode=0750;UNIX.uid=2387;UNIX.gid=12;unique=821g3058009; dir

Listing: type=dir;sizd=4096;modify=20130406172122;UNIX.mode=0755;UNIX.uid=2387;UNIX.gid=2387;unique=821g305800a; dir

Listing: type=dir;sizd=4096;modify=20140407015549;UNIX.mode=0751;UNIX.uid=2387;UNIX.gid=2387;unique=821g305800b; dir

Listing: type=dir;sizd=4096;modify=20120222203933;UNIX.mode=0755;UNIX.uid=2387;UNIX.gid=2387;unique=821g3124156; dir

Listing: type=dir;sizd=4096;modify=20100625200907;UNIX.mode=0755;UNIX.uid=2387;UNIX.gid=2387;unique=821g305800c; dir

Listing: type=dir;sizd=4096;modify=20141007074132;UNIX.mode=0755;UNIX.uid=2387;UNIX.gid=2387;unique=821g305800d; dir

Listing: type=dir;sizd=4096;modify=20130406172019;UNIX.mode=0755;UNIX.uid=2387;UNIX.gid=2387;unique=821g305800e; dir

Listing: type=dir;sizd=4096;modify=20140327025505;UNIX.mode=0750;UNIX.uid=2387;UNIX.gid=2387;unique=821g306c8d5; dir

Listing: type=dir;sizd=4096;modify=20141207111701;UNIX.mode=0755;UNIX.uid=2387;UNIX.gid=2387;unique=821g305800f; dir

Listing: type=file;size=24123;modify=20071018215100;UNIX.mode=0644;UNIX.uid=2387;UNIX.gid=2387;unique=821g3058103; file

Listing: type=OS.unix=slink:;size=11;modify=20100224214718;UNIX.mode=0777;UNIX.uid=2387;UNIX.gid=2387;unique=821g3058003; link

Status: Success

Your server is working and assorted routers/firewalls have been correctly configured for plain basic FTP as performed by this test. However there have been warnings about compatibility issues, not all users will be able to use your server.

For maximum compatibility, consider resolving these warnings.

Same result for implicit.

But explicit failed with:

Code: Select all

Command: MLSD

Error: Connection timed out


Error: Connection timed out

Timeouts are usually caused by some router and/or firewall that is interrupting the connection.
Try uninstalling all firewalls and plug your computer directly into your modem, thus bypassing the router.
I don't understand why it's giving the above advice. I have to use my computer the way it's setup.
That is, I have to use my firewall and my router.

User avatar
Site Admin
Posts: 33238
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse

Re: Latest update not working

#4 Post by botg » 2014-12-11 08:41

The problem is with the server. You need to contact your server administrator or server hosting provider for assistance.

503 Bad sequence of commands
Posts: 19
Joined: 2011-07-21 18:05
First name: Bill
Last name: Dee

Re: Latest update not working

#5 Post by fzbill » 2014-12-11 08:48

This is the same thing that happened a year or two ago that made
Filezilla unusable by many people.

You can't expect server hosting companies to change something to
work with Filezilla.

It's RIDICULOUS that Filezilla works one day and then doesn't the next day
with an upgrade. (with Filezilla being the only thing that has changed)


Plain and simple.

I will revert to the version before 3.10.0.-beta2 that actually works.

User avatar
Site Admin
Posts: 33238
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse

Re: Latest update not working

#6 Post by botg » 2014-12-11 09:59

How is it a bug in FileZilla, if confirms that the issue is with the server?

Post Reply