Updated To Version 3.10.0 Now Receiving Errors

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Locked
Message
Author
cyberpvnk
500 Command not understood
Posts: 1
Joined: 2015-01-21 22:26
First name: Jim
Last name: S

Re: Updated To Version 3.10.0 Now Receiving Errors

#121 Post by cyberpvnk » 2015-01-21 22:52

@Botg, I work in dev and I get what you're saying in a lot of posts but your analogies and criticisms aren't helping this issue. I work at a large company and have NO control over the FTP server we run. I also use FTP to give my customers a way to pull data (security is not a concern) down and now I need to issue a communication informing them how to work around this issue while my IT department works to fix the TLS issue. While the workaround is simple for me to do I know it is going to cause issues for my customer base which in turn causes me problems.

Don't be so heavy handed next time and you wouldn't lose so many users.

Other FTP clients connected with no issue which doesn't mean they are better, but did help in troubleshooting this.

To everyone else complaining, just remember that sometimes you get what you pay for.

User avatar
boco
Contributor
Posts: 25154
Joined: 2006-05-01 03:28
Location: Germany

Re: Updated To Version 3.10.0 Now Receiving Errors

#122 Post by boco » 2015-01-22 04:11

In the Site Manager, under Encryption.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

User avatar
botg
Site Admin
Posts: 32975
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Updated To Version 3.10.0 Now Receiving Errors

#123 Post by botg » 2015-01-22 09:48

@cyberpvnk: Please don't shift the blame to me if your server administrators need too long to make a really, really simple configuration change.

User avatar
botg
Site Admin
Posts: 32975
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Updated To Version 3.10.0 Now Receiving Errors

#124 Post by botg » 2015-01-22 09:55

botg wrote:@cyberpvnk: Please don't shift the blame to me if your server administrators need too long to make a really, really simple configuration change.
[...]just remember that sometimes you get what you pay for.
I'll bite: Looks like you need to pay your server administrators more. :twisted:
I also use FTP to give my customers a way to pull data (security is not a concern) down
If security is not a concern, I'm sure you won't mind posting the login credentials for your server here. If security is not a concern, why do you not have administrator permissions on the server to simply change its configuration?

Security is always a concern.

Bertie
500 Command not understood
Posts: 1
Joined: 2015-01-22 23:06
First name: Roberta
Last name: Edwards

Re: Updated To Version 3.10.0 Now Receiving Errors

#125 Post by Bertie » 2015-01-22 23:14

I too am getting this error when trying to connect........
I, however, know nothing of the workings of how to change to FTP or where to even start looking. Could some one help me please?

Status: Resolving address of xxxxxxx.com.au
Status: Connecting to 202.40.166.157:21...
Status: Connection established, waiting for welcome message...
Status: Initializing TLS...
Status: Verifying certificate...
Status: TLS connection established.
Status: Server does not support non-ASCII characters.
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/" is your current location
Command: TYPE I
Response: 200 TYPE is now 8-bit binary
Command: PASV
Response: 227 Entering Passive Mode (202,40,166,157,211,82)
Command: MLSD
Error: Connection timed out
Error: Failed to retrieve directory listing

sava700
504 Command not implemented
Posts: 7
Joined: 2015-01-17 18:16

Re: Updated To Version 3.10.0 Now Receiving Errors

#126 Post by sava700 » 2015-01-23 00:42

botg wrote:
@botg: Could you insert a warning (at startup) into future FileZilla versions in case they detect being over, let's say, six months old?
"Warning: You are using an obsolete FileZilla version that may suffer from bugs and security vulnerabilities." etc.
Basically annoying every Debian user on the planet? ;)

Joke aside, it's possible to implement something like this for the official flavor of FileZilla only.
I don't see how this would be annoying at all...its basic disable/enable features for a popular program.

I'd rather not be warned of updates and update when I feel like it after I review the current revisions and so on.

In the case of what I have - I've made the edit to the xml file and stopped the notifications for now but I'm going to sit on 3.9.0.6 because its working for me... If it's not broken then I'm not going to fix it.

User avatar
boco
Contributor
Posts: 25154
Joined: 2006-05-01 03:28
Location: Germany

Re: Updated To Version 3.10.0 Now Receiving Errors

#127 Post by boco » 2015-01-23 06:01

I don't see how this would be annoying at all...its basic disable/enable features for a popular program.
That warning would be independent from updates and could not be disabled. However, only if the build is very old.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

turitook
500 Command not understood
Posts: 1
Joined: 2015-01-24 18:56
First name: Turi
Last name: took

Re: Updated To Version 3.10.0 Now Receiving Errors

#128 Post by turitook » 2015-01-24 18:58

i cant connect my website via filezilla it always giving me .net error i dont get it
Last edited by boco on 2015-01-24 21:41, edited 1 time in total.
Reason: Removed possible advertising.

pelukapuskas
500 Command not understood
Posts: 2
Joined: 2015-01-27 07:42
First name: Angel
Last name: Perez

Re: Updated To Version 3.10.0 Now Receiving Errors

#129 Post by pelukapuskas » 2015-01-27 07:48

Good morning

I have an own server through a hard drive in the cloud WD Ex2.

I do not know as I have to set the parameters for access via Filezilla.

I enabled the TLS Explicit option but to take the test page shows me the following error.

Previously accessed smoothly by FTP, having ports correctly redirected.

Thank you very much for your help.


Status: Connected, waiting for welcome message...
Reply: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Reply: 220-You are user number 1 of 10 allowed.
Reply: 220-Local time is now 08:40. Server port: 21.
Reply: 220-IPv6 connections are also welcome on this server.
Reply: 220 You will be disconnected after 10 minutes of inactivity.
Command: CLNT https://ftptest.net on behalf of 88.2.21.128
Reply: 530 You aren't logged in
Command: AUTH TLS
Reply: 234 AUTH TLS OK.
Status: Performing TLS handshake...
Status: TLS handshake successful, verifying certificate...
Command: USER aescudero
Reply: 331 User aescudero OK. Password required
Command: PASS **********
Reply: 230 OK. Current restricted directory is /
Command: SYST
Reply: 215 UNIX Type: L8
Command: FEAT
Reply: 211-Extensions supported:
Reply: EPRT
Reply: IDLE
Reply: MDTM
Reply: SIZE
Reply: REST STREAM
Reply: MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
Reply: MLSD
Reply: ESTP
Reply: PASV
Reply: EPSV
Reply: SPSV
Reply: ESTA
Reply: AUTH TLS
Reply: PBSZ
Reply: PROT
Reply: 211 End.
Command: PBSZ 0
Reply: 200 PBSZ=0
Command: PROT P
Reply: 200 Data protection level set to "private"
Command: PWD
Reply: 257 "/" is your current location
Status: Current path is /
Command: TYPE I
Reply: 200 TYPE is now 8-bit binary
Command: PASV
Reply: 227 Entering Passive Mode (192,168,1,109,217,42)
Error: Server returned unroutable private IP address in PASV reply

User avatar
botg
Site Admin
Posts: 32975
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Updated To Version 3.10.0 Now Receiving Errors

#130 Post by botg » 2015-01-27 09:06

pelukapuskas wrote:Command: PASV
Reply: 227 Entering Passive Mode (192,168,1,109,217,42)
Error: Server returned unroutable private IP address in PASV reply
Your server is behind a NAT router. Neither the server nor the NAT router are properly configured for FTP over TLS.
Previously accessed smoothly by FTP, having ports correctly redirected.
Actually no, ports weren't properly configured. See the section about malicious routers: https://ftptest.net/Help

pelukapuskas
500 Command not understood
Posts: 2
Joined: 2015-01-27 07:42
First name: Angel
Last name: Perez

Re: Updated To Version 3.10.0 Now Receiving Errors

#131 Post by pelukapuskas » 2015-01-27 17:23

Hello,

In the WD server I can activate the Explicit TLS but do not know which ports have to activate for redirecting them to the internal IP of the computer.

You can tell the ports to redirect to the WD ??

Thank you very much.

brodieM
500 Command not understood
Posts: 1
Joined: 2015-01-27 17:43
First name: Brodie
Last name: M

Re: Updated To Version 3.10.0 Now Receiving Errors

#132 Post by brodieM » 2015-01-27 18:04

I made the mistake of updating and now I have to go in and manually update 100s of saved site connections BACK to plain FTP. So what if some system admin somewhere doesn't have their servers configured well. This update didn't just offer a new 'feature', it changed my settings for existing site connections I've set up. It is now a pain in my ass to use this software. I'm rolling back my install and disabling updates. (devs, sorry if that makes me a caveman but if you want me using your software that's what I have to do) The only reason I'm even staying with this program at this point is because of all my saved connections.

It's a great program and I love that it's free, but honestly guys, you're being twats.

User avatar
botg
Site Admin
Posts: 32975
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Updated To Version 3.10.0 Now Receiving Errors

#133 Post by botg » 2015-01-28 09:01

Oh yes, shoot the messenger that brings you the news that your server is badly configured or broken.

JaxRolo
500 Command not understood
Posts: 2
Joined: 2015-01-28 13:38
First name: ROlando
Last name: Almaguer

Re: Updated To Version 3.10.0 Now Receiving Errors

#134 Post by JaxRolo » 2015-01-28 13:45

botg wrote:FileZilla now automatically uses FTP over TLS if the server accepts it. Unfortunately there are a few badly configured servers out there. These servers need to be fixed.
Where can I find this setting. I can not find it.

JaxRolo
500 Command not understood
Posts: 2
Joined: 2015-01-28 13:38
First name: ROlando
Last name: Almaguer

Re: Updated To Version 3.10.0 Now Receiving Errors

#135 Post by JaxRolo » 2015-01-28 14:00

nodirectorylisting wrote:
fischzilla wrote:I found that after the update my encryption was changed to 'FTP over TLS if available'. I changed it to 'plain FTP' and it is working now.
Same problem here. I could not find how to change the encryption back to 'plain FTP' .. please advise.. thanks
...
ok .. found the setting .. changed to 'plain ftp'... now getting 'critical error: cannot connect to server'

at this point wish I had not upgraded .. looked for a downgrade version.. is this possible? was working perfectly for years.. would like to return to that and will not upgrade in the future

...
ok - got the 'plain ftp' to work.. thanks

How did you fix the critical error? I'm getting the same thing?

Locked