Disable check for automatic updates not working

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Message
Author
raybanned
500 Command not understood
Posts: 1
Joined: 2015-03-04 00:09
First name: Alexander
Last name: Fishburn

Disable check for automatic updates not working

#1 Post by raybanned » 2015-03-04 00:16

Apologies if this question has been asked already. Search returned very little.

I am using v3.9.0.6 of FileZilla for Mac OS X. I updated to 3.10.2 last month, but experienced connection problems and rolled back.

Now every time I open FileZilla, I am prompted to update, even though I have set "automatically check for updates" to Never in Settings.

That's fine, but every time I close the prompt, this file is installed in the root of my Documents folder: FileZilla_3.10.2_macosx-x86.app.tar.bz2

I close the prompt and delete that file at least once a day. Is there a way to prevent this, short of always keeping the client open?

User avatar
botg
Site Admin
Posts: 33357
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Disable check for automatic updates not working

#2 Post by botg » 2015-03-04 08:20

It doesn't check for updates. It already knows there is an update.

Old versions are not supported, please update to the most recent version.

enchant
504 Command not implemented
Posts: 9
Joined: 2015-03-10 13:06
First name: pat
Last name: traynor

Re: Disable check for automatic updates not working

#3 Post by enchant » 2015-03-10 13:12

botg wrote:It doesn't check for updates. It already knows there is an update.

Old versions are not supported, please update to the most recent version.
This is a catch-22. The problem is that the disable auto-update option doesn't work. Your solution is to update. We do not WANT to update. The version we have works just fine as it is. Are you saying that the auto-update option was broken in all older versions but it absolutely has been fixed in the current version?

User avatar
botg
Site Admin
Posts: 33357
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Disable check for automatic updates not working

#4 Post by botg » 2015-03-10 15:24

If checking for updates is disabled it doesn't check for updates. It still displays update availability if it already knows about a new update being available.

User avatar
boco
Contributor
Posts: 25448
Joined: 2006-05-01 03:28
Location: Germany

Re: Disable check for automatic updates not working

#5 Post by boco » 2015-03-10 15:30

In other words: The version number of the update it found last before you disabled the check is still stored in the settings file.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

enchant
504 Command not implemented
Posts: 9
Joined: 2015-03-10 13:06
First name: pat
Last name: traynor

Re: Disable check for automatic updates not working

#6 Post by enchant » 2015-03-10 15:32

I have update checking disabled. In ...\appdata\roaming\filezilla\filezilla.xml is:
<Setting name="Update Check">0</Setting>

When I start up the program, a popup box appears titled "Check for updates" saying
"A new version of Filezilla is available" ...

I close it and shut down Filezilla.

I go to my downloads directory and delete
FileZilla_3.10.2_win32-setup.exe

I start up Filezilla and no popup box.
Shut down Filezilla and restart it, popup box is back and .exe is is in download directory again.

If there's something I'm doing incorrectly, please let me know.

enchant
504 Command not implemented
Posts: 9
Joined: 2015-03-10 13:06
First name: pat
Last name: traynor

Re: Disable check for automatic updates not working

#7 Post by enchant » 2015-03-10 15:39

boco wrote:In other words: The version number of the update if found last before you disabled the check is still stored in the settings file.
I found a line beginning with this in that .xml file:
<Setting name="Update Check New Version">nightly 2015-03-10 http://filezilla-project.org/nightlies/ ... _setup.exe

I deleted that line, and it appears to have fixed the problem. Is this what you were referring to?

User avatar
botg
Site Admin
Posts: 33357
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Disable check for automatic updates not working

#8 Post by botg » 2015-03-10 15:40

Possibly. Old versions aren't supported so I can't tell.

enchant
504 Command not implemented
Posts: 9
Joined: 2015-03-10 13:06
First name: pat
Last name: traynor

Re: Disable check for automatic updates not working

#9 Post by enchant » 2015-03-10 15:48

botg wrote:Possibly. Old versions aren't supported so I can't tell.
I didn't specify, but I'm running 3.10.1.1, which was the current stable version barely a week ago.

HoldOffHunger
500 Command not understood
Posts: 1
Joined: 2016-04-27 12:49

Re: Disable check for automatic updates not working

#10 Post by HoldOffHunger » 2016-04-27 12:52

botg wrote:It doesn't check for updates. It already knows there is an update.

Old versions are not supported, please update to the most recent version.
In order to use the "don't update feature," we need to update to a version that uses the "don't update feature"? But then how do we use the "don't update featuer"?
botg wrote:Possibly. Old versions aren't supported so I can't tell.
I'm sorry, you're speaking in English, the beta version, 0.51.0, which is not supported among most English speakers, so I really can't tell what you're even trying to say.

User avatar
boco
Contributor
Posts: 25448
Joined: 2006-05-01 03:28
Location: Germany

Re: Disable check for automatic updates not working

#11 Post by boco » 2016-04-27 14:26

FileZilla Client's Update check can be disabled. However, any updates already found and stored in its configuration prior to disabling the check will still be shown.

0.9.51 sounds like an unsupported version of FileZilla Server (a different product). Server does not have update check and must be updated manually.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

wirfen
500 Command not understood
Posts: 2
Joined: 2016-05-10 13:57
First name: Wirfen
Last name: Wirfen

Re: Disable check for automatic updates not working

#12 Post by wirfen » 2016-05-10 14:01

botg wrote:If checking for updates is disabled it doesn't check for updates. It still displays update availability if it already knows about a new update being available.
This havent sense, I cant work with filezilla, all the days "News update" every day!! Im so tired!! Im looking for other aplication. I hope you change that in the future... with AN UPDATE!!

User avatar
botg
Site Admin
Posts: 33357
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Disable check for automatic updates not working

#13 Post by botg » 2016-05-10 14:05

There are no daily updates, there are maybe one or two updates per month.

wirfen
500 Command not understood
Posts: 2
Joined: 2016-05-10 13:57
First name: Wirfen
Last name: Wirfen

Re: Disable check for automatic updates not working

#14 Post by wirfen » 2016-05-10 14:08

botg wrote:There are no daily updates, there are maybe one or two updates per month.
Give the chance to disable it, look with the update from windows X to windows 10, bad idea, we arent idiots.

mathiasl
500 Command not understood
Posts: 3
Joined: 2020-04-02 10:34
First name: Matthias
Last name: L

Re: Disable check for automatic updates not working

#15 Post by mathiasl » 2020-04-02 11:12

Solution in answer #7 in this thread.

A more detailed description here:
viewtopic.php?p=173137#p173137

Post Reply