Cannot Edit Field Input

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
Ciaraldi
500 Command not understood
Posts: 3
Joined: 2015-09-15 07:28
First name: Mike
Last name: Ciaraldi

Cannot Edit Field Input

#1 Post by Ciaraldi » 2015-09-16 01:17

I am running Xubuntu (Ubuntu with Xfce desktop) 15.04 on an AMD A10. I installed Filezilla from the distro repository about a year ago and have kept it updated, and it has worked fine. Recently I did an update (to Filezilla 3.9.0.5, the latest on the Xubuntu repository), and now I have a problem.

I can now type text into fields in Filezilla (for host name and such) but cannot edit them. For example, if I type some text and hit the backspace key, nothing happens. Similarly, the left and right arrow keys do not move the cursor. You might think that this would be just an inconvenience, and I should just be careful and not make any typing mistakes, but it is worse than that.

When I try to create a new site in the site manager, it defaults to anonymous login, and fills in username=anonymous and password=something hidden. When I change to other login types, such as Normal or Ask for Password, the username and password are still there, and since I cannot backspace (or highlight and hit Delete), there is no way to remove them. So I cannot define sites I can actually use!

I tried downloading the source for 3.13. It compiled and installed but has the same problem. Same with 3.14RC1 and 2.

Other programs, such as the shell and Firefox do not have this problem -- I can type and edit as much as I want.

I did some Googling and found a suggestion that changing the "input method" would help, but I don't know how to do this. I have been a Unix, Linux, and XWindows user for many years, but the way configuration is done has changed so many times over the years that I have trouble keeping it all straight.

Has anyone else seen this? Does anyone have any suggestions? Thanks!

User avatar
botg
Site Admin
Posts: 32607
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Cannot Edit Field Input

#2 Post by botg » 2015-09-16 07:10

Please try this: Open a terminal and execute the following command:

Code: Select all

sudo ibus exit
Does it then work?

Ciaraldi
500 Command not understood
Posts: 3
Joined: 2015-09-15 07:28
First name: Mike
Last name: Ciaraldi

Re: Cannot Edit Field Input

#3 Post by Ciaraldi » 2015-09-16 07:47

botg wrote:Please try this: Open a terminal and execute the following command:

Code: Select all

sudo ibus exit
Does it then work?
Hooray! Doing that immediately causes Filezilla, both version 3.9.0.5 and 3.14RC2, to work properly. In fact, I had 3.9.0.5 open at the time I typed that command, and it started working without having to even exit Filezilla. I did exit, then restart, Filezilla, and again it worked. Thank you, botg!

Rebooting brought back the problem. So how do I make the fix permanent? I should mention that I only intend to ever type in English. I have just run ibus-setup, and I see that English is the only input method currently installed.

User avatar
botg
Site Admin
Posts: 32607
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Cannot Edit Field Input

#4 Post by botg » 2015-09-16 11:33

I don't know.

Ciaraldi
500 Command not understood
Posts: 3
Joined: 2015-09-15 07:28
First name: Mike
Last name: Ciaraldi

Re: Cannot Edit Field Input

#5 Post by Ciaraldi » 2015-09-17 00:41

Acting on a tip from someone else, I went to the Ubuntu Software Center app and installed ibus-gtk, which is the version which works with Gnome specifically. In this case I thought maybe i should uninstall plain ibus first, but when I went to that entry it listed ibus-gtk as one of its optional add-ons. So I clicked the checkbox next to ibus-gtk, then clicked Apply Changes. It installed without error, but did not seem to fix the problem. But then I rebooted, and now it seems to work fine. So that is the fix -- install ibus-gtk, then reboot. Thanks for pointing me in the right direction!

aleoreina
500 Command not understood
Posts: 1
Joined: 2020-01-25 13:14
First name: Angel
Last name: Reina

Re: Cannot Edit Field Input

#6 Post by aleoreina » 2020-01-25 13:18

botg wrote:
2015-09-16 07:10
Please try this: Open a terminal and execute the following command:

Code: Select all

sudo ibus exit
Does it then work?

Hello.

This really works to me on: XUbuntu 18.04

Thank you

Post Reply