FileZilla Forums

Welcome to the official discussion forums for FileZilla
Donate to project
It is currently 2014-04-23 14:21

All times are UTC




Post new topic Reply to topic  [ 22 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: 2007-10-21 22:16 
Offline
504 Command not implemented

Joined: 2007-10-21 22:04
Posts: 7
I am having a problem connecting to my server Mac OS X sftp server at home using an XP remote client. I'm using the default Remote Login via SSH, which uses SSH and the sftp_server.

I just downloaded FZ 3.0.2.1 and imported my settings from 2.2.28. With the new version I am unable to connect to my server from the remote client. With 2.2.28 I have no problem and the connection is quick. I have tried connecting using the IP and also my domain name, neither work. My server is setup behind a simple router which is forwarding port 22 traffic to my internal server.

Here is the problem I am getting when trying to connect from the remote computer using FZ 3.

Status: Connecting to ------------------:22...
Response: fzSftp started
Command: open "username@myserver.org" 22
Error: Connection timed out
Error: Could not connect to server

Help would be appreciated.


Last edited by chambs10 on 2007-10-23 04:47, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: 2007-10-21 22:36 
Offline
Site Admin
User avatar

Joined: 2004-02-23 20:49
Posts: 22552
Please set debug level to 3 in the settings and post another log.


Top
 Profile  
 
 Post subject: Debug Mode Output
PostPosted: 2007-10-22 06:09 
Offline
504 Command not implemented

Joined: 2007-10-21 22:04
Posts: 7
Here is the result. I have substituted my domain name and IP, but left the rest of the information verbatim.

Status: Connecting to myserver.org:22...
Trace: Going to execute "C:\Program Files\FileZilla Client\fzsftp.exe"
Response: fzSftp started
Trace: CSftpControlSocket::ConnectParseResponse(fzSftp started)
Command: open "username@myserver.org" 22
Trace: Looking up host "myserver.org"
Trace: Connecting to XXX.XXX.XXX.XXX port 22
Trace: Server version: SSH-1.99-OpenSSH_4.5
Trace: Using SSH protocol version 2
Trace: We claim version: SSH-2.0-PuTTY_Local:_Oct_17_2007_21:18:37
Error: Connection timed out
Trace: CSftpControlSocket::ResetOperation(2114)
Trace: CControlSocket::ResetOperation(2114)
Error: Could not connect to server
Status: Waiting to retry...
Status: Connecting to myserver.org:22...
Trace: Going to execute "C:\Program Files\FileZilla Client\fzsftp.exe"
Response: fzSftp started
Trace: CSftpControlSocket::ConnectParseResponse(fzSftp started)
Command: open "username@myserver.org" 22
Trace: Looking up host "myserver.org"
Trace: Connecting to XXX.XXX.XXX.XXX port 22
Trace: Server version: SSH-1.99-OpenSSH_4.5
Trace: Using SSH protocol version 2
Trace: We claim version: SSH-2.0-PuTTY_Local:_Oct_17_2007_21:18:37
Trace: Doing Diffie-Hellman group exchange
Error: Connection timed out
Trace: CSftpControlSocket::ResetOperation(2114)
Trace: CControlSocket::ResetOperation(2114)
Error: Could not connect to server


Top
 Profile  
 
 Post subject:
PostPosted: 2007-10-22 20:13 
Offline
Site Admin
User avatar

Joined: 2004-02-23 20:49
Posts: 22552
Nothing unusual in the log. I have no idea why it times out. Can you please the psftp component from PuTTY? FileZilla's SFTP support is based on that. Only if Putty's psftp works, the problem is in FileZilla.


Top
 Profile  
 
 Post subject:
PostPosted: 2007-10-22 22:01 
Offline
504 Command not implemented

Joined: 2007-10-21 22:04
Posts: 7
Okay, here is the output. It look like it might have something to do with the way authentication works between Putty and my server. One difference is that FZ doesn't show me the key fingerprint. I thought I removed that from the registry SimonTimor so it would ask me to accept the certificate next time I tried to connect.

I've tried to set different authentication modes in FZ, but none of them work. When using Putty, it seems that the default is keyboard-interactive, as shown in the snippet below. However, I tried eliminating that option from my server in the sshd-config and tried using the password authentication. The only difference is that after I sent the password the console says "password sent". From there it gives me the same access denied response.

Code:
psftp.exe -v "open username@myserver.org"
looking up host "myserver.org"
Connecting to XXX.XXX.XXX.XXX port 22
Server version: SSH-1.99-OpenSSH_4.5
We claim version: SSH-2.0-PuTTY_Release_0.60
Using SSH protocol version 2
Doing Diffie-Hellman group exchange
Doing Diffie-Hellman key exchange with hash SHA-256
Host key fingerprint is:
ssh-rsa 2048 blah:blah:blah:blah
Initialised AES-256 SDCTR client->server encryption
Initialised HMAC-SHA1 client->server MAC algorithm
Initialised AES-256 SDCTR server->client encryption
Initialised HMAC-SHA1 server->client MAC algorithm
Using username "open username".
Using keyboard-interactive authentication.
Password:
Access denied
Access denied
Using keyboard-interactive authentication.
Password:
Access denied
Access denied



Is there that much of a difference in the way connections were made between FZ 2.2.28 and FZ 3? This may help us figure it out.

Thank you for your quick responses!


Top
 Profile  
 
 Post subject: Log in OK with psftp
PostPosted: 2007-10-22 22:43 
Offline
504 Command not implemented

Joined: 2007-10-21 22:04
Posts: 7
I have been able to successfully login using psftp.

When connecting with psftp I used the command:

Code:
psftp.exe -v "open username@myserver.org"


I noticed that after the keys were exchanged the program said:

Code:
Using username "open username"


This is a problem because actually, the correct user name is "username" not "open username". So, I tried the following:

Code:
psftp.exe -v "username@myserver.org"


Then, after the keys were exchanged the program said:

Code:
Using username "username"


I then inserted my password and was given access, connection at last! I suspect, based on the debug messages given in FZ 3, that FZ is issuing an incorrect command. Instead of FZ issuing the command:

Code:
open "username@myserver.org" 22


Perhaps you can eliminate the word "open" from the command, or is this how fzsftp requires the command?

Either way, perhaps this has helped you out. Let me know if you have any more questions.


Top
 Profile  
 
 Post subject:
PostPosted: 2007-10-22 23:04 
Offline
Site Admin
User avatar

Joined: 2004-02-23 20:49
Posts: 22552
Code:
Command: open "username@myserver.org" 22


That's actually is the right command. Try using the open command from inside psftp, you don't have to pass the host on the commandline.


Top
 Profile  
 
 Post subject: Command
PostPosted: 2007-10-23 04:46 
Offline
504 Command not implemented

Joined: 2007-10-21 22:04
Posts: 7
Are we using a different version of psftp? That command does not work for the version I am using. When I type the command you request, I get the following:

Code:
>psftp.exe open "username@myserver.org"
PuTTY Secure File Transfer (SFTP) client
Release 0.60
Usage: psftp [options] [user@]host
Options:
  -V        print version information and exit
  -pgpfp    print PGP key fingerprints and exit
  -b file   use specified batchfile
  -bc       output batchfile commands
  -be       don't stop batchfile processing if errors
  -v        show verbose messages
  -load sessname  Load settings from saved session
  -l user   connect with specified username
  -P port   connect to specified port
  -pw passw login with specified password
  -1 -2     force use of particular SSH protocol version
  -4 -6     force use of IPv4 or IPv6
  -C        enable compression
  -i key    private key file for authentication
  -noagent  disable use of Pageant
  -agent    enable use of Pageant
  -batch    disable all interactive prompts


... and also the same response when I pass "22" as a parameter ...

Code:
>psftp.exe open "username@myserver.org" 22
PuTTY Secure File Transfer (SFTP) client
Release 0.60
Usage: psftp [options] [user@]host
Options:
  -V        print version information and exit
  -pgpfp    print PGP key fingerprints and exit
  -b file   use specified batchfile
  -bc       output batchfile commands
  -be       don't stop batchfile processing if errors
  -v        show verbose messages
  -load sessname  Load settings from saved session
  -l user   connect with specified username
  -P port   connect to specified port
  -pw passw login with specified password
  -1 -2     force use of particular SSH protocol version
  -4 -6     force use of IPv4 or IPv6
  -C        enable compression
  -i key    private key file for authentication
  -noagent  disable use of Pageant
  -agent    enable use of Pageant
  -batch    disable all interactive prompts


Also, I just wanted to clarify why I originally used "open username@myserver.org" at the command line. For the version of psfto that I have, when I typed psftp.exe at the command line I received this note:

Code:
psftp: no hostname specified; use "open host.name" to connect
psftp>


So, either the command you are using is for FZ's compiled psftp version, or the version I am using is different than the one you are testing with, or we're using different binaries on a different OS, or something else.

Ideas?


Top
 Profile  
 
 Post subject:
PostPosted: 2007-10-23 08:42 
Offline
Site Admin
User avatar

Joined: 2004-02-23 20:49
Posts: 22552
You're confusing a command with commandline arguments. Start psftp without any arguments, then enter the open command.


Top
 Profile  
 
 Post subject: Works
PostPosted: 2007-10-23 15:48 
Offline
504 Command not implemented

Joined: 2007-10-21 22:04
Posts: 7
Sorry about that, yes the command works using:

Code:
psftp> open "username@myserver.org" 22


Top
 Profile  
 
 Post subject: Next Steps
PostPosted: 2007-10-24 14:48 
Offline
504 Command not implemented

Joined: 2007-10-21 22:04
Posts: 7
Is there anything else that you need me to test? If Putty works, then is this an issue with Filezilla? Is there any help you need on development?


Top
 Profile  
 
 Post subject:
PostPosted: 2007-10-24 15:20 
Offline
Site Admin
User avatar

Joined: 2004-02-23 20:49
Posts: 22552
Would it be possible to get a temporary guest account on your server for further analysis?


Top
 Profile  
 
 Post subject:
PostPosted: 2007-11-05 09:45 
Offline
500 Command not understood

Joined: 2007-10-26 14:21
Posts: 4
I've the same problem... Is there a solution for this issue?


Top
 Profile  
 
PostPosted: 2007-11-26 14:46 
Offline
504 Command not implemented

Joined: 2005-11-16 00:22
Posts: 8
exactly the same problem, using FZ v3 and FZ server (latest releases)
Still no solution?
Thanks for your help


Top
 Profile  
 
PostPosted: 2007-11-26 17:10 
Offline
Site Admin
User avatar

Joined: 2004-02-23 20:49
Posts: 22552
Try increasing your timeout value.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 22 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 31 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Dedicated server provided by Artmotion.
Forum sponsored by Everyware.ch.
Powered by phpBB® Forum Software © phpBB Group