Cannot register Filezilla as the default app for FTP

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
jlgarnier
500 Command not understood
Posts: 2
Joined: 2018-03-12 06:47
First name: Jean-Luc
Last name: GARNIER

Cannot register Filezilla as the default app for FTP

#1 Post by jlgarnier » 2018-03-12 06:56

Hi Community,

I'm trying to register Fz with Win10 settings as the default application for FTP protocol. Unfortunately, Filezilla doesn't display as a possible app for FTP (only browsers by default), leaving me to install other FTP app (WinSCP correctly displays in the list)...

How can I fix this?

Thanks in advance for any help.

User avatar
botg
Site Admin
Posts: 32267
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Cannot register Filezilla as the default app for FTP

#2 Post by botg » 2018-03-12 07:34

FileZilla doesn't register itself as protocol handler. You could manually add the registry entries for it.

Note that there a bunch of issues if passing URIs via the command-line to FileZilla, notably it doesn't download files and always treats any passed filename as directory.

jlgarnier
500 Command not understood
Posts: 2
Joined: 2018-03-12 06:47
First name: Jean-Luc
Last name: GARNIER

Re: Cannot register Filezilla as the default app for FTP

#3 Post by jlgarnier » 2018-03-12 08:51

Thanks botg for the quick answer! It's a pity Fz doesn't handle this feature at installation! Can you please point me to the procedure I should follow to manually register Fz as a protocol handler?

Thanks in advance for your help!

skiwi
500 Command not understood
Posts: 3
Joined: 2009-05-11 09:23
First name: simon
Last name: davis

Re: Cannot register Filezilla as the default app for FTP

#4 Post by skiwi » 2019-07-27 03:21

I too would very much ro be able to choose FileZilla as the default application for ftp protocol on on Windows 10
without having to do the following: https://www.trishtech.com/2016/09/set-f ... n-windows/

Post Reply