Win 10 1803: filezilla client: hostname 'No address associated' - cannot resolve

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
500 Command not understood
Posts: 1
Joined: 2018-05-20 09:42
First name: r
Last name: d

Win 10 1803: filezilla client: hostname 'No address associated' - cannot resolve

#1 Post by whitesocks » 2018-05-20 12:08

First post here - great product!

I'm posting here though this is not a filezilla problem, but the client is being affected and I have a simple but crazy work round...

Symptoms: Since updating to win 10, 1803, I can no longer connect with filezilla to an Ubuntu PC using sftp, as the host is not recognised.
ping (command prompt) cannot reach the hostname either.

Interesting: ping name -4 can connect though, as can ssh name -4 (cygwin). The -4 forces IPv4 rather than IPv6.
Using the raw IP4 address of the server works in filezilla client, too.
Filezilla client does not have a force IP4 option for name resolution as far as I can determine. (Enhancement request maybe).

The root problem: is almost certainly microsofts, and their buggy windows 10, version 1803 update, as all worked until it installed itself on my computer.

More details: I do not know how widespread the 1803 update is, but generally people are having problems with shares and odbc connections, yet no-one seems to have reported filezilla issues yet. There maybe something in my setup that triggers the problem (As well as win 10 1803, I run VirtualBox with bridged adaptors, run Comodo firewall, have a large host file ( and have an HG533 router that has no IP6 options).
But there is another reason why this issue will not affect everyone as I will explain.

The obvious solution: is for the server to have a fixed IP address then place an entry in the client's Host file. I've done this for decades. But I don't really think of the computers I want to connect to now as servers - they are just clients I want to move files around on securely, reliably and quickly. Microsoft themselves are degrading client to client connectivity (like homegroup, network browser) in the face of sophisticated malware attacks. (Filezilla is the future!) The problem is the clients naturally have dynamic IP addresses so static addressing is not a good solution for me.

A crazy solution: Bizarrely if you use mixed case for the hostname, the problem goes away!
My hostnames are lowercase, but by capitalising the first letter, filezilla client works again, as does ping.
(SSH on cygwin still needs the -4 option). It seems deliberately mismatching the case solves the issue.
I've found 1 reference to this behaviour ( ... d-p/187721) so it is a known problem, not that microsoft have done anything to solve it.

Depending on people's use of the host file or their ability to exactly write the hostname case incorrectly, then filezilla client under win 10 1803 will sometimes work sometimes not as described.

Summary: This is a Microsoft problem, and they'll eventually fix it as I suspect it is at the core of their other network problems. I've spent enough time on this now, especially now I know how to easily work round the problem, but I'd welcome comments for those who have persevered with this long long post.

Post Reply