Page 1 of 1

FileZilla Won't Upload .js File

Posted: 2018-06-08 16:44
by madi
Dear all

I've been trying to upload a .js file via FTP and FileZilla is not allowing it's upload.

It gets to 100% but then seems to reconnect to the server and ask me if I want to 'replace' the file I am trying to upload. If I then connect to the server the whole process starts again in a loop.

I've uploaded files such as this before and the only variable seems to be the file size which is 2.1mb. I haven't uploaded any videos lately, but I know I've successfully upload far larger files than this using FileZilla.

I've tried this to several websites hosted by different providers and the result is the same.

I have successfully uploaded this with another FTP program and FileZilla will upload other files to the same server. I've tried recreating the .js file several times, but the end result is the same. I don't think it's the file as other programs are uploading this with no issues at all.

I wondered if there was some kind of 'file size limit' for .js files specifically?

Any thoughts welcomed.


Re: FileZilla Won't Upload .js File

Posted: 2018-06-08 18:58
by botg
FileZilla is content agnostic, it doesn't matter what you transfer. Perhaps your server has limitations on certain types of files?

Re: FileZilla Won't Upload .js File

Posted: 2018-06-08 19:38
by madi
Thanks botg - I wondered that, however I was able to upload the file from another FTP client to the server with no issues.

I was also able to upload other files using FileZilla. I initially thought there was an issue with the naming convention for the file, but there are others of a similar name I'd successfully uploaded over the past few months.

The only variable on this file was it was the largest .js file I'd tried to upload at a little over 2mb.

Re: FileZilla Won't Upload .js File

Posted: 2018-06-13 13:33
by flagpole
You could try renaming it as something else. Uploading it. Then renaming it on the server.

But I can confirm that .js files upload.