Page 1 of 1

Invisible contents of attached external drive

Posted: 2018-10-04 17:35
by LR4949
Just updated to MacOS Mojave and tried to download from an FTP site to an external drive attached to an iMac. The external volume itself appears twice, once under User and once under the main directory, but when I click on the volume the contents are invisible in the pane and a carat doesn't appear and allow further opening on the local site browsing window. I don't think it's a dark mode issue, as there no response at all from the UI when clicking in that window and the carat doesn't appear to show the 3 directories contained in that volume.

Here's the funny part: if you drag a duplicate into that pane it will warn you you're replacing. So it looks like FileZilla might have write but not read permissions for that volume, but why/how?

In Sierra and after the transition to High Sierra this operation worked fine, but honestly I haven't tried to run this backup in a few months (it's a tertiary, not a main, and it's manual, so it's less frequently run) so I can't point to a specific time when this issue might have started. But my guess is that it has to do with Mojave and permissions levels.

Details:

Main machine: iMac with APFS (GUID), running Mojave
External Drive: WD40EZRZ formatted APFS (GUID) case-sensitive and encrypted

Obviously if this is an old issue, please delete/demote this topic and (hopefully) point me in the right direction.

Thanks!

Re: Invisible contents of attached external drive

Posted: 2018-10-04 21:08
by LR4949
Here's a log file... Doesn't tell me much, still looking for other info. It's been slightly anonymized, so the addresses are incorrect but other than inserting some "Here It Is" lines before a successful transfer and an unsuccessful transfer it's unmodified otherwise.
filezilla.rtf
(17.58 KiB) Downloaded 29 times

Re: Invisible contents of attached external drive

Posted: 2018-10-05 00:05
by hurcomv
I believe I have essentially the same problem but not with an external drive. I'm using FileZilla Pro 3.37.3 which is the latest version on the App Store and Mojave. FIleZilla is not expanding all directories properly and in my specific case I can't see any of the files in my Documents folder, nor most of the folders within the Documents folder.
Clicking on the one folder it is displaying within the documents folder expands that folder to show many folders, however it doesn't display any of the actual files in the folder. Clicking on a sub-folder does show it contents.
I have an admin account so I guess in principal it shouldn't be a privilege/security problem.

Re: Invisible contents of attached external drive

Posted: 2018-10-05 05:59
by botg
If you are using FileZilla Pro from the Mac App Store you need to grant FileZilla permission through the directory access permissions dialog. After a system update it may be necessary to remove and re-add permissions.

Re: Invisible contents of attached external drive

Posted: 2018-10-05 07:35
by hurcomv
My apologies - I must not have granted access to Documents previously, probably because I don't normally upload or download directly into that folder. That explains why Downloads and the other folder I mentioned were working - they're already "allowed".
Thanks for your quick response!!

Re: Invisible contents of attached external drive

Posted: 2018-10-11 16:15
by LR4949
botg wrote:
2018-10-05 05:59
If you are using FileZilla Pro from the Mac App Store you need to grant FileZilla permission through the directory access permissions dialog. After a system update it may be necessary to remove and re-add permissions.
Thanks, botg!

For anyone wondering, this is the procedure:

(Top Menu) Edit / Directory access permissions / ... and then click through and add the "missing" directory.

I'm sure this is in the FAQ somewhere, but I couldn't find it--the FAQ is really dense and has a lot of good information, but I didn't understand its hierarchy and couldn't find the right search terms to make sense of the results I got out of it. Contrary to my assumption in the beginning, this is NOT something which can be addressed by using the Directory Utility in Mac Core Services.

Thanks!! Rock on!!