Issue with Directory Access Permissions

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Message
Author
beyondfear
500 Command not understood
Posts: 4
Joined: 2018-12-03 17:45
First name: Scott
Last name: Diehl

Re: Issue with Directory Access Permissions

#16 Post by beyondfear » 2018-12-04 18:24

Glad I'm not alone. Both are enabled.

scotts-mbp:~ scottdiehl$ csrutil status
System Integrity Protection status: enabled.

scotts-mbp:~ scottdiehl$ spctl --status
assessments enabled

I really appreciate your time and expertise debugging. Let me know what more I can do to help get through this.

Thanks.

User avatar
botg
Site Admin
Posts: 31608
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Issue with Directory Access Permissions

#17 Post by botg » 2018-12-10 12:40

Do you have any third-party kernel extensions installed? You can check with

Code: Select all

kextstat | grep -v com.apple

Also, are there any errors logged in the Console app when you try to give permissions to a directory?

kangbu
500 Command not understood
Posts: 2
Joined: 2018-12-11 07:28
First name: kangbu

Re: Issue with Directory Access Permissions

#18 Post by kangbu » 2018-12-11 07:33

Hello, I have faced totally same issue. I bought Pro apps from App store but I coundn't use it once. I do nothing with my Mac file system but it rejected selecting any folders.

I executed the command above and the results are:

Code: Select all

kbMBP:~ we$ csrutil status
System Integrity Protection status: enabled.

kbMBP:~ we$ spctl --status
assessments enabled
Please give me advice. Thank you.

kangbu
500 Command not understood
Posts: 2
Joined: 2018-12-11 07:28
First name: kangbu

Re: Issue with Directory Access Permissions

#19 Post by kangbu » 2018-12-11 07:35

Maybe some of my apps are conflict with Filezilla Pro. I'm testing apps which mount cloud drives to my Mac.

Code: Select all

kbMBP:~ we$ kextstat | grep -v com.apple
Index Refs Address            Size       Wired      Name (Version) UUID <Linked Against>
   82    2 0xffffff7f8107e000 0xf000     0xf000     com.symantec.internetSecurity.kext (14.0.1f214) 6F5043C0-B4BC-3F78-A3BB-9D895B049B29 <5 4 3 1>
   83    0 0xffffff7f8108d000 0x18000    0x18000    com.symantec.nfm.kext (14.0.1f214) 42BE2C0D-3EDA-3B1B-89F7-36A0A7D51170 <82 5 4 3 1>
   84    0 0xffffff7f810cc000 0x6b000    0x6b000    com.symantec.ips.kext (14.0.1f214) no UUID <82 5 4 3 1>
  165    0 0xffffff7f849c1000 0x7000     0x7000     com.parallels.virtualsound (1.0.36 36) E9131806-D073-8482-AC46-B4AAE55EA6FE <125 5 4 3 1>
  172    0 0xffffff7f849c8000 0x7000     0x7000     org.pqrs.driver.Karabiner.VirtualHIDDevice.v041100 (4.11.0) E1649988-9411-3099-82B6-131B2B52A2DE <41 5 4 3 1>
  173    0 0xffffff7f849cf000 0x5000     0x5000     com.parallels.virtualhid (1.0.3 3) B0C355DF-4268-359B-9654-0A67F4305F7B <41 5 4 3 1>
  176    1 0xffffff7f80e44000 0x47000    0x47000    com.Logitech.Control Center.HID Driver (3.9.6) no UUID <175 77 50 41 5 4 3>
  183    0 0xffffff7f84a25000 0x17000    0x17000    com.Logitech.Unifying.HID Driver (1.3.6) no UUID <176 175 50 41 5 4 3>
  234    0 0xffffff7f84a9d000 0x15000    0x15000    com.google.dfsfuse.filesystems.dfsfuse (3.7.4) 6ACB4FE9-419E-3B09-9D04-A39C77D5816D <7 5 4 3 1>
  247    0 0xffffff7f84ac3000 0x19000    0x19000    com.github.osxfuse.filesystems.osxfuse (3.7.1) 8C89BD7B-DA6D-347D-AC76-759C45AE6099 <7 5 4 3 1>


Any advice will be appreciated. Thanks.

User avatar
botg
Site Admin
Posts: 31608
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Issue with Directory Access Permissions

#20 Post by botg » 2018-12-11 09:47

I'm testing apps which mount cloud drives to my Mac.
That could be a possible explanation. I can see how a kernel extension not implementing a particular ioctl could result in this.

Of the listed kernel extensions you listed, I think these are the most likely to cause problems:

Code: Select all

   82    2 0xffffff7f8107e000 0xf000     0xf000     com.symantec.internetSecurity.kext (14.0.1f214) 6F5043C0-B4BC-3F78-A3BB-9D895B049B29 <5 4 3 1>
   83    0 0xffffff7f8108d000 0x18000    0x18000    com.symantec.nfm.kext (14.0.1f214) 42BE2C0D-3EDA-3B1B-89F7-36A0A7D51170 <82 5 4 3 1>
   84    0 0xffffff7f810cc000 0x6b000    0x6b000    com.symantec.ips.kext (14.0.1f214) no UUID <82 5 4 3 1>
  234    0 0xffffff7f84a9d000 0x15000    0x15000    com.google.dfsfuse.filesystems.dfsfuse (3.7.4) 6ACB4FE9-419E-3B09-9D04-A39C77D5816D <7 5 4 3 1>
  247    0 0xffffff7f84ac3000 0x19000    0x19000    com.github.osxfuse.filesystems.osxfuse (3.7.1) 8C89BD7B-DA6D-347D-AC76-759C45AE6099 <7 5 4 3 1>
Could you please try to uninstall these extensions and check if the issue has gone or if it persists?

Post Reply