bug? weird transfer speed issue

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
flow
550 File not found
Posts: 34
Joined: 2018-01-09 12:53

bug? weird transfer speed issue

#1 Post by flow » 2018-12-03 14:45

Rarely, this happens:
- I start a SFTP to C: transfer - it's slow as hell (less than 10% of the usual speed)
- I stop the transfer
- I open a new tab and start a FTP to C: Linux DVD transfer from a public FTP server - it's fast!
- I stop the transfer
- I restart the original SFTP to C: transfer - now it's fast too!

Is this a FileZilla bug? Any other ideas?

User avatar
botg
Site Admin
Posts: 31608
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: bug? weird transfer speed issue

#2 Post by botg » 2018-12-03 16:18

Most likely simply a slow harddisk on the server. The difference between the first and the second transfer is that the second time around the file is already in main memory.

flow
550 File not found
Posts: 34
Joined: 2018-01-09 12:53

Re: bug? weird transfer speed issue

#3 Post by flow » 2018-12-03 16:22

Ah, ok. Thanks.

flow
550 File not found
Posts: 34
Joined: 2018-01-09 12:53

Re: bug? weird transfer speed issue

#4 Post by flow » 2018-12-12 18:54

I made another discovery that doesn't fit the "slow harddisk on the server" theory: hours ago, I started a file transfer (FTP to C:), the file was just about 1 GB. When I came back to the PC it was still transfering at 20 KB/s (WAY less than the regular speed). I stopped and removed the file and restarted the download a few seconds later - and the new transfer speed was 4 MB/s.

Is there anything I can do to prevent this from happening in the future?

If this is an issue for other people too, how about an "stop and restart transfer if download speed falls below XX/s" option?

User avatar
botg
Site Admin
Posts: 31608
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: bug? weird transfer speed issue

#5 Post by botg » 2018-12-12 21:46

There must be some faulty networking equipment causing this sitting between the client and the server.

flow
550 File not found
Posts: 34
Joined: 2018-01-09 12:53

Re: bug? weird transfer speed issue

#6 Post by flow » 2018-12-13 17:20

botg wrote:
2018-12-12 21:46
There must be some faulty networking equipment causing this sitting between the client and the server.
Hmm.... What would you guess: is it my router or my ISP?

User avatar
botg
Site Admin
Posts: 31608
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: bug? weird transfer speed issue

#7 Post by botg » 2018-12-13 20:38

Could be both. Could also be your server provider's ISP or even something your server provider is doing.

Post Reply