Please make sure the LC_CTYPE (or LC_ALL) environment variable is set correctly

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
a2apple
500 Command not understood
Posts: 1
Joined: 2018-12-05 15:44
First name: omar
Last name: elroubi

Please make sure the LC_CTYPE (or LC_ALL) environment variable is set correctly

#1 Post by a2apple » 2018-12-05 15:56

hi there


every time i start filezilla i get the following error

Character encoding issue
A local filename could not be decoded.
Please make sure the LC_CTYPE (or LC_ALL) environment variable is set correctly.
Unless you fix this problem, files might be missing in the file listings.

FileZilla Client
----------------

Version: 3.39.0

Build information:
Compiled for: x86_64-pc-linux-gnu
Compiled on: x86_64-pc-linux-gnu
Build date: 2018-11-30
Compiled with: gcc (GCC) 8.2.1 20180831
Compiler flags: -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -Wall -g

Linked against:
wxWidgets: 3.0.4
SQLite: 3.25.3
GnuTLS: 3.5.19

Operating system:
Name: Linux 4.19.6-1-MANJARO x86_64
Version: 4.19
CPU features: sse sse2 sse3 ssse3 lm
Settings dir: /home/omar/.config/filezilla/

could you please help me solve this issue

best regard
a2apple

User avatar
botg
Site Admin
Posts: 31605
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Please make sure the LC_CTYPE (or LC_ALL) environment variable is set correctly

#2 Post by botg » 2018-12-05 16:07

Your system's character encoding doesn't match the encoding of the files on your filesystem.

This usually happens if using a filesystem created on one system on a different system that uses a different encoding. This can also happen if you at some point changed your system encoding without also changing the encoding of the filesystem.

Make sure your system encoding, as controlled through LC_CTYPE, matches your filesystem encoding. These days it is highly recommended to use UTF-8 for everything.

Post Reply