Page 1 of 1


Posted: 2019-06-14 11:51
by mgglasby
Filezilla suddenly stopped working and is now not allowing a directory listing.

It appears to be using an invalid command but I have very little knowledge when it comes to this stuff. Please see the transcript below:

Status: Resolving address of
Status: Connecting to [2001:8004:11d0:4e2a::1f16:412]:21...
Status: Connection established, waiting for welcome message...
Status: Initializing TLS...
Status: Verifying certificate...
Status: TLS connection established.
Status: Logged in
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/" is your current location
Command: TYPE I
Response: 200 TYPE is now 8-bit binary
Command: EPSV
Response: 500 Unknown command
Command: EPRT |2|2001:8004:18eb:c97:9502:da92:5cd2:3eec|50106|
Response: 500 I won't open a connection to 2001:8004:18eb:c97:9502:da92:5cd2:3eec (only to
Error: Failed to retrieve directory listing

So far I have tried the solutions that have been offered online such as switching from passive to active and turning off my firewall.

I don't understand why Filezilla is trying to use EPSV

Please help.


Posted: 2019-06-14 14:50
by boco
That looks like a severely mis-configured server, it does not know how to handle IPv6 connections. If it worked shortly before either your or their side did just enable IPv6 access. You need to contact them and tell them.

1. Recommended fix: The server administrator must fix/upgrade the FTP server software, so it fully handles IPv6, together with the EPSV (Extended Passive) and EPRT (Extended PORT) commands. These commands are fully valid, exist for many years, and are mandatory for IPv6. IPv6 is the future.

2. Non-recommended way of short-term workaround: The server administrator must disable IPv6 (by removing the AAAA DNS record). All clients will then again use IPv4 to connect.