Page 1 of 1

Filezilla 3.38+ can't connect to pure-ftpd 1.0.46 on Ubuntu 18.04 - GnuTLS error -110, ECONNABORTED

Posted: 2019-11-26 17:15
by kayson
Posting this here because I ran into this problem and started by searching here but had no luck.

After upgrading to 3.45.1, I could no longer connect to my pure-ftpd server with filezilla because it failed after an AUTH command:
Error: GnuTLS error -110: The TLS connection was non-properly terminated.
Status: Server did not properly shut down TLS connection
Error: Disconnected from server: ECONNABORTED - Connection aborted

Other clients seemed to work fine, though. As suggested by the sticky, it was a server problem. I just had a hell of a time finding what it was. The issue is a bug with pure-ftpd 1.0.46 and OpenSSL 1.1.1, which are the latest packages on Ubuntu 18.04
See: https://bugs.launchpad.net/ubuntu/+sour ... g/1832998/
and a fix: https://bugs.launchpad.net/ubuntu/+sour ... comments/8

Hopefully this helps someone!

Re: Filezilla 3.38+ can't connect to pure-ftpd 1.0.46 on Ubuntu 18.04 - GnuTLS error -110, ECONNABORTED

Posted: 2019-11-26 17:58
by boco
Well, I see, the TLS 1.3 problem still hasn't been fixed...

Or rather, it has been fixed, but not backported to older distros.