Icons missing with filetype associations

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
Zazou
500 Command not understood
Posts: 5
Joined: 2019-12-27 22:49

Icons missing with filetype associations

#1 Post by Zazou » 2019-12-27 22:56

Hello,

I use Filezilla for many years without problem. Today I formated my Windows 10. After the installation, icons not showed for PHP file. I set NotePad++ for edition. When I click on file, no problem.

Image

I have no problem with other file like html, .mp4 or .txt

Image

Tested to install again, portable version, deleted files under %APPDATA%/FileZilla, nothing resolve the problem.

Thank you !!

User avatar
boco
Contributor
Posts: 25195
Joined: 2006-05-01 03:28
Location: Germany

Re: Icons missing with filetype associations

#2 Post by boco » 2019-12-27 23:26

The "Default editor" setting is NOT a file type association, it merely states what should be used for non-associated files.

Try the following:
1. Start NP++ WITH ADMINISTRATOR RIGHTS (right-click, Run as Administrator).
2. Use the NP++ settings to associate the desired file types to NP++. I found that without admin rights, associations set in NP++ do not register correctly.
3. In Windows 10, you might have to double-click a PHP file in the File Explorer and select NP++ as Editor, once more.

Then, the PHP files should adopt the NP++ icon and FileZilla will follow suit.

File type associations in Windows are a real mess, these days.


Note: You can also set a hard override for PHP files in the FileZilla settings. Use the "Custom filetype associations" field for doing so.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

Zazou
500 Command not understood
Posts: 5
Joined: 2019-12-27 22:49

Re: Icons missing with filetype associations

#3 Post by Zazou » 2019-12-27 23:40

It worked ! Thank you very much.

Post Reply