Install filezilla in ubuntu 18.04

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
Eman
500 Command not understood
Posts: 1
Joined: 2019-12-28 18:13
First name: Eman
Last name: Khalaf

Install filezilla in ubuntu 18.04

#1 Post by Eman » 2019-12-28 18:43

Hello,

I am new to filezilla and have been referred to it through a collaborator to share FTP files. They send me a link to download the software. I downloaded the file in Ubuntu 18.04 which is also new to me (just installed last week) , however, I used to use Ubuntu 16.04. When I opened the install file (have installation instructions), I found that the process will require the followings:
FileZilla depends on the following libraries:
- libfilezilla 0.19.3 or greater
- wxWidgets 3.0.4 or greater of the 3.0.x branch
- libidn (only if not on Windows and not having gettaddrinfo with AI_IDN support)
- Nettle 3.1 or greater
- libdbus on *nix
- sqlite3 3.7 or greater

To compile FileZilla 3, the following tools need to be installed:
- A C++17 compiler, e.g. a recent GCC or Clang
- GNU make
- GNU gettext

Optional tools:
- recent automake, autoconf if you plan to change configure.in or any of the
Makefile.am files
- CppUnit >= 1.13.0 if you want to run the tests, which you want.
- NSIS if you want to create the Windows installer

If crosscompiling, a native wxrc tool, which is part of wxWidgets, has to
exist or compilation will fail

and since the machine is new and just arrived last week as well, none of these libraries are installed.
May you please guide me how to install Filezilla in my new machine?

Thanks
Eman

User avatar
botg
Site Admin
Posts: 33236
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Install filezilla in ubuntu 18.04

#2 Post by botg » 2019-12-30 09:16

You would need to first compile all the dependencies, then compile FileZilla.

Alternatively you could use the outdated and unsupported version of FileZilla available through the Ubuntu repositories, but I cannot recommend using outdated software.

Easiest option might be to update to a more recent Ubuntu version, where most of the dependencies already exist.

Post Reply