Not possible to disable SSH public key authentication?

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
altjx
504 Command not implemented
Posts: 7
Joined: 2009-11-15 01:59

Not possible to disable SSH public key authentication?

#1 Post by altjx » 2020-06-05 14:19

Today I started getting "too many authentication failures" error and I realized that it's because Filezilla is trying to use my SSH keys to authenticate via SFTP. How do I simply disable public key authentication? I'm not sure why this isn't an option.

User avatar
boco
Contributor
Posts: 25154
Joined: 2006-05-01 03:28
Location: Germany

Re: Not possible to disable SSH public key authentication?

#2 Post by boco » 2020-06-05 19:45

If you did set your keys in the global settings, or if you use PuTTY's Pageant tool, the keys are tried against every SFTP server. That's what globally defined means.

You can define Public Key Authentication per server, in the Site Manager (select protocol as "SFTP" and Logon Type as "key file"). Keys defined that way apply only to that one server.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

altjx
504 Command not implemented
Posts: 7
Joined: 2009-11-15 01:59

Re: Not possible to disable SSH public key authentication?

#3 Post by altjx » 2020-06-05 22:21

It seems like the only way I could get this to stop is to kill the ssh-agent process running on the macbook. I cannot authenticate via SSH keys and don't want FileZilla to try using them, but it doesn't seem like there's a way to turn this option off if the ssh agent is running on the local system. Is that right?

User avatar
boco
Contributor
Posts: 25154
Joined: 2006-05-01 03:28
Location: Germany

Re: Not possible to disable SSH public key authentication?

#4 Post by boco » 2020-06-05 23:28

The OS SSH agent holds the global (system-wide) keys. They will be used by all SSH/SFTP applications, not just FileZilla.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

altjx
504 Command not implemented
Posts: 7
Joined: 2009-11-15 01:59

Re: Not possible to disable SSH public key authentication?

#5 Post by altjx » 2020-06-06 00:00

I think there is some confusion here. I am trying to avoid SSH keys altogether. I do not want to use SSH keys, but FileZilla is forcing me to. I just want to authenticate using my password, but even after providing my password, FileZilla still tries to authenticate using SSH keys.

User avatar
botg
Site Admin
Posts: 32975
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Not possible to disable SSH public key authentication?

#6 Post by botg » 2020-06-06 17:17

Configure your SSH agent to not load keys into it.

altjx
504 Command not implemented
Posts: 7
Joined: 2009-11-15 01:59

Re: Not possible to disable SSH public key authentication?

#7 Post by altjx » 2020-06-06 17:42

Gotcha. Sounds great!

Post Reply