No access with FileZilla but ftp works

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
User avatar
ESgt
500 Command not understood
Posts: 2
Joined: 2020-06-10 22:34
First name: Eric
Last name: Sargeant
Location: Derbyshire, UK
Contact:

No access with FileZilla but ftp works

#1 Post by ESgt » 2020-06-12 23:23

I have two web-sites, one of which I control with ftp from cmd prompt; like this:
C:\Users\HP>ftp
ftp> open www.derbyarc.org
Connected to rs1.vidavia.net.
220 Microsoft FTP Service
200 OPTS UTF8 command successful - UTF8 encoding now ON.
User (rs1.vidavia.net:(none)): derbyarc
331 Password required
Password:
230 User logged in.
ftp> cd www.derbyarc.org
250 CWD command successful.
ftp> prompt
Interactive mode Off .
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection.
03-21-20 11:47PM 10375 about.html ---------------- and so on.

But with FileZilla the result is always like this:
Status: Connection attempt failed with "EAI_NONAME - Neither nodename nor servname provided, or not known".

Could you please help me how to apply FileZilla in this case.

User avatar
boco
Contributor
Posts: 25259
Joined: 2006-05-01 03:28
Location: Germany

Re: No access with FileZilla but ftp works

#2 Post by boco » 2020-06-14 16:20

Looks like FileZilla cannot resolve the server name to an IP, maybe a firewall restricts its ability to DNS-resolve?

As a workaround, try to use the IP address of the server directly (which is 94.236.73.13).
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

User avatar
ESgt
500 Command not understood
Posts: 2
Joined: 2020-06-10 22:34
First name: Eric
Last name: Sargeant
Location: Derbyshire, UK
Contact:

Re: No access with FileZilla but ftp works

#3 Post by ESgt » 2020-06-19 23:13

Thank you for the suggestion using the IP directly. It produces this set of statements. Is there further indication amongst them please?
Status: Connecting to 94.236.73.13:21...
Status: Connection established, waiting for welcome message...
Status: Initializing TLS...
Status: Verifying certificate...
Status: TLS connection established.
Status: Logged in
Status: Retrieving directory listing...
Status: Server sent passive reply with unroutable address. Using server address instead.
Command: LIST
Response: 150 Opening BINARY mode data connection.
Error: Connection timed out after 20 seconds of inactivity
Error: Failed to retrieve directory listing

User avatar
botg
Site Admin
Posts: 33128
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: No access with FileZilla but ftp works

#4 Post by botg » 2020-06-20 18:35

The server sits behind a NAT router, however neither the server nor the NAT router have been configured accordingly.

Post Reply