TLS errors during file transfers or connections attempts

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
ktager
500 Command not understood
Posts: 3
Joined: 2020-08-02 12:56
First name: Kevin
Last name: Tager

TLS errors during file transfers or connections attempts

#1 Post by ktager » 2020-08-02 13:15

Ever since Microsoft did what they did on June 1st in regards to killing support for TLS 1.0 & 1.1 we have had many issues with systems using TLS. We were not able to connect to our inmotionhosting FTP server until we installed v3.49.1 of Filezilla. Now that we have finally connected, when I try to upload a file I get the attached TLS errors. Strange thing is our accounting software that connects to our Office365 mail server for sending e-mails stopped working on June 1st too. It also throws TLS errors. I have spent the last 2 months working with Microsoft support (useless) and also my accounting software support team and we can't figure out what is causing these failures. All systems worked just fine on Friday May 29th, but when we came into the office June 1st, everything failed. After we get these TLS errors on upload, I disconnect and try to reconnect to the server and it fails. (See attached image).

Any help on trying to figure out why we keep getting these TLS errors would be greatly appreciated.
Attachments
Filezilla reconnect error.PNG
Filezilla reconnect error.PNG (14.77 KiB) Viewed 527 times
Filezilla TLS error.PNG
Filezilla TLS error.PNG (16.1 KiB) Viewed 527 times

User avatar
botg
Site Admin
Posts: 33125
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: TLS errors during file transfers or connections attempts

#2 Post by botg » 2020-08-03 07:11

FileZilla does not rely on WIndows' functionality for TLS. Any changes by Microsoft's TLS policy does not affect FileZilla.

Are you by chance using a firewall or virus scanner that intercepts or even modifies TLS traffic?

ktager
500 Command not understood
Posts: 3
Joined: 2020-08-02 12:56
First name: Kevin
Last name: Tager

Re: TLS errors during file transfers or connections attempts

#3 Post by ktager » 2020-08-05 10:05

Botg,

We use Vipre Endpoint Security and have a Fortigate 81e firewall running fortiOS 6.4.2. I originally reached out to Fortinet support in regards to the e-mail issue with our Accounting Software, and they captured a tracert showing the traffic was leaving our network and reaching the Office365 servers. We have not done one for Filezilla. I have also disabled Vipre on the desktops with no luck. As it pertains to our Filezilla issue, it definitely seems to be something in our environment causing the issue, because my Filezilla on my personal home PC can connect and send files with no issues. What's strange is that nothing in our environment changed between May 29 and Jun 1st, so we are stumped as to why we are having these issues and no one has been able to figure it out.

Kevin

User avatar
botg
Site Admin
Posts: 33125
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: TLS errors during file transfers or connections attempts

#4 Post by botg » 2020-08-06 08:26

If you click the lock icon in the status bar, what certificate fingerprint do you see? Unless the hostname points to a load-balancer, the fingerprint should be the same regardless of where you connect from.

ktager
500 Command not understood
Posts: 3
Joined: 2020-08-02 12:56
First name: Kevin
Last name: Tager

Re: TLS errors during file transfers or connections attempts

#5 Post by ktager » 2020-08-06 09:55

botg,

Attached is a screenshot showing certificates on my Home PC where everything works just fine. I've also attached a screenshot of the error I get when trying to connect on work PC and the certificates it's using. From what I can see they look to be exactly the same.
Attachments
FZ Cert - Home PC.PNG
FZ Cert - Home PC.PNG (27.73 KiB) Viewed 426 times
FZ - Cert - Work PC.PNG
FZ - Cert - Work PC.PNG (26.97 KiB) Viewed 426 times
FZ - TLS Errors.PNG
FZ - TLS Errors.PNG (49.28 KiB) Viewed 426 times

Post Reply