Page 1 of 1

view/edit with notepad++ not working

Posted: 2020-10-29 09:37
by gniposoave
Hi all, I'm facing a weird issue. I'm running Win-10 Enterprise and Filezilla v3.51 (64-bit) , notepad++ v7.9 (64-bit).
After installing Filezilla 3.51, I'm not able to use view/edit files with notepad++.
I've tried to debug this, and find this:
1. I click the view/edit choice on Filezilla.
2. The file transfer to the local directory C:\Users\PC-USER\AppData\Local\Temp\fz3temp-2 starts, and I can see the file
3. Immediately after the end of the download, the file is being deleted!!! So I can't open it

The view/edit feature works fine with other programs like Windows_notepad, WordPad , or other file types having another program associated to open it.
I'm facing this issue after upgrading to 3.51 Filezilla version.
But now, even downgrading to 3.48 version doesn't solve this

Can anyone help me?
I'll appreciate very much. Thank in advance

Re: view/edit with notepad++ not working

Posted: 2020-10-29 11:56
by gniposoave
After struggling a lot, i've found and put here the solution, perhaps it can help someone else.
The issue was caused by the conf of notepad to run always as administrator.
Navigate to C:\Program Files \Notepad++ folder. Right mouse click the Notpad++.exe file click properties & under the compatability Tab UN-TICK run the program as administrator box.
Done :D

Re: view/edit with notepad++ not working

Posted: 2020-10-29 15:01
by boco
If I require a software starting in Admin mode, but also regularly, I create a copy of the executable, e. g. "notepad++A.exe". This copy (or hardlink) is configured to always run as Administrator. The shell keeps starting the original "notepad++.exe" and works fine.

<rant>Unbelievable that very good software like 7-Zip still doesn't auto-elevate when required...</rant over>

Re: view/edit with notepad++ not working

Posted: 2020-12-11 05:05
by dannyfoo
Registered an account, because I'm facing this issue now. It was working before I last updated to the latest version of FileZilla.

Now, whenever I try to Edit a file and use any editor (Notepad++ / Notepad etc), it returns the error:
"C:\Users\name\AppDate\Local\Temp\fz3temp-2\filename.extension" cannot be opened.

Folder "C:\Users\name\AppDate\Local\Temp\fz3temp-2" does not exist.
And when I hit this error, application automatically closes.

The last thing I remembered doing with the application was setting a queue to close it after it finished transferring a large file.

If it helps, I'm running Windows 10 20h2 if that helps.

And I've done an sfc scan - it didn't detect any issues. Also tried re-installing, it didn't solve the issue.

Re: view/edit with notepad++ not working

Posted: 2020-12-11 09:01
by botg
Please post screenshots of your configured file editing settings and file type associations.

Re: view/edit with notepad++ not working

Posted: 2020-12-11 16:03
by dannyfoo
I've managed to resolve the issue!

While I was uploading a large file, I selected the "Action after queue completion" to "None" .

Now, when I try to View / Edit any of the files, it'll launch the file in Notepad++ without issues. :mrgreen: