filezilla pro does not work on ubuntu 18.04 lts due to dependencies required x86_64-linux-gnu/libc.so.6

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
AndyPhy
500 Command not understood
Posts: 3
Joined: 2021-02-15 18:31
First name: Andrew
Last name: Brockman

filezilla pro does not work on ubuntu 18.04 lts due to dependencies required x86_64-linux-gnu/libc.so.6

#1 Post by AndyPhy » 2021-02-15 18:49

We just purchased FileZilla Pro, and installed the manual and stand-alone binaries into ~/Desktop. From a Ubuntu 18.04LTS machine (64bit), we read the manual and then tried to runt he executable, the following to reproduce the errors:

Code: Select all

(base) andrew@pragati-phykija-server:~/Desktop/FileZilla3/bin$ ./filezilla
./filezilla: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by ./filezilla)
./filezilla: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by /home/andrew/Desktop/FileZilla3/bin/../lib/libwx_baseu-3.0.so.0)
./filezilla: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by /home/andrew/Desktop/FileZilla3/bin/../lib/libsqlite3.so.0)
So, right now I am installing a VirtualBox VM of the latest Debian, and hopefully we can get it working on the VM... But this is really odd... Please can we not just have a pre-compile Filezilla Pro and allow us to compile and make with the more recent GNU compiler we have already pre-installed on our Ubuntu machine?

Or any advice on how to fix the dependency errors without having wide-reaching impacts on our stack?

Thanks!

User avatar
botg
Site Admin
Posts: 33352
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: filezilla pro does not work on ubuntu 18.04 lts due to dependencies required x86_64-linux-gnu/libc.so.6

#2 Post by botg » 2021-02-16 08:21

Our binaries are for the stable version of Debian or compatible. Ubuntu 18.04 is simply too old.

User avatar
boco
Contributor
Posts: 25437
Joined: 2006-05-01 03:28
Location: Germany

Re: filezilla pro does not work on ubuntu 18.04 lts due to dependencies required x86_64-linux-gnu/libc.so.6

#3 Post by boco » 2021-02-16 12:58

Linux Mint 19.x is the same. I'm just using the Windows version under Wine.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

AndyPhy
500 Command not understood
Posts: 3
Joined: 2021-02-15 18:31
First name: Andrew
Last name: Brockman

Re: filezilla pro does not work on ubuntu 18.04 lts due to dependencies required x86_64-linux-gnu/libc.so.6

#4 Post by AndyPhy » 2021-02-16 23:38

botg wrote:
2021-02-16 08:21
Our binaries are for the stable version of Debian or compatible. Ubuntu 18.04 is simply too old.
Thanks.

So now we've installed the latest Debian onto a Virtualbox guest. > transferred over the FileZilla pro and then:

Code: Select all

ab@debian:~/Desktop/FileZilla3/bin$ ./filezilla 
./filezilla: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
Which is at least a different error now, any ideas on how to fix this would really be appreciated.

AndyPhy
500 Command not understood
Posts: 3
Joined: 2021-02-15 18:31
First name: Andrew
Last name: Brockman

Re: filezilla pro does not work on ubuntu 18.04 lts due to dependencies required x86_64-linux-gnu/libc.so.6

#5 Post by AndyPhy » 2021-02-16 23:56

AndyPhy wrote:
2021-02-16 23:38
botg wrote:
2021-02-16 08:21
Our binaries are for the stable version of Debian or compatible. Ubuntu 18.04 is simply too old.
Thanks.

So now we've installed the latest Debian onto a Virtualbox guest. > transferred over the FileZilla pro and then:

Code: Select all

ab@debian:~/Desktop/FileZilla3/bin$ ./filezilla 
./filezilla: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
Which is at least a different error now, any ideas on how to fix this would really be appreciated.
Awesome, it finally works!

Solution:
sudo apt-get install libgtk2.0-0

Post Reply