Error 550 - Can't Access File

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Message
Author
da chicken
226 Transfer OK
Posts: 619
Joined: 2005-11-02 06:41

Re: Error 550 - Can't Access File

#16 Post by da chicken » 2008-06-29 04:14

Exactly right. :)

Glad I could help.

MiG
500 Command not understood
Posts: 1
Joined: 2006-10-18 11:28

Re: Error 550 - Can't Access File

#17 Post by MiG » 2008-07-31 22:43

da chicken wrote:Ok, here's an example.

Let's say I don't have a domain. A domain would make life much easier, but the steps are largely the same.
I have two servers with Win2k3 installed.
One server has a hostname (computer name) of FTP1. This is the server where FileZilla Server is installed.
The second server has a hostname of FILE2. This server has a directory where we want to keep files, D:\ftproot\.

Step 1: We go log in to FTP1, and we create a Windows local user account to use as a service account.

To create a local user account:
  • On FTP1, open Computer Management.
  • Expand Local Users and Groups.
  • Right-click Users and click New User.
  • In the User name box, type a name for the service account (for example, FileZillaServerService).
  • In the Password and Confirm password boxes, type the account's password, like "12345" (except use something secure).
  • Clear the User must change password at next logon check box.
  • Check the Password never expires and User cannot change password options because this is a service account.
  • Click Create
Step 2: Add the local user FTP1\FileZillaServerService to the local Administrators group (FTP1\Administrators). This is more permissions than are strictly necessary so I don't recommend it for security reasons, so if you want to lock it down properly you certainly can. I don't know what permissions FileZilla Server needs to operate so I'm going the easy route.

Step 3: Configure the FileZilla Server Service on FTP1 to start using the FTP1\FileZillaServerService account.

Step 4: Now let's go log in to the file server, FILE2. Create a Windows local user account with the exact same name and the exact same password as the one you created on FTP1. You should now have FileZillaServerService on FTP1 and FILE2, both with the exact same password.

Step 5: Turn on File Sharing on the directory D:\ftproot\. Give the share a name (ftproot is fine). Grant the local user FILE2\FileZillaServerService the Share Permission of Full Control, and the NTFS Permissions of Read, Read & Execute, Write, and Modify (granting Full Control is not necessary and carries security implications).

Step 6: Now go back to FTP1, and log on as FileZillaServerService. Open up Windows Explorer and browse to \\FILE2\. Right-click share we created (ftproot) and pick Map Network Drive.... Give it a drive letter. Now you can configure FileZilla Server in the Control Interface to use the mapped network drive. You should be able to access the network drive, create files and folders and so on. It shouldn't ask for a password or anything.

Warning: Mapped network drives are associated with user accounts when they're logged on, not with service accounts. It's very likely that if the user account FileZillaServerService is logged off the server that the network drive on FTP1 will no longer available. This will cause problems whenever you reboot FTP1 because you'll have to go log in again to get your mapped drive back most likely. The FileZilla Server, however, will already have started at that point, and may have thrown an error because the file server appears to be inaccessible.

These kinds of problems are some of the reasons why it's not recommended to do things this way. It will break, and probably often.
I came up with a similar solution, except for some reason it doesn't work here - empty directory showing up in the FTP client and no write access either. FZ is configured to give the user full access to the mapped network drive though.

In my case "FTP1" is a WinXP SP3 machine, "FILE2" a linux machine with SMB shares. The main user account on FTP1 has already been granted full access to the SMB shares on FILE2, and another program, Cobian Backup, happily writes its backups from FTP1 to FILE2. CB runs a service under that local account .\username, and I've changed the FZ service (through services.msc) to do the same thing. I've restarted FTP1's FZ service twice now, unfortunately to no avail. The firewall (FTP1) has been disabled for testing purposes.

What I'm not sure about is what else could cause FZ not to be able to access those network drives. The server is now running under the local user account, which *should* have resulted in full access through FTP.

francisco
503 Bad sequence of commands
Posts: 23
Joined: 2008-08-02 20:57
First name: Francisco
Last name: Flores

Re: Error 550 - Can't Access File

#18 Post by francisco » 2010-03-04 19:10

I have followed your steps and it works great!!!!!
Thank you.
I do have an issue that I am not sure how to solve it.
First, the settings you posted are the same as the one I followed, then I have set up two user (so far) and two folders within the ftproot folder.one user has full rights and the other I want to assign it full right to only one of these two folders.
The other folder, he should only be able to view.
Currently, within FileZilla, the 2nsuser is set up just to view folder2 but he can upload files there.
The settings seems not to apply.
How can I achieve this?
The goal is to have two folders within the FTPROOT. One folder is incoming files, the other is outgoing files.
The files that I want to list in 1stfolder should not be overwritten by the 2nduser. 2nduser should download the file from 1stfolder, make changes and upload it into the 2ndfolder. This way, users should have more control of what files have been
modified without compromising the original.
Please advice.

billegge
504 Command not implemented
Posts: 6
Joined: 2014-06-09 19:11
First name: Bill
Last name: Egge

Re: Error 550 - Can't Access File

#19 Post by billegge » 2015-03-25 18:10

I realize this thread is old but there is another cause which I recently found out. Another user simply had the file opened.

arvobowen
504 Command not implemented
Posts: 6
Joined: 2015-07-24 14:22
First name: Arvo
Last name: Bowen

Re: Error 550 - Can't Access File

#20 Post by arvobowen » 2015-07-24 14:39

So I ran into a little issue myself. Before I get started I should note that this works perfectly fine on Serv-U FTP server.

Some quick facts:
  • I have a domain (mydomain.local) and a user in that domain (FTPServer).
  • The FTPServer user is a member of two groups (Group1 and Group2).
  • Group1 has read/write access to a folder (\\myNASserver\myfolder1\subdir\).
  • Group2 has read/write access to a folder (\\myOtherNASserver\myfolder2\subdir\).
  • I have FileZilla Server setup as a service using the FTPServer user to run the service (logon).
  • The FileZilla Server service starts up and runs perfectly with no issues.
  • On FileZilla FTP Server UI I have a user created (User1).
  • User1 has a home directory (\\myNASserver\myfolder1) which is read only.
  • User1 has access to another directory (\\myNASserver\myfolder1\subdir) which is read/write)
Now for some reason it seems that everything works as expected with one exception... The FileZilla FTP Server does not recognize the group that the FTPServer is a member of. If I add read/write access to the folder (\\myNASserver\myfolder1\subdir\) for the user FTPServer (instead of just having the Group1 with read/write) then EVERYTHING works just like I want it to (perfectly!).

Why is FileZilla not recognizing the groups that the FTPServer user is a member of??? Once again, this works perfectly on Serv-U (currently the production environment).

Thanks for any help or advice on the issue!

User avatar
boco
Contributor
Posts: 25332
Joined: 2006-05-01 03:28
Location: Germany

Re: Error 550 - Can't Access File

#21 Post by boco » 2015-07-25 01:55

Please note that FileZilla Server does not integrate with Windows accounts. Inheritance of access privileges from Windows Groups to the individual User should work, as long as the user has no Deny tokens set. Network shares might need to be mapped two times: Once with Highest privileges and once without.

Windows Network is a mess... :cry:
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

arvobowen
504 Command not implemented
Posts: 6
Joined: 2015-07-24 14:22
First name: Arvo
Last name: Bowen

Re: Error 550 - Can't Access File

#22 Post by arvobowen » 2015-07-25 17:11

I'm not trying to integrate with a windows account. The user account that runs the FileZilla server has access to the shares it's trying to get to but it seems FileZilla does not recognize that fact. I don't use deny tokens/ACLs. I also have no use for mapped drives. I stay away from them because the user running the application is not used to log on to the server, it's just used to run the FileZilla application.

Any ideas why it's not working?

arvobowen
504 Command not implemented
Posts: 6
Joined: 2015-07-24 14:22
First name: Arvo
Last name: Bowen

Re: Error 550 - Can't Access File

#23 Post by arvobowen » 2015-07-27 12:54

Well it seems it was just a case of stupidity... I logged on to the server using the account I use to run the FTP server and tried to access the path I was getting errors on. I found that I could not access it. In the end it ended up being a windows rights issue after all.

Sorry for the confusion! Thanks for trying to help. :mrgreen:

Jean-Pierre Guiran
500 Command not understood
Posts: 1
Joined: 2020-11-09 13:39
First name: Jean-Pierre
Last name: Guiran

Re: Error 550 - Can't Access File

#24 Post by Jean-Pierre Guiran » 2020-11-09 13:43

I did a quick fix by deleting the file by accessing it in Dreamweaver. Select "external display"

Locked