File listing on Raiden servers

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
MortenCB
500 Command not understood
Posts: 4
Joined: 2004-03-10 14:55

File listing on Raiden servers

#1 Post by MortenCB » 2004-03-10 14:57

I have a problem when connecting to raiden ftp servers over ssl: I can't get file listing. It works with any other program, but filezilla won't do the directory listing.

I have heard from several others that they experience the same thing.

Is this a bug that someone could take a look at and fix?

User avatar
botg
Site Admin
Posts: 33352
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

#2 Post by botg » 2004-03-10 15:57

Hi,

please post some logs, there could be dozens of reasons for this problem.

MortenCB
500 Command not understood
Posts: 4
Joined: 2004-03-10 14:55

Log

#3 Post by MortenCB » 2004-03-10 23:36

When you login, you get all the normal welcome messages, and then it wants to list the contents of the login dir, and you get this:
---
Command: LIST
Response: 150 Opening ASCII data connection for ls /.
Error: Can't establish SSL connection
Error: Could not retrieve directory listing
Response: 226-free disk space under this directory : 15685 mb
Response: 226 Transfer finished successfully. Data connection closed .
---
I am logged in, but it can't do the listing.

This works, as I said, nicely in all other programs I have gotten my hands on.

The server runs Raiden (newest version) with explicit ssl turned on.

User avatar
botg
Site Admin
Posts: 33352
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

#4 Post by botg » 2004-03-11 08:59

Please post the complete logs since the problem can occur earlier. Please also enable everything on the debug page in the settings dialog of Filezilla.

MortenCB
500 Command not understood
Posts: 4
Joined: 2004-03-10 14:55

Full log

#5 Post by MortenCB » 2004-03-11 13:15

Here is a full debug-log of the login attempt. The ip-address has been exchanged with XXX.XXX.XXX.XXX, the username with XXX.

http://mortencb.cx/temp/filezilla-debuglog.rtf

MortenCB
500 Command not understood
Posts: 4
Joined: 2004-03-10 14:55

*Silence*

#6 Post by MortenCB » 2004-03-13 14:51

No answer?

I would really like this to be fixed, as now I can't use FileZilla, and I know a lot of others can't either.

User avatar
botg
Site Admin
Posts: 33352
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

#7 Post by botg » 2004-03-13 18:28

Well, it should work, everything looks normal. The only thing that I've noticed is that the server uses AES256-SHA as cipher.
I've access to another server which uses AES256-SHA as cipher and FileZilla doesn't work with it either. Yet I could not find out why it doesn't work.

Post Reply