Howto: Compiling FileZilla 3 under Windows

Moderator: Project members

Message
Author
FileGamer
450 Internal Error
Posts: 38
Joined: 2014-08-16 06:26

Re: Howto: Compiling FileZilla 3 under Windows

#166 Post by FileGamer » 2014-09-25 23:03

botg wrote:
- For installing GnuTLS, I needed the nettle-dev package.
That's odd. In particular the nettle-dev package is for Linux and not cross-compiled for Windows.
Something else. Even after installing wxWidgets 3.0.1, I can't issue the configure command for Filezilla because it says the requested build 3.0.1 can't be found as I'm still on 2.8. The latest lib packages I can find online are also 2.8.

kenh
500 Command not understood
Posts: 3
Joined: 2014-09-25 17:40

Re: Howto: Compiling FileZilla 3 under Windows

#167 Post by kenh » 2014-09-26 04:14

If it helps it all, I was able to solve the compiler hanging problems (under Windows) by getting rid of precompiled headers (I forget the configure option, but it was obvious when you look for it). There are other problems, though (to be detailed in another post).

FileGamer
450 Internal Error
Posts: 38
Joined: 2014-08-16 06:26

Re: Howto: Compiling FileZilla 3 under Windows

#168 Post by FileGamer » 2014-09-27 03:58

kenh wrote:If it helps it all, I was able to solve the compiler hanging problems (under Windows) by getting rid of precompiled headers (I forget the configure option, but it was obvious when you look for it). There are other problems, though (to be detailed in another post).
I'm compiling in Linux for Windows. The wxWidgets that installs is not 3.0.1 in the compiler's eyes, its 2.8 for some reason, and its keeping me from compiling Filezilla.

User avatar
botg
Site Admin
Posts: 31574
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Howto: Compiling FileZilla 3 under Windows

#169 Post by botg » 2014-09-27 16:32

FileGamer wrote: I'm compiling in Linux for Windows. The wxWidgets that installs is not 3.0.1 in the compiler's eyes, its 2.8 for some reason, and its keeping me from compiling Filezilla.
See https://wiki.filezilla-project.org/Cros ... _GNU/Linux for cross-compilation instructions.

FileGamer
450 Internal Error
Posts: 38
Joined: 2014-08-16 06:26

Re: Howto: Compiling FileZilla 3 under Windows

#170 Post by FileGamer » 2014-09-28 02:44

botg wrote:
FileGamer wrote: I'm compiling in Linux for Windows. The wxWidgets that installs is not 3.0.1 in the compiler's eyes, its 2.8 for some reason, and its keeping me from compiling Filezilla.
See https://wiki.filezilla-project.org/Cros ... _GNU/Linux for cross-compilation instructions.
Yes, that's the article I've been following. The problem comes up following those instructions. It just so happened that me talking about compiling in Linux poured into this topic from other posts I had here. Technically, it is for Windows, so I kept posting in this topic. Any idea how to fix this wxWidgets error?

User avatar
botg
Site Admin
Posts: 31574
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Howto: Compiling FileZilla 3 under Windows

#171 Post by botg » 2014-09-28 08:32

You're either not cross-compiling or you have downloaded and compiled and installed the wrong wx version.

FileGamer
450 Internal Error
Posts: 38
Joined: 2014-08-16 06:26

Re: Howto: Compiling FileZilla 3 under Windows

#172 Post by FileGamer » 2014-09-28 15:33

botg wrote:You're either not cross-compiling or you have downloaded and compiled and installed the wrong wx version.
I installed right from the cross compiling wiki page which was 3.0.1.

FileGamer
450 Internal Error
Posts: 38
Joined: 2014-08-16 06:26

Re: Howto: Compiling FileZilla 3 under Windows

#173 Post by FileGamer » 2014-09-29 01:01

FileGamer wrote:
botg wrote:You're either not cross-compiling or you have downloaded and compiled and installed the wrong wx version.
I installed right from the cross compiling wiki page which was 3.0.1.
When wxWidgets 3.0.1 installs, it sets the compatibility to 'yes' for wxWidgets 2.8. The Filezilla code requires 3.0.1 and above. This is the problem we're running into.

User avatar
botg
Site Admin
Posts: 31574
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Howto: Compiling FileZilla 3 under Windows

#174 Post by botg » 2014-09-29 07:28

The wxWidgets that installs is not 3.0.1 in the compiler's eyes, its 2.8 for some reason
When wxWidgets 3.0.1 installs, it sets the compatibility to 'yes' for wxWidgets 2.8. The Filezilla code requires 3.0.1 and above. This is the problem we're running into.
While it has some 2.8 compatibility, it still reports itself as 3.0.1. If at some other place 2.8 is being detected, it means that the 3.0.1 version has not been installed correctly.

FileGamer
450 Internal Error
Posts: 38
Joined: 2014-08-16 06:26

Re: Howto: Compiling FileZilla 3 under Windows

#175 Post by FileGamer » 2014-09-29 13:08

botg wrote:
The wxWidgets that installs is not 3.0.1 in the compiler's eyes, its 2.8 for some reason
When wxWidgets 3.0.1 installs, it sets the compatibility to 'yes' for wxWidgets 2.8. The Filezilla code requires 3.0.1 and above. This is the problem we're running into.
While it has some 2.8 compatibility, it still reports itself as 3.0.1. If at some other place 2.8 is being detected, it means that the 3.0.1 version has not been installed correctly.
Well, I followed what the wiki article says. How do I go about installing 3.0.1 "correctly" then?

User avatar
botg
Site Admin
Posts: 31574
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Howto: Compiling FileZilla 3 under Windows

#176 Post by botg » 2014-09-29 17:11

What's the output of the following three commands:

Code: Select all

which wx-config
wx-config --list
wx-config --cppflags

FileGamer
450 Internal Error
Posts: 38
Joined: 2014-08-16 06:26

Re: Howto: Compiling FileZilla 3 under Windows

#177 Post by FileGamer » 2014-09-29 22:44

botg wrote:What's the output of the following three commands:

Code: Select all

which wx-config
wx-config --list
wx-config --cppflags
which wx-config:

/usr/bin/wx-config

wx-config --list:

Default config is gtk2-unicode-release-2.8

Default config will be used for output

Alternate matches:
base-unicode-release-2.8

wx-config --cppflags:

-I/usr/lib/x86_64-linux-gnu/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__

User avatar
botg
Site Admin
Posts: 31574
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Howto: Compiling FileZilla 3 under Windows

#178 Post by botg » 2014-09-30 07:09

Yup. You didn't compile and install wx 3 correctly. In fact it doesn't seem to be there at all. Have you even setup your environment variables?

FileGamer
450 Internal Error
Posts: 38
Joined: 2014-08-16 06:26

Re: Howto: Compiling FileZilla 3 under Windows

#179 Post by FileGamer » 2014-09-30 13:14

botg wrote:Yup. You didn't compile and install wx 3 correctly. In fact it doesn't seem to be there at all. Have you even setup your environment variables?
I did whatever the wiki article says to do. Alright, well how do i uninstall whatever wx is there and install the correct wx 3?

User avatar
botg
Site Admin
Posts: 31574
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Howto: Compiling FileZilla 3 under Windows

#180 Post by botg » 2014-09-30 13:38

Let's start with your environment first.

Do you have the PATH, CPPFLAGS, LDFLAGS and PKG_CONFIG_PATH variables set as mentioned in the guide? Note that these variables need to be set anew if you ever close the shell.

Post Reply