Unable to generate preprocessed file (.i file) for FileZilla Server with Visual Studio13

Moderator: Project members

Post Reply
Message
Author
mitulshr
500 Command not understood
Posts: 4
Joined: 2015-07-24 17:06
First name: Mitul
Last name: Shrivastava

Unable to generate preprocessed file (.i file) for FileZilla Server with Visual Studio13

#1 Post by mitulshr » 2015-08-12 00:20

Hi All,

I am unable to generate preprocessor file (.i file) for FileZilla Server project.

I have applied following settings, but still its not working. I wanted to know if there is any specific settings required to enable this feature.

Steps :

1. Open Properties of "FileZilla Server Interface" Project.
2. Open C/C++ folder
3. Go to PreProcessor
4. Enable: Preprocessor to File === Yes (/P)
Enable: Preprocessor Supress Line Number === yes (/EP)

But, its not working please help!!

Note: I am building only "FileZilla Server Interface" project.(as I am unable to find OpenSSL code build with /MT flag.)

Thanks,
Mitul

User avatar
botg
Site Admin
Posts: 32554
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Unable to generate preprocessed file (.i file) for FileZilla Server with Visual Studio13

#2 Post by botg » 2015-08-12 07:29

Note: I am building only "FileZilla Server Interface" project.(as I am unable to find OpenSSL code build with /MT flag.)
The interface too makes use of OpenSSL. Don't search for /MT builds of OpenSSL, you won't likely find them. Build it yourself.
I am unable to generate preprocessor file (.i file) for FileZilla Server project.
Why do you want to preprocess to files?
But, its not working please help!!
Why is it not working?

mitulshr
500 Command not understood
Posts: 4
Joined: 2015-07-24 17:06
First name: Mitul
Last name: Shrivastava

Re: Unable to generate preprocessed file (.i file) for FileZilla Server with Visual Studio13

#3 Post by mitulshr » 2015-08-12 17:42

Hi,
Thanks for your quick response.

1. I am working on to compile OpenSSL with /MT flag

2. I am working on some experiment, and I found an issue. So, to replicate the issue on another system I want to get a pre-processed file, so that I dont have to do any environment settings on new system.

3. I think there might be a flag with is over writing the /PO /EP flag, and hence it is unable to generate the .i file.

Thanks,
Mitul

User avatar
botg
Site Admin
Posts: 32554
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Unable to generate preprocessed file (.i file) for FileZilla Server with Visual Studio13

#4 Post by botg » 2015-08-12 18:36

Does it say anything in the compiler output?

mitulshr
500 Command not understood
Posts: 4
Joined: 2015-07-24 17:06
First name: Mitul
Last name: Shrivastava

Re: Unable to generate preprocessed file (.i file) for FileZilla Server with Visual Studio13

#5 Post by mitulshr » 2015-08-12 20:25

No, its building successfully and binaries are getting generated.
But, as per MS documentation, if I provide /P and /EP flag binaries should not be generated.

User avatar
botg
Site Admin
Posts: 32554
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Unable to generate preprocessed file (.i file) for FileZilla Server with Visual Studio13

#6 Post by botg » 2015-08-12 22:17

The only thing I can think of is if you modify the settings for the Release build while compiling Debug, or vice-versa. Apart from that I'm completely out of ideas.

Post Reply