XP firewall once again!

Need help with FileZilla Server? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Locked
Message
Author
Tief
500 Command not understood
Posts: 2
Joined: 2007-10-17 01:33

XP firewall once again!

#1 Post by Tief » 2007-10-17 01:42

Add the server to the exceptions! People can enter the server but cannot do anything! When I disable the firewall everything works!

Vedurin
500 Command not understood
Posts: 1
Joined: 2007-10-17 04:17

#2 Post by Vedurin » 2007-10-17 04:19

Did you specify secondary ports ?
"Edit->Settings->Passive Mode Settings->Use custom Port range:"
Then you also have to open those ports in your FW.

User avatar
botg
Site Admin
Posts: 31379
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

#3 Post by botg » 2007-10-17 08:13

If only a single program is allowed to bypass the firewall, the firewall has been compromised and is just wasting resources.

If you don't want to disable your firewall, read http://filezilla-project.org/wiki/index ... figuration

Tief
500 Command not understood
Posts: 2
Joined: 2007-10-17 01:33

#4 Post by Tief » 2007-10-17 12:39

Vedurin wrote:Did you specify secondary ports ?
"Edit->Settings->Passive Mode Settings->Use custom Port range:"
Then you also have to open those ports in your FW.
Yeah I did this!
botg wrote:If only a single program is allowed to bypass the firewall, the firewall has been compromised and is just wasting resources.

If you don't want to disable your firewall, read http://filezilla-project.org/wiki/index ... figuration
Setting up FileZilla Server with Vista and Windows Firewall

If you are having problems with setting up FileZilla Server to run behind Windows Firewall (specifically, it fails on "List" and the client receives a "Failed to receive directory listing" error), you must add the FileZilla Server application to Windows Firewall's Exceptions list. To do this, follow these steps:
Open Windows Firewall under Control Panel.
Click on the link that says "Allow a program through Windows Firewall"
Click "Add program..."
Do NOT select "FileZilla Server Interface" from the list, instead click on "Browse..."
Locate the directory you installed FileZilla Server to (normally "C:\Program Files\FileZilla Server")
Double click or select "FileZilla server.exe" and press open (Once again, NOT "FileZilla Server Interface.exe")
Select "FileZilla server.exe" from the list and click "Ok"
Verify that "FileZilla server.exe" is added to the exceptions list and that it has a check mark in the box next to it
Press "Ok" to close the window

Passive mode should now work. If you are still having problems connecting (from another computer or outside the network) check your router settings.
Already done this.

It the damn firewall! If I disable it everythings ok, if I enable it that suddenly people cannot join properly etc.!

celeste
500 Command not understood
Posts: 1
Joined: 2007-10-29 00:25

windows firewall exeptions for filezilla server

#5 Post by celeste » 2007-10-29 00:35

Tief wrote:
Vedurin wrote:Did you specify secondary ports ?
"Edit->Settings->Passive Mode Settings->Use custom Port range:"
Then you also have to open those ports in your FW.
Yeah I did this!
botg wrote:If only a single program is allowed to bypass the firewall, the firewall has been compromised and is just wasting resources.

If you don't want to disable your firewall, read http://filezilla-project.org/wiki/index ... figuration
Setting up FileZilla Server with Vista and Windows Firewall

If you are having problems with setting up FileZilla Server to run behind Windows Firewall (specifically, it fails on "List" and the client receives a "Failed to receive directory listing" error), you must add the FileZilla Server application to Windows Firewall's Exceptions list. To do this, follow these steps:
Open Windows Firewall under Control Panel.
Click on the link that says "Allow a program through Windows Firewall"
Click "Add program..."
Do NOT select "FileZilla Server Interface" from the list, instead click on "Browse..."
Locate the directory you installed FileZilla Server to (normally "C:\Program Files\FileZilla Server")
Double click or select "FileZilla server.exe" and press open (Once again, NOT "FileZilla Server Interface.exe")
Select "FileZilla server.exe" from the list and click "Ok"
Verify that "FileZilla server.exe" is added to the exceptions list and that it has a check mark in the box next to it
Press "Ok" to close the window

Passive mode should now work. If you are still having problems connecting (from another computer or outside the network) check your router settings.
Already done this.

It the damn firewall! If I disable it everythings ok, if I enable it that suddenly people cannot join properly etc.!
I had the same problem. I was getting an error: 425 can't open data connection. I could log in, but couldn't access the folders. When I disabled the windows firewall, everything was fine. When enabled, nobody could connect. Finally I got it to work by doing what is quoted above.
Only I made a windows firewall exception for BOTH "FileZilla server.exe" AND "FileZillaServer.exe" . That worked for me.

-Celeste

hakiru
500 Command not understood
Posts: 1
Joined: 2011-09-27 10:02
First name: thomas

Re: XP firewall once again!

#6 Post by hakiru » 2011-09-27 10:06

I have the same problem on Windows XP SP3 (FileZilla Server is 0.9.39) :(
When I disabled the windows firewall, everything was fine. When enabled, nobody could connect (I tried it on Win7 and their firewall and it seems everything is ok).
I have correct exceptions for ports and for the program... but still it's not enough

Edited:
-------------------
(000028) 2011-09-27 11:37:37 - (not logged in) (192.168.0.1)> USER anonymous
(000028) 2011-09-27 11:37:37 - (not logged in) (192.168.0.1)> 331 Password required for anonymous
(000028) 2011-09-27 11:37:43 - (not logged in) (192.168.0.1)> PASS ******************
(000028) 2011-09-27 11:37:43 - (not logged in) (192.168.0.1)> 421 Temporarily banned for too many failed login attempts

I found the problem, my browser (Chrome 16.0.891.0) just tried reconnect connection as anonymous user... (I had set autoban),
but this is normal? how ignore or block anonymous connections without ban?

User avatar
boco
Contributor
Posts: 24009
Joined: 2006-05-01 03:28
Location: Germany

Re: XP firewall once again!

#7 Post by boco » 2011-09-27 13:16

Simply don't use Autoban (will be removed anyway). Unless you actually have an ''anonymous'' account, nobody will be able to connect as anonymous.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

roback33
500 Command not understood
Posts: 3
Joined: 2012-01-24 06:33

Re: XP firewall once again!

#8 Post by roback33 » 2012-01-24 06:39

Hi , anyone fixed this problem? I got the same troubles. If I switch off the windows firewall, I can connect to my server, however, with firewall on, I fail. I have the ports set to 50000 - 51000 and can see that the user tries to use for example 50017. I also have both FileZillaServer and FileZilla Server within my exceptions. Cant figure it out and dont wanna switch to different firewalls. Do I have to restart the server in order to get the exceptions to work?

User avatar
boco
Contributor
Posts: 24009
Joined: 2006-05-01 03:28
Location: Germany

Re: XP firewall once again!

#9 Post by boco » 2012-01-24 09:04

I also have both FileZillaServer and FileZilla Server within my exceptions.
And what about the exceptions for the ports?
Do I have to restart the server in order to get the exceptions to work?
Maybe, usually the fix for Microsoft's products.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

roback33
500 Command not understood
Posts: 3
Joined: 2012-01-24 06:33

Re: XP firewall once again!

#10 Post by roback33 » 2012-01-24 13:21

And what about the exceptions for the ports?
I've filezilla running on 20-21 and these are open in exeptions under self created "ftp" - programm AND in "lan area connections" under advanced is the FTP Server entry checked.
Dont know what else to do. If is definitely a firewall problem bcs if I switch it off, the website https://ftptest.net//#result can access my server, if its on, not anymore. Also a client shows the same behavior
The easiest way would be to change to another firewall, but I am kind of no-quiter person and want to solve this

User avatar
boco
Contributor
Posts: 24009
Joined: 2006-05-01 03:28
Location: Germany

Re: XP firewall once again!

#11 Post by boco » 2012-01-24 15:02

The data ports would have to be opened, too.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

roback33
500 Command not understood
Posts: 3
Joined: 2012-01-24 06:33

Re: XP firewall once again!

#12 Post by roback33 » 2012-01-25 10:50

The data ports would have to be opened, too.
tell me more please...

User avatar
boco
Contributor
Posts: 24009
Joined: 2006-05-01 03:28
Location: Germany

Re: XP firewall once again!

#13 Post by boco » 2012-01-25 11:24

I have the ports set to 50000 - 51000
These. Sometimes the Win firewall doesn't only require the FZ Server executable to have an exception rule, but all involved ports also. That means listening port (21) and data ports (50000-51000).

Port 20 is nonsense.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

minja_subota
500 Command not understood
Posts: 1
Joined: 2018-05-14 07:53
First name: Hrx
Last name: T

Re: windows firewall exeptions for filezilla server

#14 Post by minja_subota » 2018-05-14 07:58

celeste wrote:
2007-10-29 00:35
Tief wrote:
Vedurin wrote:Did you specify secondary ports ?
"Edit->Settings->Passive Mode Settings->Use custom Port range:"
Then you also have to open those ports in your FW.
Yeah I did this!
botg wrote:If only a single program is allowed to bypass the firewall, the firewall has been compromised and is just wasting resources.

If you don't want to disable your firewall, read http://filezilla-project.org/wiki/index ... figuration
Setting up FileZilla Server with Vista and Windows Firewall

If you are having problems with setting up FileZilla Server to run behind Windows Firewall (specifically, it fails on "List" and the client receives a "Failed to receive directory listing" error), you must add the FileZilla Server application to Windows Firewall's Exceptions list. To do this, follow these steps:
Open Windows Firewall under Control Panel.
Click on the link that says "Allow a program through Windows Firewall"
Click "Add program..."
Do NOT select "FileZilla Server Interface" from the list, instead click on "Browse..."
Locate the directory you installed FileZilla Server to (normally "C:\Program Files\FileZilla Server")
Double click or select "FileZilla server.exe" and press open (Once again, NOT "FileZilla Server Interface.exe")
Select "FileZilla server.exe" from the list and click "Ok"
Verify that "FileZilla server.exe" is added to the exceptions list and that it has a check mark in the box next to it
Press "Ok" to close the window

Passive mode should now work. If you are still having problems connecting (from another computer or outside the network) check your router settings.
Already done this.

It the damn firewall! If I disable it everythings ok, if I enable it that suddenly people cannot join properly etc.!
I had the same problem. I was getting an error: 425 can't open data connection. I could log in, but couldn't access the folders. When I disabled the windows firewall, everything was fine. When enabled, nobody could connect. Finally I got it to work by doing what is quoted above.
Only I made a windows firewall exception for BOTH "FileZilla server.exe" AND "FileZillaServer.exe" . That worked for me.

-Celeste
When in pasive mode, added both as an exception in WinXP and it works. Thanks!

User avatar
boco
Contributor
Posts: 24009
Joined: 2006-05-01 03:28
Location: Germany

Re: XP firewall once again!

#15 Post by boco » 2018-05-14 22:28

Windows XP is no longer supported. Closed.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

Locked