FileFileZilla Server 1.0.0-rc4 - Start minimized

Need help with FileZilla Server? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
c2d2
500 Command not understood
Posts: 3
Joined: 2021-07-20 17:37

FileFileZilla Server 1.0.0-rc4 - Start minimized

#1 Post by c2d2 » 2021-07-20 17:49

I'm using FileZilla Server for years (with heavy traffic).
For now with new RC version I have set Minimum TLS version to 3 (hope it is TLS1.3) - please confirm? (with older I had TLS1.2 - everything was ok - moved to the new RC, because of possibility to turn on 1.3)
Anyway please add/correct function Start minimized (to tray) - with previous version (stable) I was watching icon in tray, when it was changed to green I knew, that someone is here.

oibaf
500 Command not understood
Posts: 5
Joined: 2021-07-16 21:02
First name: Fabio
Last name: Alemagna
Contact:

Re: FileFileZilla Server 1.0.0-rc4 - Start minimized

#2 Post by oibaf » 2021-07-20 19:50

The option to minimize the admin window to the tray is already in the pipeline and will be available in one of the next releases.

User avatar
boco
Contributor
Posts: 25590
Joined: 2006-05-01 03:28
Location: Germany

Re: FileFileZilla Server 1.0.0-rc4 - Start minimized

#3 Post by boco » 2021-07-20 19:58

Where did you set that? AFAIK, the "Minimum TLS version" does not exist in 1.x at all.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

c2d2
500 Command not understood
Posts: 3
Joined: 2021-07-20 17:37

Re: FileFileZilla Server 1.0.0-rc4 - Start minimized

#4 Post by c2d2 » 2021-07-20 21:20

FileZilla Server.xml
<Item name="Minimum TLS version" type="numeric">3</Item>

oibaf
500 Command not understood
Posts: 5
Joined: 2021-07-16 21:02
First name: Fabio
Last name: Alemagna
Contact:

Re: FileFileZilla Server 1.0.0-rc4 - Start minimized

#5 Post by oibaf » 2021-07-20 22:24

c2d2 wrote:
2021-07-20 21:20
FileZilla Server.xml
<Item name="Minimum TLS version" type="numeric">3</Item>
That file belongs to the old server, and although the installation procedure converts the old config into the new one (spread over many different files, each with its purpose), that specific configuration element was not being converted.

The new server will have support for minimum TLS version starting from a future release, and that parameter will be converted as well. It's also going to be adjustable through the Admin UI. Its minimum is set to v1.2, though.

User avatar
boco
Contributor
Posts: 25590
Joined: 2006-05-01 03:28
Location: Germany

Re: FileFileZilla Server 1.0.0-rc4 - Start minimized

#6 Post by boco » 2021-07-20 22:29

FileZilla Server 1.x does not use that file anymore. Your old settings have been imported into the new configuration.

If you run the server as program, it's in: %LOCALAPPDATA%\filezilla-server

Running as service uses : %Systemroot%\System32\config\systemprofile\AppData\Local\filezilla-server
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

c2d2
500 Command not understood
Posts: 3
Joined: 2021-07-20 17:37

Re: FileFileZilla Server 1.0.0-rc4 - Start minimized

#7 Post by c2d2 » 2021-07-21 06:59

Ok thank you for explanations.
Changed to <tls_mode>3</tls_mode> - seems to work (I'm able to connect).

Already one user reported, that he can't connect. His username (on server) was Xyz, but he was always using xyz - with old version there was no problem. Now he was not able to connect. :-)

oibaf
500 Command not understood
Posts: 5
Joined: 2021-07-16 21:02
First name: Fabio
Last name: Alemagna
Contact:

Re: FileFileZilla Server 1.0.0-rc4 - Start minimized

#8 Post by oibaf » 2021-07-21 08:30

c2d2 wrote:
2021-07-21 06:59
Changed to <tls_mode>3</tls_mode> - seems to work (I'm able to connect).
That is not the TLS version. RC4 doesn't support setting the minimum TLS version, but TLS v1.3 will be negotiated if both the client and the server support it. Wait for a future release if you want to set the minimum TLS version.

Post Reply