FileZilla Forums

Welcome to the official discussion forums for FileZilla
Donate to project
It is currently 2014-04-24 18:12

All times are UTC




Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: 2009-09-09 00:31 
Offline
500 Command not understood

Joined: 2009-09-09 00:11
Posts: 1
I have Windows RTM installed on my computer and I have allowed through the firewall FileZilla. I have installed the client on my laptop and try to connect but I never get a connection. As soon as I turn off the firewall everything works as it should. Does anybody have an idea on what works. I even read in one persons post was to open port 111 for TCP and that did not work either. :cry: So any help would be great !!!!!!


Top
 Profile  
 
PostPosted: 2009-09-09 00:35 
Offline
226 Transfer OK

Joined: 2008-12-30 10:30
Posts: 392
Location: In a small white padded room.
Opening port 111 makes no sense to me, but you will need to open a range of ports for passive mode iirc.

Have you seen this? Network Configuration

_________________
http://jdrrant.blogspot.com/ - CODEpendent Blog


Top
 Profile  
 
PostPosted: 2009-09-13 14:29 
Offline
500 Command not understood

Joined: 2009-09-07 18:51
Posts: 3
same here, no chance for Filezilla Server with windows 7 ....

Is there any workaround for filezilla server under windows 7?


Top
 Profile  
 
PostPosted: 2009-09-14 14:56 
Offline
504 Command not implemented

Joined: 2009-09-14 14:51
Posts: 9
i have filezilla server on my windows 7 and the filezilla.exe is what you have to allow through the firewall not the filezilla server interface. for the port forwarding you have to set port 21 (which is the ftp port.). hope this helps


Top
 Profile  
 
PostPosted: 2009-09-14 20:39 
Offline
504 Command not implemented

Joined: 2009-08-26 11:57
Posts: 6
Filezilla worked fine for me until my ISP cut me off for 24 hrs
I'm running Windoze 7 RTM
Kaspersky 8.0 for Windows 7
Windows firewall is disabled
Here is the log:

Status: Connecting to 127.0.0.1:21...
Status: Connection established, waiting for welcome message...
Response: 220-FileZilla Server version 0.9.33 beta
Response: 220-written by Tim Kosse (Tim.Kosse@gmx.de)
Response: 220 Please visit http://sourceforge.net/projects/filezilla/
Command: USER wobblymatt
Response: 331 Password required for wobblymatt
Command: PASS *******
Response: 230 Logged on
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/" is current directory.
Status: Directory listing successful




Status: Connecting to 192.168.1.1:21...
Status: Connection attempt failed with "ECONNREFUSED - Connection refused by server".
Error: Could not connect to server
Status: Waiting to retry...
Status: Connecting to 192.168.1.1:21...
Status: Connection attempt failed with "ECONNREFUSED - Connection refused by server".
Error: Could not connect to server






As you can see I can connect to localhost but not my router 'wrt54gl with custom firmware from my ISP (Nomotech Wimax) nore can anyone else
I cannot access my surveillance camera from the exterior anymore.
Everything worked fine last week
I have allowed ports 20 and 21 in the router
I have a static IP and dyndns.org finds my IP straight away
HELP!!!!!!!


Top
 Profile  
 
PostPosted: 2009-09-14 20:54 
Offline
504 Command not implemented

Joined: 2009-08-26 11:57
Posts: 6
Heres another one:


Status: Resolving address of xxxxxxxxxx.dyndns.org
Status: Connecting to xxx.xxx.xxx.xxx:21...
Status: Connection attempt failed with "ECONNREFUSED - Connection refused by server".
Error: Could not connect to server


Top
 Profile  
 
PostPosted: 2009-09-14 21:46 
Offline
Site Admin
User avatar

Joined: 2004-02-23 20:49
Posts: 22557
Simply disable that broken firewall.


Top
 Profile  
 
PostPosted: 2009-09-14 21:49 
Offline
226 Transfer OK

Joined: 2008-12-30 10:30
Posts: 392
Location: In a small white padded room.
wobblymatt wrote:
I have allowed ports 20 and 21 in the router


dyndns and 192.168.1.1 are the same. They both go to your router, so until it's configured properly, neither will work. You have to setup port forwarding. I have no idea what you mean by 'allowed'.

You say you have Windows Firewall turned off. You're sure about this? Is Kaspersky also a firewall? I only know about their virus scanners, but most companies put out firewalls too. If so, is this disabled?

If FileZilla server isn't configured to listen on the proper network interface (probably 192.168.1.something), it won't work even if the router is properly configured.

Port 20 is not for FTP, so you can stop 'allowing' for that.

If you didn't specify a range of passive ports, it's not going to work either. Did you read Network Configuration?

http://www.portforward.com/ can help you with port forwarding on various routers/firewalls.

_________________
http://jdrrant.blogspot.com/ - CODEpendent Blog


Top
 Profile  
 
PostPosted: 2009-09-15 19:43 
Offline
504 Command not implemented

Joined: 2009-08-26 11:57
Posts: 6
I managed to sort that one out because when my ISP reset my router the port forward stayed saved in it, However it changed my PC's IP address by one digit.. So I didnt notice it..

Now I have another problem which I have no idea if it has anything to do with Windows 7, however I'll post the log, hoping someone can help me :?
This is what happens when someone tries to connect to my server from outside my home network:


[color=#00BF40](000030) 9/15/2009 21:22:46 PM - (not logged in) ()> Connected, sending welcome message...
(000030) 9/15/2009 21:22:46 PM - (not logged in) ()> 220-FileZilla Server version 0.9.33 beta
(000030) 9/15/2009 21:22:46 PM - (not logged in) ()> 220-written by Tim Kosse (Tim.Kosse@gmx.de)
(000030) 9/15/2009 21:22:46 PM - (not logged in) ()> 220 Please visit http://sourceforge.net/projects/filezilla/
(000030) 9/15/2009 21:22:49 PM - (not logged in) ()> USER thierry
(000030) 9/15/2009 21:22:49 PM - (not logged in) ()> 331 Password required for thierry
(000030) 9/15/2009 21:22:59 PM - (not logged in) ()> PASS ********
(000030) 9/15/2009 21:22:59 PM - thierry ()> 230 Logged on
(000030) 9/15/2009 21:22:59 PM - thierry ()> SYST
(000030) 9/15/2009 21:22:59 PM - thierry ()> 215 UNIX emulated by FileZilla
(000030) 9/15/2009 21:22:59 PM - thierry ()> FEAT
(000030) 9/15/2009 21:22:59 PM - thierry ()> 211-Features:
(000030) 9/15/2009 21:22:59 PM - thierry ()> MDTM
(000030) 9/15/2009 21:22:59 PM - thierry ()> REST STREAM
(000030) 9/15/2009 21:22:59 PM - thierry ()> SIZE
(000030) 9/15/2009 21:22:59 PM - thierry ()> MLST type*;size*;modify*;
(000030) 9/15/2009 21:22:59 PM - thierry ()> MLSD
(000030) 9/15/2009 21:22:59 PM - thierry ()> UTF8
(000030) 9/15/2009 21:22:59 PM - thierry ()> CLNT
(000030) 9/15/2009 21:22:59 PM - thierry ()> MFMT
(000030) 9/15/2009 21:22:59 PM - thierry ()> 211 End
(000030) 9/15/2009 21:23:00 PM - thierry ()> PWD
(000030) 9/15/2009 21:23:00 PM - thierry ()> 257 "/" is current directory.
(000030) 9/15/2009 21:23:00 PM - thierry ()> TYPE I
(000030) 9/15/2009 21:23:00 PM - thierry ()> 200 Type set to I
(000030) 9/15/2009 21:23:00 PM - thierry ()> PASV
(000030) 9/15/2009 21:23:00 PM - thierry ()> 227 Entering Passive Mode ()
(000030) 9/15/2009 21:23:01 PM - thierry ()> MLSD
(000030) 9/15/2009 21:23:10 PM - thierry ()> 425 Can't open data connection.
[/color]




Can eneyone tell me what this means because I've disactivated Kaspersky and Windoze firewall is swithed off as well.
What does MLSD mean as well?
Everything worked fine last week :roll:


Top
 Profile  
 
PostPosted: 2009-09-15 19:48 
Offline
504 Command not implemented

Joined: 2009-08-26 11:57
Posts: 6
This is what happens from within my home network:



Status: Resolving address of xxx.dyndns.org
Status: Connecting to :21...
Status: Connection established, waiting for welcome message...
Response: 220-FileZilla Server version 0.9.33 beta
Response: 220-written by Tim Kosse (Tim.Kosse@gmx.de)
Response: 220 Please visit http://sourceforge.net/projects/filezilla/
Command: USER matt
Response: 331 Password required for matt
Command: PASS *******
Response: 230 Logged on
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/" is current directory.
Status: Directory listing successful




Why? :(


Top
 Profile  
 
PostPosted: 2009-09-15 20:02 
Online
226 Transfer OK
User avatar

Joined: 2006-05-01 03:28
Posts: 19663
Location: Germany
Quote:
(000030) 9/15/2009 21:23:10 PM - thierry ()> 425 Can't open data connection.
Still something blocking the transfer connection (Passive port range). As you deleted all useful information, we're unable to assist you further.

_________________
### BEGIN SIGNATURE BLOCK ###
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
All support requests per PM will be ignored!
### END SIGNATURE BLOCK ###


Top
 Profile  
 
PostPosted: 2009-09-15 20:33 
Offline
504 Command not implemented

Joined: 2009-08-26 11:57
Posts: 6
Sorry, but I only deleted the external IP adresses because I don't want to give them out


Top
 Profile  
 
PostPosted: 2009-09-16 12:33 
Offline
226 Transfer OK

Joined: 2008-12-30 10:30
Posts: 392
Location: In a small white padded room.
When using a port forward, it might be a good idea to use a static internal IP for your machine too. You may be able to configure the DHCP server to always give you the same address, or tell it to ignore a certain range of IPs and assign your machine one of those statically.

What does http://ftptest.net/ say?

I agree with boco and botg. Either your router is borked and is sabotaging your connections, or it isn't configured properly. I suggest you reset your routers configuration back to the factory settings, and follow the Network Configuration guide step by step.

_________________
http://jdrrant.blogspot.com/ - CODEpendent Blog


Top
 Profile  
 
PostPosted: 2009-09-16 16:30 
Offline
504 Command not implemented

Joined: 2009-08-26 11:57
Posts: 6
Problem solved!!!

I just re-installed filezilla, used the same ports and settings et voila!
Working fine now so it wasn't Windoze 7 or Kaspersky.

Thanks for the responses :P


Top
 Profile  
 
PostPosted: 2011-06-30 19:54 
Offline
503 Bad sequence of commands
User avatar

Joined: 2009-01-10 11:19
Posts: 19
Location: Scandinavia
Sorry for re-bumping, but I need help.
Running W7 Enterprise on two LAN computers.

Server: 192.168.1.10
Client: 192.168.1.11

Added exception for 'Filezilla server.exe' on server.
Still, I can't connect from client.
If I completely disable the Windoze firewall, I can connect.
No exception rules will work though.

What's the catch here?
Running latest Filezilla Server.


EDIT:
Please disregard from this thread. I finally nailed my issue.
I have a "symlink" (using Microsoft utility junction.exe) "C:\P\" -> "C:\Program files\".
I'm so used to entering C:\P\.. so I did this in my exception.
Obviously, using junction/symlink shortcut will make W7 Firewall malfunction.

SOLVED!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: boco and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Dedicated server provided by Artmotion.
Forum sponsored by Everyware.ch.
Powered by phpBB® Forum Software © phpBB Group