Server restart - "Protocol error: Auth failed"

Need help with FileZilla Server? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
JeremyP99
500 Syntax error
Posts: 15
Joined: 2010-03-03 20:19
First name: Jeremy
Last name: Poynton

Server restart - "Protocol error: Auth failed"

#1 Post by JeremyP99 » 2010-03-08 21:11

Thanks to assistance from Peregate I was at last able to add a user login and password, and give them access to a folder. Transfer by a friend across the pond worked just fine. Restarted the server just now and got this message

Protocol error: Auth failed, closing connection.
Connection to server closed.


Shut it down, restarted the server service, restarted the server, and the same happens.

What happened? How do I fix this one?!

User avatar
botg
Site Admin
Posts: 32474
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Server restart - "Protocol error: Auth failed"

#2 Post by botg » 2010-03-08 22:38

Trying to connect to the administration port using the wrong password.

JeremyP99
500 Syntax error
Posts: 15
Joined: 2010-03-03 20:19
First name: Jeremy
Last name: Poynton

Re: Server restart - "Protocol error: Auth failed"

#3 Post by JeremyP99 » 2010-03-09 08:47

botg wrote:Trying to connect to the administration port using the wrong password.
I haven't changed the password, and it was all working. Simply restarted the server. Now I can't edit the settings, as the options are disabled, and the error message just repeats itself.

What to do? Start all over, again?!

User avatar
botg
Site Admin
Posts: 32474
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Server restart - "Protocol error: Auth failed"

#4 Post by botg » 2010-03-09 19:06

See the file menu and manually connect again using the actual administration password.

JeremyP99
500 Syntax error
Posts: 15
Joined: 2010-03-03 20:19
First name: Jeremy
Last name: Poynton

Re: Server restart - "Protocol error: Auth failed"

#5 Post by JeremyP99 » 2010-03-09 21:36

botg wrote:See the file menu and manually connect again using the actual administration password.
Yes, working again, seem to be flying on a wing and a prayer at the moment, but am sure it will all become clear
in the fullness of time. Success in that I've had some uploads.

Is there any guidance on what needs to be done in the Advanced Settings for the W7 firewall? I'm thinking of
the incoming rules. I have some set for Inbound Rules, have no idea whether they are necessary, but am loath
to fix something that isn't broke.

Thanks a lot for your assistance, it's much appreciated. This is a project I have been meaning to do for a few
years, but, life kept getting in the way, as it does.

User avatar
botg
Site Admin
Posts: 32474
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Server restart - "Protocol error: Auth failed"

#6 Post by botg » 2010-03-09 23:00

See the Network Configuration guide for firewall configuration instructions.

JeremyP99
500 Syntax error
Posts: 15
Joined: 2010-03-03 20:19
First name: Jeremy
Last name: Poynton

Re: Server restart - "Protocol error: Auth failed"

#7 Post by JeremyP99 » 2010-03-10 11:11

botg wrote:See the Network Configuration guide for firewall configuration instructions.
Yes - however, nothing is stated as to whether you need to create inbound rules for custom ports defined for passive transfers, and the info re adding a program is for XP, not the Windows 7 firewall; so it is rather hit and miss. For example, in order to make available my network shares, which I can't make visible on the machine I am referring to here, I have replicated all settings onto the other machine, using port 21212 for ftp, and cannot make a connection at all! The Port Forward checker program tells me the port is open, but I just get a timeout from ftptest.net, and indeed, when invoked by a browser on the "main" machine.

The advanced setting for the Windows 7 firewall allows you to define from Program or Port; there is no indication as to which of these should be used; similarly, using Port, should this be bound to the Filezilla Server? I'm familiar with basic firewall config stuff for Unix boxes, but it is not clear to me how the Server Program should be added as a new Inbound rule to make things work.

Cypress
226 Transfer OK
Posts: 121
Joined: 2008-09-13 19:39
First name: J

Re: Server restart - "Protocol error: Auth failed"

#8 Post by Cypress » 2010-03-10 11:59

JeremyP99 wrote:Yes - however, nothing is stated as to whether you need to create inbound rules for custom ports defined for passive transfers, and the info re adding a program is for XP, not the Windows 7 firewall; so it is rather hit and miss.
Read the quote below from the net config guide :?
http://wiki.filezilla-project.org/Network_Configuration#Passive_mode_2 wrote:If you do not want to allow incoming connections on all ports, or if you have a NAT router, you need to tell FileZilla Server to use a specific range of ports for passive mode connections. You will have to open these ports in your firewall.
---
JeremyP99 wrote:The advanced setting for the Windows 7 firewall allows you to define from Program or Port; there is no indication as to which of these should be used; similarly, using Port, should this be bound to the Filezilla Server?
Either way.. allowing the program itself would be simplest(1 rule vs 2 or more rules).

JeremyP99
500 Syntax error
Posts: 15
Joined: 2010-03-03 20:19
First name: Jeremy
Last name: Poynton

Re: Server restart - "Protocol error: Auth failed"

#9 Post by JeremyP99 » 2010-03-10 12:15

Cypress wrote:
JeremyP99 wrote:Yes - however, nothing is stated as to whether you need to create inbound rules for custom ports defined for passive transfers, and the info re adding a program is for XP, not the Windows 7 firewall; so it is rather hit and miss.
Read the quote below from the net config guide :?
http://wiki.filezilla-project.org/Network_Configuration#Passive_mode_2 wrote:If you do not want to allow incoming connections on all ports, or if you have a NAT router, you need to tell FileZilla Server to use a specific range of ports for passive mode connections. You will have to open these ports in your firewall.
---
JeremyP99 wrote:The advanced setting for the Windows 7 firewall allows you to define from Program or Port; there is no indication as to which of these should be used; similarly, using Port, should this be bound to the Filezilla Server?
Either way.. allowing the program itself would be simplest(1 rule vs 2 or more rules).
OK. I have three inbound rules defined, one automatically for the Server, for all protocols and all ports, and then a TCP and a UDP rule defined for Port 21, but not linked to the server. Are these two rules unnecessary, in that "all ports" and "all protocols" are defined for the server program?

Cypress
226 Transfer OK
Posts: 121
Joined: 2008-09-13 19:39
First name: J

Re: Server restart - "Protocol error: Auth failed"

#10 Post by Cypress » 2010-03-10 12:39

JeremyP99 wrote:OK. I have three inbound rules defined, one automatically for the Server, for all protocols and all ports, and then a TCP and a UDP rule defined for Port 21, but not linked to the server. Are these two rules unnecessary, in that "all ports" and "all protocols" are defined for the server program?
Yes, 2 extra should be unnecessary. Other thoughts -> you should only need TCP.

JeremyP99
500 Syntax error
Posts: 15
Joined: 2010-03-03 20:19
First name: Jeremy
Last name: Poynton

Re: Server restart - "Protocol error: Auth failed"

#11 Post by JeremyP99 » 2010-03-10 12:47

Cypress wrote:
JeremyP99 wrote:OK. I have three inbound rules defined, one automatically for the Server, for all protocols and all ports, and then a TCP and a UDP rule defined for Port 21, but not linked to the server. Are these two rules unnecessary, in that "all ports" and "all protocols" are defined for the server program?
Yes, 2 extra should be unnecessary. Other thoughts -> you should only need TCP.
Excellent, will try with just the automated server entry. As an side, I'm using ftptest.net to test access - and am being asked to log in every time I change directory. Is that normal? An option?

Many thanks for your advice!

JeremyP99
500 Syntax error
Posts: 15
Joined: 2010-03-03 20:19
First name: Jeremy
Last name: Poynton

Re: Server restart - "Protocol error: Auth failed"

#12 Post by JeremyP99 » 2010-03-10 12:47

JeremyP99 wrote:
Cypress wrote:
JeremyP99 wrote:OK. I have three inbound rules defined, one automatically for the Server, for all protocols and all ports, and then a TCP and a UDP rule defined for Port 21, but not linked to the server. Are these two rules unnecessary, in that "all ports" and "all protocols" are defined for the server program?
Yes, 2 extra should be unnecessary. Other thoughts -> you should only need TCP.
Excellent, will try with just the automated server entry. As an side, I'm using ftptest.net to test access - and am being asked to log in every time I change directory. Is that normal? An option?

Many thanks for your advice!
Sorry - ftptest to check the connection, browser (firefox) to access.

Cypress
226 Transfer OK
Posts: 121
Joined: 2008-09-13 19:39
First name: J

Re: Server restart - "Protocol error: Auth failed"

#13 Post by Cypress » 2010-03-10 14:34

JeremyP99 wrote:Excellent, will try with just the automated server entry. As an side, I'm using ftptest.net to check the connection. browser (firefox) to access - and am being asked to log in every time I change directory. Is that normal? An option?
Many thanks for your advice!
So your post should look like the quote above if you understood what an edit button is for?

Ask firefox?

User avatar
boco
Contributor
Posts: 24789
Joined: 2006-05-01 03:28
Location: Germany

Re: Server restart - "Protocol error: Auth failed"

#14 Post by boco » 2010-03-10 15:15

and am being asked to log in every time I change directory. Is that normal?
Yes, can happen with browsers, which will ask the password for every new connection unless you save it. For Firefox I recommend the FireFTP add-on.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

Post Reply