FileZilla Forums

Welcome to the official discussion forums for FileZilla
Donate to project
It is currently 2014-04-23 23:19

All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: 2010-05-16 03:23 
Offline
500 Command not understood

Joined: 2010-05-16 02:27
Posts: 5
I have installed Filezilla on two computers on my office LAN. For discussion, we'll call them \\Alpha (192.168.1.5 on LAN) and \\Beta (192.168.1.65 on LAN). Everything works perfectly on \\Alpha (even connecting from outside the LAN, but I can't connect to \\Beta even from inside the office LAN

\\Alpha is listening on Port 21. \\Beta is listening on Port 2121.
\\Alpha and \\Beta passive settings are both set to default.

My office router port forwarding is set as follows:
* TCP Port 21 is forwarded to \\Alpha
* TCP Ports 10000 to 11000 are forwarded to \\Alpha
* TCP Port 2121 is forwarded to \\Beta
* TCP Port 11001 to 12000 are forwarded to \\Beta

Not only am I unable to connect to \\Beta from home, I can't even connect to \\Beta from within my office LAN (using 192.168.1.65:2121 as the address). I can't even connect to 127.0.0.1:2121 while on \\Beta.

I've looked at the AVG firewall running on \\Beta and it seems to be set correctly. The Filezilla Server application is set to "allow for all.

What am I doing wrong? I have read the FAQ at the top of this forum, including these statements:

# I'm behind a firewall and nobody can connect to my server or transfer files / directory listings
You have to configure your firewall to allow incoming connections on the ftp port (default: 21), as well as allowing outgoing connections from the server. FileZilla Server tries to use a port one less than the ftp port for outgoing connections. If that fails it tries to use a port one larger than the ftp port and after that it requests a port from windows. It may be best to allow all outgoing connections from the server.
Further you have to allow a port range for incoming connections for passive mode transfers. You can specify this port range on the "passive mode settings" page in the settings dialog in the server interface. In most cases, a range like 5000-5100 is sufficient.
With certain firewalls, it may be possible that FileZilla can't determinate the external IP address. In this case you have to enter the IP address (or your host name) on the passive mode page in the settings dialog. In case you've a dynamic IP (most dialup users), you can also chose to retrieve the ip address from a website.

# I'm behind a router and nobody can connect to my server or transfer files / directory listings
You have to configure your router to forward the ftp port (default: 21) to the server machine.
Further you have to forward a port range for passive mode transfers. You can specify this port range on the "passive mode settings" page in the settings dialog in the server interface. In most cases, a range like 5000-5100 is sufficient.
Most likely, FileZilla can't determinate the external IP address if behind a router. In this case you have to enter the IP address (or your host name) on the passive mode page in the settings dialog. In case you've a dynamic IP (most dialup users), you can also chose to retrieve the ip address from a website.


I've read and re-read them and checked and re-checked my settings on Filezilla Server on \\Beta, the firewall on \\Beta and the office router. Obviously, I'm doing something WRONG, but I'll be darned if I can see what it is. Can you?


Top
 Profile  
 
PostPosted: 2010-05-16 08:49 
Offline
Site Admin
User avatar

Joined: 2004-02-23 20:49
Posts: 22556
Try uninstalling the firewall, does that make any difference?


Top
 Profile  
 
PostPosted: 2010-05-16 15:14 
Offline
500 Command not understood

Joined: 2010-05-16 02:27
Posts: 5
I didn't uninstall my firewall (which would require uninstalling my entire AVG antivirus), but I did stop the firewall, then I tried to reach \\Beta from another pc on the same LAN. The result was the same: timeout waiting for a connection that never happens. I double checked the status of the Filezilla service (Control Panel, Admin Settings, Services) on \\Beta. It was and is running. A screenshot of my FZ port setting is below. What am I overlooking?
Image


Top
 Profile  
 
PostPosted: 2010-05-16 17:40 
Offline
Site Admin
User avatar

Joined: 2004-02-23 20:49
Posts: 22556
Have you accidentally set the administration port to be identical to the listening port?


Top
 Profile  
 
PostPosted: 2010-05-16 19:09 
Offline
500 Command not understood

Joined: 2010-05-16 02:27
Posts: 5
Nope. Admin port on \\Beta (and \\Alpha) set to 14147.


Top
 Profile  
 
PostPosted: 2010-05-16 19:22 
Offline
500 Command not understood

Joined: 2010-05-16 02:27
Posts: 5
FIXED... grrr. :evil:

Somehow I was running TWO firewalls on \\Beta. I knew I was running the firewall that is part of AVG Antivirus, but did not realize that the Windows Firewall had not been disabled when the AVG firewall was installed. My previous experience with AVG is that it does that (disables the default Windows firewall when AVG is installed). With the Windows Firewall disabled, it works just fine -- and fast.

Stupid,stupid, stupid, stupid :oops:


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: Bing [Bot], Holdstrong and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Dedicated server provided by Artmotion.
Forum sponsored by Everyware.ch.
Powered by phpBB® Forum Software © phpBB Group